summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-07-07 16:17:57 +0000
committerDenys Dmytriyenko <denys@konsulko.com>2022-07-11 19:56:28 +0000
commit32bc374d3ab668a00dcd3083613d51f0ae59398d (patch)
tree174dded92db45cc5b2058c45e386b5b8217d628e /recipes-graphics
parentbca7a3095f8f39ee685dba7dd23581e767a765ad (diff)
weston-terminal-conf: add systemd-sandboxed demo configuration
Add a secondary .desktop file for weston-terminal to demonstrate new applaunchd systemd_manager with sandboxing capabilities. The sandboxing example enables PrivateNetwork - only loopback interface is available with localhost access only, easy to verify in the terminal Bug-AGL: SPEC-4466 Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Change-Id: Ib17880050056a2801f03bcc54caef921e8bdb516
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/weston-terminal-conf.bb13
-rw-r--r--recipes-graphics/wayland/weston-terminal-conf/weston-terminal.desktop12
2 files changed, 24 insertions, 1 deletions
diff --git a/recipes-graphics/wayland/weston-terminal-conf.bb b/recipes-graphics/wayland/weston-terminal-conf.bb
index abc23cb4..573e2df0 100644
--- a/recipes-graphics/wayland/weston-terminal-conf.bb
+++ b/recipes-graphics/wayland/weston-terminal-conf.bb
@@ -4,6 +4,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7ca
SRC_URI = " \
file://org.freedesktop.weston.wayland-terminal.desktop \
+ file://weston-terminal.desktop \
"
inherit allarch
@@ -11,9 +12,19 @@ inherit allarch
do_install() {
install -d ${D}${datadir}/applications
install -m 0644 ${WORKDIR}/org.freedesktop.weston.wayland-terminal.desktop ${D}${datadir}/applications
+
+ # Enable systemd sandboxing override as a demonstration
+ mkdir -p ${D}${sysconfdir}/systemd/system/agl-app@weston-terminal.service.d/
+ ln -sf ${sysconfdir}/systemd/sandboxing/no-network.conf ${D}${sysconfdir}/systemd/system/agl-app@weston-terminal.service.d/
+
+ # HACK - install .desktop file for systemd until applaunchd can do enumeration with homescreen names and icons
+ install -m 0644 ${WORKDIR}/weston-terminal.desktop ${D}${datadir}/applications/
}
-FILES:${PN} = "${datadir}/applications"
+FILES:${PN} = " \
+ ${datadir}/applications \
+ ${sysconfdir}/systemd/system/agl-app@weston-terminal.service.d \
+"
RDEPENDS:${PN} = " \
weston \
diff --git a/recipes-graphics/wayland/weston-terminal-conf/weston-terminal.desktop b/recipes-graphics/wayland/weston-terminal-conf/weston-terminal.desktop
new file mode 100644
index 00000000..d1cb2c88
--- /dev/null
+++ b/recipes-graphics/wayland/weston-terminal-conf/weston-terminal.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0
+Name=Weston Terminal (systemd)
+Comment=Terminal Emulator
+GenericName=Terminal Emulator
+Exec=weston-terminal
+Icon=utilities-terminal
+Terminal=false
+Type=Application
+Categories=System;TerminalEmulator;
+DBusActivatable=true
+StartupNotify=true