summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorArnaud Ferraris <arnaud.ferraris@collabora.com>2021-12-07 19:16:00 +0100
committerArnaud Ferraris <arnaud.ferraris@collabora.com>2021-12-21 09:03:16 +0100
commit477b8e482242db57d9ada3a8c3b2c69c27126ea5 (patch)
tree3054811304039cc1359b6cabb414fa5e1ce4ef2d /recipes-graphics
parenta88b3b1779ea71960a3048ec9a0f5fa32f52ed9c (diff)
wayland: add .desktop file for weston-terminal
weston-terminal is already installed as part of the weston installation. However, it doesn't provide a way to be easily discovered. This commit creates a .desktop file following the "Desktop entry specification" so this application can be discovered by a compliant application launcher. Bug-AGL: SPEC-4161 Signed-off-by: Arnaud Ferraris <arnaud.ferraris@collabora.com> Change-Id: I9c413645ed0bd4371c7d18977304ef6f1a5a2be7
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/weston-terminal-conf.bb20
-rw-r--r--recipes-graphics/wayland/weston-terminal-conf/weston-terminal.desktop11
2 files changed, 31 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/weston-terminal-conf.bb b/recipes-graphics/wayland/weston-terminal-conf.bb
new file mode 100644
index 00000000..4bf864f4
--- /dev/null
+++ b/recipes-graphics/wayland/weston-terminal-conf.bb
@@ -0,0 +1,20 @@
+SUMMARY = "AGL user session"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = " \
+ file://weston-terminal.desktop \
+"
+
+inherit allarch
+
+do_install() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 ${WORKDIR}/weston-terminal.desktop ${D}${datadir}/applications
+}
+
+FILES:${PN} = "${datadir}/applications"
+
+RDEPENDS:${PN} = " \
+ weston \
+"
diff --git a/recipes-graphics/wayland/weston-terminal-conf/weston-terminal.desktop b/recipes-graphics/wayland/weston-terminal-conf/weston-terminal.desktop
new file mode 100644
index 00000000..6c462870
--- /dev/null
+++ b/recipes-graphics/wayland/weston-terminal-conf/weston-terminal.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Name=Weston Terminal
+Comment=Terminal Emulator
+GenericName=Terminal Emulator
+Exec=weston-terminal
+Icon=utilities-terminal
+Terminal=false
+Type=Application
+Categories=System;TerminalEmulator;
+StartupNotify=true