summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-04-30 16:04:22 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-04-30 16:04:22 +0200
commit69d40194167df655116115f8864251594dbc8744 (patch)
treeedcab5f0e785d5b8d39f973499fe762b436f74a7 /recipes-graphics
parentc60877d5323111e090dbfe6ae0a0a394c333722a (diff)
Cleanup post next merge
Remove recipes no longer used by any image. - als-meter-demo - controls - settings-log-utils - vod-server - windowmanager (old version) - web-runtime (replaced with chromium) Packagegroup updates. Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> Change-Id: I2824a1a645a6f31e2f2ee9023548aefd7710aa07
Diffstat (limited to 'recipes-graphics')
-rwxr-xr-xrecipes-graphics/web-runtime/web-runtime/web-runtime18
-rw-r--r--recipes-graphics/web-runtime/web-runtime/web-runtime-webkit.qml13
-rw-r--r--recipes-graphics/web-runtime/web-runtime/web-runtime.qml14
-rw-r--r--recipes-graphics/web-runtime/web-runtime_0.1.bb37
4 files changed, 0 insertions, 82 deletions
diff --git a/recipes-graphics/web-runtime/web-runtime/web-runtime b/recipes-graphics/web-runtime/web-runtime/web-runtime
deleted file mode 100755
index 39f3781b..00000000
--- a/recipes-graphics/web-runtime/web-runtime/web-runtime
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/bash
-export -n QT_WAYLAND_SHELL_INTEGRATION
-port=$(echo -n "$1" | sed 's,.*local.*:\([^/]*\)/.*,\1,')
-token=$(echo -n "$1" | sed 's,.*token=,,')
-export AFM_APP_INSTALL_DIR=$(mktemp -d)
-cat << EOC > $AFM_APP_INSTALL_DIR/runxdg.toml
-[application]
-role = "WebBrowser"
-method = "POSIX"
-path = "/usr/bin/qt5/qmlscene"
-params = [
- "$1",
- "/usr/bin/web-runtime.qml"
-]
-EOC
-export LD_PRELOAD=/usr/lib/libEGL.so
-/usr/bin/runxdg "$port" "$token"
-rm -rf $AFM_APP_INSTALL_DIR
diff --git a/recipes-graphics/web-runtime/web-runtime/web-runtime-webkit.qml b/recipes-graphics/web-runtime/web-runtime/web-runtime-webkit.qml
deleted file mode 100644
index 8025ab12..00000000
--- a/recipes-graphics/web-runtime/web-runtime/web-runtime-webkit.qml
+++ /dev/null
@@ -1,13 +0,0 @@
-import QtQuick 2.1
-import QtQuick.Controls 1.1
-import QtWebKit 3.0
-
-ApplicationWindow {
- width: 1080
- height: 1488
- visible: true
- WebView {
- url: Qt.application.arguments[1]
- anchors.fill: parent
- }
-}
diff --git a/recipes-graphics/web-runtime/web-runtime/web-runtime.qml b/recipes-graphics/web-runtime/web-runtime/web-runtime.qml
deleted file mode 100644
index 3efe5159..00000000
--- a/recipes-graphics/web-runtime/web-runtime/web-runtime.qml
+++ /dev/null
@@ -1,14 +0,0 @@
-import QtQuick 2.1
-import QtQuick.Controls 1.1
-import QtWebEngine 1.1
-
-ApplicationWindow {
- width: 1080
- height: 1488
- visible: true
- flags: Qt.WindowFullScreen | Qt.FramelessWindowHint
- WebEngineView {
- url: Qt.application.arguments[1]
- anchors.fill: parent
- }
-}
diff --git a/recipes-graphics/web-runtime/web-runtime_0.1.bb b/recipes-graphics/web-runtime/web-runtime_0.1.bb
deleted file mode 100644
index ea5acbbf..00000000
--- a/recipes-graphics/web-runtime/web-runtime_0.1.bb
+++ /dev/null
@@ -1,37 +0,0 @@
-inherit allarch
-
-SUMMARY = "Provides the 'web-runtime' command"
-DESCRIPTION = "The command 'web-runtime' is an abstraction that allows to "
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-SRC_URI = "\
- file://web-runtime;md5sum=2245be1e6029b30966f0842e3fee75ea \
- file://web-runtime.qml;md5sum=922aeae6d596d7c83af01abca266f0df \
- file://web-runtime-webkit.qml;md5sum=4daf9df39078634c27a7923d37e82e3d \
-"
-
-RDEPENDS_${PN} = "\
- qtdeclarative-tools \
- qtwayland-qmlplugins \
- qtquickcontrols-qmlplugins \
- qtwebengine \
- runxdg \
- bash \
-"
-
-PROVIDES += "virtual/webruntime"
-# add also RPROVIDES to satisfy the packagegroup
-RPROVIDES_${PN} += "virtual/webruntime"
-
-do_configure() {
- :
-}
-
-do_install() {
- install -d ${D}${bindir}
- install -m 0755 ${WORKDIR}/web-runtime ${D}${bindir}/web-runtime
- install -m 0644 ${WORKDIR}/web-runtime.qml ${D}${bindir}/web-runtime.qml
- install -m 0644 ${WORKDIR}/web-runtime-webkit.qml ${D}${bindir}/web-runtime-webkit.qml
-}