summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-10-30 17:49:22 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-11-04 14:37:10 +0000
commit6e5995597c93831394024e0b8431702f1e785dcb (patch)
treea51f9c30f1b621600e9ad0dceaf7c6834bfe2429 /recipes-graphics
parent541493df5008c92acd42a2bfa01e8deb24774e11 (diff)
weston-agl-driver-conf: add recipe
Add recipe which installs a systemd drop-in configuration override to run Weston as the agl-driver user. This will be used in the new image for running agl-demo-control-panel, but may also be useful for other downstream users. Bug-AGL: SPEC-4952 Change-Id: I99c6801169e1c8e51a92c82fed354cdbbedda614 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29346 Tested-by: Jenkins Job builder account Reviewed-by: Hiroyuki Ishii <ishii.hiroyuki002@jp.panasonic.com> ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-build: Jenkins Job builder account
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/weston-agl-driver-conf.bb22
-rw-r--r--recipes-graphics/wayland/weston-agl-driver-conf/weston-agl-driver.conf5
2 files changed, 27 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/weston-agl-driver-conf.bb b/recipes-graphics/wayland/weston-agl-driver-conf.bb
new file mode 100644
index 00000000..763103d4
--- /dev/null
+++ b/recipes-graphics/wayland/weston-agl-driver-conf.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Weston systemd configuration to run as agl-driver user"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit systemd allarch features_check
+
+REQUIRED_DISTRO_FEATURES = "wayland systemd"
+
+SRC_URI = "file://weston-agl-driver.conf"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ # Install override drop-in
+ install -d ${D}${systemd_system_unitdir}/weston.service.d
+ install -m 0644 ${WORKDIR}/weston-agl-driver.conf ${D}${systemd_system_unitdir}/weston.service.d/
+}
+
+FILES:${PN} += "${systemd_system_unitdir}"
+
+RDEPENDS:${PN} += "weston agl-users"
diff --git a/recipes-graphics/wayland/weston-agl-driver-conf/weston-agl-driver.conf b/recipes-graphics/wayland/weston-agl-driver-conf/weston-agl-driver.conf
new file mode 100644
index 00000000..75ab576a
--- /dev/null
+++ b/recipes-graphics/wayland/weston-agl-driver-conf/weston-agl-driver.conf
@@ -0,0 +1,5 @@
+[Service]
+User=
+User=agl-driver
+Group=
+Group=agl-driver