summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-24 15:15:42 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-28 00:29:25 +0200
commitb1ee9d6cb0f28ba3dc5b35be97cd9507c39ede48 (patch)
tree2fe9ee45196c6fa8ee907503dc2bb1495489087c /recipes-graphics
parent8885505217f4180eb82ffc3ac8b0b9a24f5036b5 (diff)
2nd part of the layer/profile rework [2/2]
Main goal of this is to move the agl-service-* bindings into the core and to unify common recipes like wayland/weston into meta-agl-profile-graphical. As a placeholder for recipes is meta-agl-profile-demo which are being reshuffled. TLDR: remove recipes from meta-agl-demo that were moved to other layers Bug-AGL: SPEC-145 , SPEC-876 , SPEC-877 v2: moving updated udisks changes to meta-agl Change-Id: I873107f00adadeb6f3f266cce37b513fe6d44cf2 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/.gitkeep0
-rw-r--r--recipes-graphics/wayland/wayland-ivi-extension/cmake-find-gtest.patch22
-rw-r--r--recipes-graphics/wayland/wayland-ivi-extension/test-path.patch55
-rw-r--r--recipes-graphics/wayland/wayland-ivi-extension_1.1%.bbappend27
-rw-r--r--recipes-graphics/wayland/weston-ini-conf.bbappend15
-rw-r--r--recipes-graphics/wayland/weston-ini-conf/virtualoutput.cfg7
-rw-r--r--recipes-graphics/wayland/weston_%.bbappend1
7 files changed, 0 insertions, 127 deletions
diff --git a/recipes-graphics/.gitkeep b/recipes-graphics/.gitkeep
deleted file mode 100644
index e69de29b..00000000
--- a/recipes-graphics/.gitkeep
+++ /dev/null
diff --git a/recipes-graphics/wayland/wayland-ivi-extension/cmake-find-gtest.patch b/recipes-graphics/wayland/wayland-ivi-extension/cmake-find-gtest.patch
deleted file mode 100644
index 5371174d..00000000
--- a/recipes-graphics/wayland/wayland-ivi-extension/cmake-find-gtest.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -Naur old/ivi-input-api/test/CMakeLists.txt new/ivi-input-api/test/CMakeLists.txt
---- old/ivi-input-api/test/CMakeLists.txt 2015-10-19 23:31:13.000000000 +1000
-+++ new/ivi-input-api/test/CMakeLists.txt 2015-10-19 23:30:32.000000000 +1000
-@@ -18,6 +18,7 @@
- ############################################################################
-
- CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
-+SET(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/../../cmake/modules)
-
- FIND_PACKAGE(gtest)
-
-diff -Naur old/ivi-layermanagement-api/test/CMakeLists.txt new/ivi-layermanagement-api/test/CMakeLists.txt
---- old/ivi-layermanagement-api/test/CMakeLists.txt 2015-10-19 23:31:20.000000000 +1000
-+++ new/ivi-layermanagement-api/test/CMakeLists.txt 2015-10-19 23:30:48.000000000 +1000
-@@ -18,6 +18,7 @@
- ############################################################################
-
- CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
-+SET(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/../../cmake/modules)
-
- FIND_PACKAGE(gtest)
-
diff --git a/recipes-graphics/wayland/wayland-ivi-extension/test-path.patch b/recipes-graphics/wayland/wayland-ivi-extension/test-path.patch
deleted file mode 100644
index 251bc58f..00000000
--- a/recipes-graphics/wayland/wayland-ivi-extension/test-path.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From fbe0d0fd35ff79561dc2da853f1b0903bfde428d Mon Sep 17 00:00:00 2001
-From: Changhyeok Bae <changhyeok.bae@gmail.com>
-Date: Thu, 1 Jun 2017 07:45:20 +0000
-Subject: [PATCH] test patch
-
----
- ivi-input-api/test/CMakeLists.txt | 9 +++++----
- ivi-layermanagement-api/test/CMakeLists.txt | 7 ++++---
- 2 files changed, 9 insertions(+), 7 deletions(-)
-
-diff --git a/ivi-input-api/test/CMakeLists.txt b/ivi-input-api/test/CMakeLists.txt
-index db05d0f..db3b745 100644
---- a/ivi-input-api/test/CMakeLists.txt
-+++ b/ivi-input-api/test/CMakeLists.txt
-@@ -65,12 +65,13 @@ IF(BUILD_ILM_API_TESTS)
-
- ADD_DEPENDENCIES(${PROJECT_NAME} ${LIBS})
-
-- INSTALL(TARGETS ${PROJECT_NAME} DESTINATION bin)
-+ INSTALL(TARGETS ${PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test)
-+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/CTestTestfile.cmake DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test/ivi-layermanagement-api)
-
- # use CTest
- ENABLE_TESTING()
-- ADD_TEST(ilmCommon ${PROJECT_NAME})
-- ADD_TEST(ilmControl ${PROJECT_NAME})
-- ADD_TEST(ilmInput ${PROJECT_NAME})
-+ ADD_TEST(ilmCommon {CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
-+ ADD_TEST(ilmControl {CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
-+ ADD_TEST(ilmInput {CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
-
- ENDIF()
-diff --git a/ivi-layermanagement-api/test/CMakeLists.txt b/ivi-layermanagement-api/test/CMakeLists.txt
-index fe9a0a4..090d734 100644
---- a/ivi-layermanagement-api/test/CMakeLists.txt
-+++ b/ivi-layermanagement-api/test/CMakeLists.txt
-@@ -63,11 +63,12 @@ IF(BUILD_ILM_API_TESTS)
-
- ADD_DEPENDENCIES(${PROJECT_NAME} ${LIBS})
-
-- INSTALL(TARGETS ${PROJECT_NAME} DESTINATION bin)
-+ INSTALL(TARGETS ${PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test)
-+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/CTestTestfile.cmake DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test/ivi-layermanagement-api)
-
- # use CTest
- ENABLE_TESTING()
-- ADD_TEST(ilmCommon ${PROJECT_NAME})
-- ADD_TEST(ilmControl ${PROJECT_NAME})
-+ ADD_TEST(ilmCommon ${CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
-+ ADD_TEST(ilmControl ${CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
-
- ENDIF()
---
-2.7.4
-
diff --git a/recipes-graphics/wayland/wayland-ivi-extension_1.1%.bbappend b/recipes-graphics/wayland/wayland-ivi-extension_1.1%.bbappend
deleted file mode 100644
index 9c29dee4..00000000
--- a/recipes-graphics/wayland/wayland-ivi-extension_1.1%.bbappend
+++ /dev/null
@@ -1,27 +0,0 @@
-FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
-
-ENABLE_TEST = "-DBUILD_ILM_API_TESTS:BOOL=TRUE \
- -DINSTALL_ILM_API_TESTS:BOOL=TRUE \
- "
-
-DISABLE_TEST = "-DBUILD_ILM_API_TESTS:BOOL=FALSE \
- -DINSTALL_ILM_API_TESTS:BOOL=FALSE \
- "
-
-PACKAGECONFIG ??= "test"
-PACKAGECONFIG[test] = "${ENABLE_TEST},${DISABLE_TEST},gtest"
-
-SRC_URI_append = "\
- file://cmake-find-gtest.patch \
- file://test-path.patch \
- "
-
-PACKAGES =+ "${PN}-test"
-
-FILES_${PN}-test = "${libdir}/${PN}/test/*/CTestTestfile.cmake \
- ${libdir}/${PN}/test/ivi-layermanagement-api-test \
- ${libdir}/${PN}/test/ivi-input-api-test \
- "
-FILES_${PN}-dbg += "${libdir}/${PN}/test/.debug"
-
-RDEPENDS_${PN}-test += "cmake"
diff --git a/recipes-graphics/wayland/weston-ini-conf.bbappend b/recipes-graphics/wayland/weston-ini-conf.bbappend
deleted file mode 100644
index d778459f..00000000
--- a/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ /dev/null
@@ -1,15 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-#
-SRC_URI += "${@bb.utils.contains("DISTRO_FEATURES", "virtual-display", "file://virtualoutput.cfg", "",d)}"
-
-do_configure_append() {
- if ${@bb.utils.contains('DISTRO_FEATURES', 'virtual-display', 'true', 'false', d)}; then
- echo virtual=1 >> ${WORKDIR}/core.cfg
- fi
-
- if ${@bb.utils.contains('DISTRO_FEATURES', 'gst-record', 'true', 'false', d)}; then
- echo recorder=true >> ${WORKDIR}/virtualoutput.cfg
- fi
-}
-
diff --git a/recipes-graphics/wayland/weston-ini-conf/virtualoutput.cfg b/recipes-graphics/wayland/weston-ini-conf/virtualoutput.cfg
deleted file mode 100644
index 76f536ff..00000000
--- a/recipes-graphics/wayland/weston-ini-conf/virtualoutput.cfg
+++ /dev/null
@@ -1,7 +0,0 @@
-[output]
-name=virtual1
-mode=1920x1080@30
-ip=192.168.20.99
-port=5005
-bitrate=3000000
-crop=384x368@0x0
diff --git a/recipes-graphics/wayland/weston_%.bbappend b/recipes-graphics/wayland/weston_%.bbappend
deleted file mode 100644
index 38590dcd..00000000
--- a/recipes-graphics/wayland/weston_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-DEPENDS_append_ulcb = " gstreamer1.0-plugins-base"