summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/aim-sound
diff options
context:
space:
mode:
authorChristian Gromm <christian.gromm@microchip.com>2017-01-24 13:48:26 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-01-27 01:03:46 +0000
commit853bd2c5ee8fb08c8654b1a07e154b66972b49ab (patch)
tree0b7f284a27e1c761527ce17b3dfd37fed24bed0e /recipes-kernel/aim-sound
parent87ce94d22c1bcea17f847fdd0c0c546bcaca7ad2 (diff)
meta-agl-demo: recipes-kernel: update MOST driver recipes
This patch updates the recipes used to build the MOST driver. Since the driver source directory holds version 1.4.0-stable as of commit f19c18408b515c5e33f96893cbe213d9ab30b904 it also adds backport patches for the MOST sound and networking driver needed to build for porter. v2 (jsmoeller): combine with c8359 Change-Id: Ie56cadf9ef6224afb585fe950a0c3b0aff53b572 Signed-off-by: Christian Gromm <christian.gromm@microchip.com> Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-kernel/aim-sound')
-rw-r--r--recipes-kernel/aim-sound/aim-sound.bb11
-rw-r--r--recipes-kernel/aim-sound/files/0001-aim-sound-3.10.31-ltsi-backport.patch29
2 files changed, 32 insertions, 8 deletions
diff --git a/recipes-kernel/aim-sound/aim-sound.bb b/recipes-kernel/aim-sound/aim-sound.bb
index 3740d257..ae8d7d8b 100644
--- a/recipes-kernel/aim-sound/aim-sound.bb
+++ b/recipes-kernel/aim-sound/aim-sound.bb
@@ -1,18 +1,16 @@
-DESCRIPTION = "Example of how to build an external Linux kernel module"
+DESCRIPTION = "Build ALSA driver for MOST"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-#LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
-# "
inherit module
PV = "0.1"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
+SRC_URI_append_porter = " file://0001-aim-sound-3.10.31-ltsi-backport.patch"
S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
-#SRCREV = "${AUTOREV}"
+SRCREV = "${AUTOREV}"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
@@ -24,6 +22,3 @@ do_install_append () {
echo "aim_sound" > ${D}${sysconfdir}/modules-load.d/aim_sound.conf
fi
}
-
-# These sources are currently for the porter kernel only
-COMPATIBLE_MACHINE = "porter"
diff --git a/recipes-kernel/aim-sound/files/0001-aim-sound-3.10.31-ltsi-backport.patch b/recipes-kernel/aim-sound/files/0001-aim-sound-3.10.31-ltsi-backport.patch
new file mode 100644
index 00000000..b999b0d6
--- /dev/null
+++ b/recipes-kernel/aim-sound/files/0001-aim-sound-3.10.31-ltsi-backport.patch
@@ -0,0 +1,29 @@
+From 686130266ff7968edc863d398fba82bd0f78bf29 Mon Sep 17 00:00:00 2001
+From: Christian Gromm <christian.gromm@microchip.com>
+Date: Wed, 28 Sep 2016 13:43:36 +0200
+Subject: [PATCH 1/4] backport module
+
+This patch replaces function snd_card_new() with snd_card_create() to match
+AGL/Renesas kernel API.
+
+Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
+---
+ aim-sound/sound.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/sound.c b/aim-sound/sound.c
+index 3dc625c..af0af2d 100644
+--- a/sound.c
++++ b/sound.c
+@@ -595,7 +595,7 @@ static int audio_probe_channel(struct most_interface *iface, int channel_id,
+ return ret;
+ }
+
+- ret = snd_card_new(NULL, -1, card_name, THIS_MODULE,
++ ret = snd_card_create(-1, card_name, THIS_MODULE,
+ sizeof(*channel), &card);
+ if (ret < 0)
+ return ret;
+--
+1.7.9.5
+