summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/mocca-usb/mocca-usb.bb
diff options
context:
space:
mode:
authorChristian Gromm <christian.gromm@microchip.com>2016-08-02 11:48:39 +0200
committerChristian Gromm <christian.gromm@microchip.com>2016-08-02 11:48:50 +0200
commit1ea0cef6934ccadc36395b60d8b8d58d69016e28 (patch)
treec3b44cb86f0eb10b125cd8f52d48cb96e31eaaaa /recipes-kernel/mocca-usb/mocca-usb.bb
parent9a319937529cca7e263e987b85cb9d6fca0b468c (diff)
recipes-kernel: update driver recipes
This patch changes the recipes to fetch the driver sources from AGL's src directory. It therefore removes the redundant source files from the recipe directory. Change-Id: Ib3c48a0c7e79144713ccd8e10a89185cd929b41c Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
Diffstat (limited to 'recipes-kernel/mocca-usb/mocca-usb.bb')
-rw-r--r--recipes-kernel/mocca-usb/mocca-usb.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-kernel/mocca-usb/mocca-usb.bb b/recipes-kernel/mocca-usb/mocca-usb.bb
new file mode 100644
index 00000000..6f4e5861
--- /dev/null
+++ b/recipes-kernel/mocca-usb/mocca-usb.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Example of how to build an external Linux kernel module"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+inherit module
+
+PV = "0.1"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/can-lin/;protocol=https"
+S = "${WORKDIR}/git/Usb-Driver"
+SRCREV = "02ba272c0eb51b06160307b6cb71f91684772c8c"
+
+# The inherit of module.bbclass will automatically name module packages with
+# "kernel-module-" prefix as required by the oe-core build environment.