summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/pulseaudio
diff options
context:
space:
mode:
authorToshiaki Isogai <isogai.toshiaki@nttd-mse.com>2017-01-24 18:00:37 +0900
committerScott Murray <scott.murray@konsulko.com>2017-05-24 13:53:58 +0000
commit9e5c86a0645e95fd3fae0a76349a7b7db9207d0a (patch)
tree8ed2833bd14a4bba22809d0290146803b49f006f /recipes-multimedia/pulseaudio
parentf98eb9f66a10e91d5c1fb050550536822c2e8dca (diff)
Add audio management between Media Player and Radio.
This patch enables loading router-module by default to manage audio routing when both Media Player and Radio start playing. Latter audio source selected by user enforces existing one corked. Detail in below. https://jira.automotivelinux.org/browse/SPEC-378 Bug-AGL: SPEC-606 Change-Id: I407924b1346f95573596434ba9b17c732cae5146 Signed-off-by: Toshiaki Isogai <isogai.toshiaki@nttd-mse.com> Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-multimedia/pulseaudio')
-rw-r--r--recipes-multimedia/pulseaudio/pulseaudio/0006-auto-load-module-router.patch26
-rw-r--r--recipes-multimedia/pulseaudio/pulseaudio_%.bbappend3
2 files changed, 29 insertions, 0 deletions
diff --git a/recipes-multimedia/pulseaudio/pulseaudio/0006-auto-load-module-router.patch b/recipes-multimedia/pulseaudio/pulseaudio/0006-auto-load-module-router.patch
new file mode 100644
index 00000000..e1ae914f
--- /dev/null
+++ b/recipes-multimedia/pulseaudio/pulseaudio/0006-auto-load-module-router.patch
@@ -0,0 +1,26 @@
+diff --git a/src/daemon/default.pa.in b/src/daemon/default.pa.in
+index 783e326..3c68638 100755
+--- a/src/daemon/default.pa.in
++++ b/src/daemon/default.pa.in
+@@ -35,9 +35,9 @@ load-sample-dir-lazy %WINDIR%\Media\*.wav
+ .fail
+
+ ### Automatically restore the volume of streams and devices
+-load-module module-device-restore
+-load-module module-stream-restore
+-load-module module-card-restore
++#load-module module-device-restore
++#load-module module-stream-restore
++#load-module module-card-restore
+
+ ### Automatically augment property information from .desktop files
+ ### stored in /usr/share/application
+@@ -195,3 +195,8 @@ ifelse(@HAVE_X11@, 1, [dnl
+ ### Make some devices default
+ #set-default-sink output
+ #set-default-source input
++
++.ifexists module-router.so
++load-module module-router
++.endif
++
diff --git a/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend b/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend
new file mode 100644
index 00000000..8ff6a736
--- /dev/null
+++ b/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://0006-auto-load-module-router.patch"