summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-20 13:58:45 -0400
committerScott Murray <scott.murray@konsulko.com>2021-08-20 15:51:10 -0400
commit4249268041b879b3d2bae338d5de88f4f2d54b26 (patch)
tree757fd0c2daef3e0ccea1a12c27f900defaea2827 /recipes-multimedia
parente89376af34201168a3e8d3fe72258b587edb7d71 (diff)
Convert to new override syntax
This is the result of running a slightly customized version of the convert-overrides.py script from poky with additional overrides added. The intent of these changes is to minimize the effort to keep the "next" branch that builds against poky master up to date and tested in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4052 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I6eeadd2c985c008b04f8f9815bf0f6fb064bedac
Diffstat (limited to 'recipes-multimedia')
-rwxr-xr-xrecipes-multimedia/flite/flite-voicedata_1.05.bb2
-rwxr-xr-xrecipes-multimedia/flite/flite_1.06.bb2
-rw-r--r--recipes-multimedia/gstreamer1.0-plugins-bad/gstreamer1.0-plugins-bad_agldemo.inc4
-rw-r--r--recipes-multimedia/gstreamer1.0-plugins-good/gstreamer1.0-plugins-good_agldemo.inc2
-rw-r--r--recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend16
-rw-r--r--recipes-multimedia/lightmediascanner/lightmediascanner_0.5.1.bb14
-rw-r--r--recipes-multimedia/openjtalk/openjtalk-voicedata_1.6.bb2
-rw-r--r--recipes-multimedia/openjtalk/openjtalk_1.09.bb14
8 files changed, 28 insertions, 28 deletions
diff --git a/recipes-multimedia/flite/flite-voicedata_1.05.bb b/recipes-multimedia/flite/flite-voicedata_1.05.bb
index c339c7bf..e38b8120 100755
--- a/recipes-multimedia/flite/flite-voicedata_1.05.bb
+++ b/recipes-multimedia/flite/flite-voicedata_1.05.bb
@@ -19,4 +19,4 @@ do_install() {
install -m 0644 -p ${S}/*.htsvoice ${D}/${datadir}/Voice/us/
}
-FILES_${PN} += " ${datadir}/Voice/us/*.htsvoice "
+FILES:${PN} += " ${datadir}/Voice/us/*.htsvoice "
diff --git a/recipes-multimedia/flite/flite_1.06.bb b/recipes-multimedia/flite/flite_1.06.bb
index aff54964..b1f83754 100755
--- a/recipes-multimedia/flite/flite_1.06.bb
+++ b/recipes-multimedia/flite/flite_1.06.bb
@@ -14,7 +14,7 @@ SRC_URI[sha256sum] = "8a8c3ecc186ef92eda150a4aa687d8638f4f42be52aa2971e72aa960d4
DEPENDS = " hts-engine "
-RDEPENDS_${PN} += " flite-voicedata "
+RDEPENDS:${PN} += " flite-voicedata "
inherit autotools-brokensep
diff --git a/recipes-multimedia/gstreamer1.0-plugins-bad/gstreamer1.0-plugins-bad_agldemo.inc b/recipes-multimedia/gstreamer1.0-plugins-bad/gstreamer1.0-plugins-bad_agldemo.inc
index fcfda531..cb45fdbf 100644
--- a/recipes-multimedia/gstreamer1.0-plugins-bad/gstreamer1.0-plugins-bad_agldemo.inc
+++ b/recipes-multimedia/gstreamer1.0-plugins-bad/gstreamer1.0-plugins-bad_agldemo.inc
@@ -1,2 +1,2 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/gstreamer1.0-plugins-bad:"
-SRC_URI_append = " file://0001-gst-wayland-Install-wayland-header-from-gstwayland-l.patch"
+FILESEXTRAPATHS:prepend := "${THISDIR}/gstreamer1.0-plugins-bad:"
+SRC_URI:append = " file://0001-gst-wayland-Install-wayland-header-from-gstwayland-l.patch"
diff --git a/recipes-multimedia/gstreamer1.0-plugins-good/gstreamer1.0-plugins-good_agldemo.inc b/recipes-multimedia/gstreamer1.0-plugins-good/gstreamer1.0-plugins-good_agldemo.inc
index 86a181fb..10fd995b 100644
--- a/recipes-multimedia/gstreamer1.0-plugins-good/gstreamer1.0-plugins-good_agldemo.inc
+++ b/recipes-multimedia/gstreamer1.0-plugins-good/gstreamer1.0-plugins-good_agldemo.inc
@@ -1,2 +1,2 @@
# libv4l2 is useful for making more efficient use of cameras via v4l2src.
-PACKAGECONFIG_append = " libv4l2"
+PACKAGECONFIG:append = " libv4l2"
diff --git a/recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend b/recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend
index b47b2796..5208933d 100644
--- a/recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend
+++ b/recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend
@@ -1,7 +1,7 @@
# Disable everything but the roygalty-free formats
PACKAGECONFIG = "ogg flac wave m3u pls jpeg png"
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
SRC_URI += "file://lightmediascanner.service \
file://plugin-ogg-fix-chucksize-issue.patch \
@@ -9,15 +9,15 @@ SRC_URI += "file://lightmediascanner.service \
file://dbus-lightmediascanner.conf \
"
-CFLAGS_append = " -D_FILE_OFFSET_BITS=64"
+CFLAGS:append = " -D_FILE_OFFSET_BITS=64"
inherit systemd
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "lightmediascanner.service"
-SYSTEMD_AUTO_ENABLE_${PN} = "enable"
+SYSTEMD_SERVICE:${PN} = "lightmediascanner.service"
+SYSTEMD_AUTO_ENABLE:${PN} = "enable"
-do_install_append() {
+do_install:append() {
# Install LMS systemd service
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${systemd_system_unitdir}
@@ -28,7 +28,7 @@ do_install_append() {
install -m 0644 ${WORKDIR}/dbus-lightmediascanner.conf ${D}/etc/dbus-1/system.d/org.lightmediascanner.conf
}
-FILES_${PN} += " \
+FILES:${PN} += " \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_system_unitdir}/lightmediascanner.service', '', d)} \
"
@@ -36,7 +36,7 @@ EXTRA_OECONF = "--enable-static --with-dbus-services=${datadir}/dbus-1/system-se
PACKAGECONFIG[mp4] = "--enable-mp4,--disable-mp4,libmp4v2"
# add support MP3 because of the format of music files for AGL CES/ALS2017 Demo
-PACKAGECONFIG_append = " id3 mp4"
+PACKAGECONFIG:append = " id3 mp4"
# add required character sets for id3 tag scanning
-RDEPENDS_${PN}_append = " glibc-gconv-utf-16 glibc-gconv-iso8859-1"
+RDEPENDS:${PN}:append = " glibc-gconv-utf-16 glibc-gconv-iso8859-1"
diff --git a/recipes-multimedia/lightmediascanner/lightmediascanner_0.5.1.bb b/recipes-multimedia/lightmediascanner/lightmediascanner_0.5.1.bb
index f2158760..09a8b19c 100644
--- a/recipes-multimedia/lightmediascanner/lightmediascanner_0.5.1.bb
+++ b/recipes-multimedia/lightmediascanner/lightmediascanner_0.5.1.bb
@@ -34,7 +34,7 @@ PACKAGECONFIG[rm] = "--enable-rm,--disable-rm"
PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg"
PACKAGECONFIG[png] = "--enable-png,--disable-png"
-do_install_append() {
+do_install:append() {
# Install "test" binary for corresponding package
install -d ${D}/${bindir}
install -m 755 ${B}/src/bin/.libs/test ${D}/${bindir}/test-lms
@@ -42,22 +42,22 @@ do_install_append() {
rm -f ${D}/${libdir}/${PN}/plugins/*.la
}
-FILES_${PN} += "${datadir}/dbus-1"
-FILES_${PN}-dbg += "${libdir}/${PN}/plugins/.debug"
+FILES:${PN} += "${datadir}/dbus-1"
+FILES:${PN}-dbg += "${libdir}/${PN}/plugins/.debug"
-PACKAGES_prepend = "${PN}-test "
+PACKAGES:prepend = "${PN}-test "
FILES_${PN}-test_prepend = "${bindir}/test-lms "
PACKAGES += "${PN}-meta"
-ALLOW_EMPTY_${PN}-meta = "1"
+ALLOW_EMPTY:${PN}-meta = "1"
PACKAGES_DYNAMIC = "${PN}-plugin-*"
-python populate_packages_prepend () {
+python populate_packages:prepend () {
lms_libdir = d.expand('${libdir}/${PN}')
pkgs = []
pkgs += do_split_packages(d, oe.path.join(lms_libdir, "plugins"), '^(.*)\.so$', d.expand('${PN}-plugin-%s'), 'LightMediaScanner plugin for %s', prepend=True, extra_depends=d.expand('${PN}'))
metapkg = d.getVar('PN') + '-meta'
- d.setVar('RDEPENDS_' + metapkg, ' '.join(pkgs))
+ d.setVar('RDEPENDS:' + metapkg, ' '.join(pkgs))
}
diff --git a/recipes-multimedia/openjtalk/openjtalk-voicedata_1.6.bb b/recipes-multimedia/openjtalk/openjtalk-voicedata_1.6.bb
index 27ef7b57..f4e6a8d4 100644
--- a/recipes-multimedia/openjtalk/openjtalk-voicedata_1.6.bb
+++ b/recipes-multimedia/openjtalk/openjtalk-voicedata_1.6.bb
@@ -19,4 +19,4 @@ do_install() {
install -m 0644 -p ${S}/Voice/mei/*.htsvoice ${D}/${datadir}/Voice/mei/
}
-FILES_${PN} += " ${datadir}/Voice/mei/*.htsvoice "
+FILES:${PN} += " ${datadir}/Voice/mei/*.htsvoice "
diff --git a/recipes-multimedia/openjtalk/openjtalk_1.09.bb b/recipes-multimedia/openjtalk/openjtalk_1.09.bb
index 5ac0771a..0c780a07 100644
--- a/recipes-multimedia/openjtalk/openjtalk_1.09.bb
+++ b/recipes-multimedia/openjtalk/openjtalk_1.09.bb
@@ -12,7 +12,7 @@ SRC_URI = "\
file://fix-mecab-tool.patch \
"
-SRC_URI_class-native = "\
+SRC_URI:class-native = "\
http://downloads.sourceforge.net/open-jtalk/open_jtalk-${PV}.tar.gz \
"
@@ -21,10 +21,10 @@ SRC_URI[md5sum] = "5dfdbad432d892f044fb96129a524bfe"
SRC_URI[sha256sum] = "8ed79238d825fee1d9e0a1c6c8a89e2cc707189be1caa3fa79e8eb72436079d7"
DEPENDS = " hts-engine openjtalk-native "
-DEPENDS_class-native = " hts-engine-native "
+DEPENDS:class-native = " hts-engine-native "
-RDEPENDS_${PN} = " openjtalk-voicedata "
-RDEPENDS_${PN}_class-native = " "
+RDEPENDS:${PN} = " openjtalk-voicedata "
+RDEPENDS:${PN}:class-native = " "
inherit autotools-brokensep
@@ -36,14 +36,14 @@ EXTRA_OECONF = " \
--with-hts-engine-library-path=${PKG_CONFIG_SYSROOT_DIR}/usr/lib \
"
-EXTRA_OECONF_class-native = " \
+EXTRA_OECONF:class-native = " \
--with-hts-engine-header-path=${includedir} \
--with-hts-engine-library-path=${libdir} \
"
-do_install_append_class-native() {
+do_install:append:class-native() {
install -m 755 mecab/src/mecab-dict-index ${D}${bindir}
}
-FILES_${PN} += " ${datadir}/dic/* "
+FILES:${PN} += " ${datadir}/dic/* "