summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-05-15 14:47:00 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-06-05 15:11:36 +0200
commitb6852864508358930586e083e72cd2912af68674 (patch)
tree4029e33f00bbd0247524d03f7c1689672d85ef9b /recipes-multimedia
parentfab778caff2041794814df54b51893965381aa66 (diff)
3rd part of the layer/profile rework [2/2]
This is the last part of the layer rework series. Notable changes are: - move demo specific recipes to the demo (dlt, web-runtime mocca-usb) - wayland-ivi-extension moved to the meta-agl-demo layer for now. - web-runtime moved here (from appfw layer to allow console-only builds with appfw) - adapted packagegroups and agl-features v2: squashed with commit on sandbox to form single commit (tnx, Scott) v3: inclusion of old packagegroup-agl-image-ivi (TODO: refactor and include in profile packagegroups. Tnx, Stephane) v4: base packagegroup-agl-demo-platform on packagegroup-agl-profile-graphical-qt5 v5: fix MOST_DRIVERS_append (disable due to FTBS) v6: re-add RDEPENDS for virtual/pulseaudio-config Bug-AGL: SPEC-145 Bug-AGL: SPEC-1422 Change-Id: I20bd5b9a957ea54a7ecd08bd4f8b99a32266c9c8 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/audiomanager/audiomanager/0001-Fix-duplicated-command-line-arg-t.patch25
-rw-r--r--recipes-multimedia/audiomanager/audiomanager/audiomanager.service17
-rw-r--r--recipes-multimedia/audiomanager/audiomanager_7.4.bb56
-rw-r--r--recipes-multimedia/pulseaudio/files/10-unload-modules.pa4
-rw-r--r--recipes-multimedia/pulseaudio/pulseaudio_%.bbappend10
5 files changed, 98 insertions, 14 deletions
diff --git a/recipes-multimedia/audiomanager/audiomanager/0001-Fix-duplicated-command-line-arg-t.patch b/recipes-multimedia/audiomanager/audiomanager/0001-Fix-duplicated-command-line-arg-t.patch
new file mode 100644
index 00000000..fcdf9c54
--- /dev/null
+++ b/recipes-multimedia/audiomanager/audiomanager/0001-Fix-duplicated-command-line-arg-t.patch
@@ -0,0 +1,25 @@
+From c4b6030f575e38dfc9cca7dfd029d207f3af6a13 Mon Sep 17 00:00:00 2001
+From: "Andre Moreira Magalhaes (andrunko)" <andre.magalhaes@collabora.co.uk>
+Date: Thu, 5 May 2016 00:01:19 -0300
+Subject: [PATCH] Fix duplicated command line arg -t.
+
+---
+ AudioManagerDaemon/src/main.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/AudioManagerDaemon/src/main.cpp b/AudioManagerDaemon/src/main.cpp
+index 795795d..67c0977 100755
+--- a/AudioManagerDaemon/src/main.cpp
++++ b/AudioManagerDaemon/src/main.cpp
+@@ -87,7 +87,7 @@ TCLAP::ValueArg<std::string> commandPluginDir("l","CommandPluginDir","path for l
+ TCLAP::ValueArg<std::string> databasePath ("p","databasePath","path for sqlite database (default is in memory)",false,":memory:","string");
+ TCLAP::ValueArg<unsigned int> telnetPort ("t","telnetport","The port that is used for telnet",false,DEFAULT_TELNETPORT,"int");
+ TCLAP::ValueArg<unsigned int> maxConnections ("m","maxConnections","Maximal number of connections for telnet",false,MAX_TELNETCONNECTIONS,"int");
+-TCLAP::SwitchArg dbusWrapperTypeBool ("t","dbusType","DbusType to be used by CAmDbusWrapper: if option is selected, DBUS_SYSTEM is used otherwise DBUS_SESSION",false);
++TCLAP::SwitchArg dbusWrapperTypeBool ("T","dbusType","DbusType to be used by CAmDbusWrapper: if option is selected, DBUS_SYSTEM is used otherwise DBUS_SESSION",false);
+ TCLAP::SwitchArg enableNoDLTDebug ("V","logDlt","print DLT logs to stdout",false);
+ TCLAP::SwitchArg currentSettings("i","currentSettings","print current settings and exit",false);
+ TCLAP::SwitchArg daemonizeAM("d","daemonize","daemonize Audiomanager. Better use systemd...",false);
+--
+2.5.0
+
diff --git a/recipes-multimedia/audiomanager/audiomanager/audiomanager.service b/recipes-multimedia/audiomanager/audiomanager/audiomanager.service
new file mode 100644
index 00000000..2210a377
--- /dev/null
+++ b/recipes-multimedia/audiomanager/audiomanager/audiomanager.service
@@ -0,0 +1,17 @@
+# AudioManager systemd service file
+
+[Unit]
+Description=GENIVI AudioManager
+Requires=dbus.service
+After=dbus.service
+Before=pulseaudio.service
+
+[Service]
+Type=notify
+ExecStart=/usr/bin/AudioManager -T
+Restart=always
+TimeoutSec=2
+WatchdogSec=2
+
+[Install]
+WantedBy=multi-user.target
diff --git a/recipes-multimedia/audiomanager/audiomanager_7.4.bb b/recipes-multimedia/audiomanager/audiomanager_7.4.bb
new file mode 100644
index 00000000..15eb3625
--- /dev/null
+++ b/recipes-multimedia/audiomanager/audiomanager_7.4.bb
@@ -0,0 +1,56 @@
+DESCRIPTION = "GENIVI Audio Manager"
+HOMEPAGE = "http://projects.genivi.org/audio-manager/home"
+LICENSE = "MPLv2"
+SECTION = "multimedia"
+DEPENDS = "dbus dlt-daemon systemd"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=f164349b56ed530a6642e9b9f244eec5"
+
+SRC_URI = " \
+ git://github.com/GENIVI/AudioManager.git;protocol=https;branch=master \
+ file://audiomanager.service \
+"
+RDEPENDS_${PN} = "audiomanager-plugins module-router"
+SRCREV = "daf851ee7a41d1b0572c0c95e15f61e427ce97f1"
+
+S = "${WORKDIR}/git"
+inherit cmake systemd
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "audiomanager.service"
+SYSTEMD_AUTO_ENABLE = "enable"
+
+EXTRA_OECMAKE = " \
+ -DWITH_TESTS=OFF \
+ -DWITH_DOCUMENTATION=OFF \
+ -DWITH_DLT=ON \
+ -DWITH_TELNET=OFF \
+ -DWITH_SYSTEMD_WATCHDOG=ON \
+ -DGLIB_DBUS_TYPES_TOLERANT=ON \
+ -DWITH_CAPI_WRAPPER=OFF \
+ -DWITH_DBUS_WRAPPER=ON \
+ -DWITH_SHARED_UTILITIES=ON \
+ -DWITH_SHARED_CORE=ON \
+"
+
+FILES_${PN} = " \
+ ${bindir}/AudioManager \
+ ${libdir}/libAudioManagerCore.so.7 \
+ ${libdir}/libAudioManagerCore.so.7.4 \
+ ${libdir}/libAudioManagerCore.so.7.4.12 \
+ ${libdir}/libAudioManagerUtilities.so.7 \
+ ${libdir}/libAudioManagerUtilities.so.7.4 \
+ ${libdir}/libAudioManagerUtilities.so.7.4.12 \
+ ${systemd_unitdir}/audiomanager.service \
+"
+
+FILES_${PN}-dev = " \
+ ${includedir}/audiomanager/* \
+ ${libdir}/cmake/* \
+ ${libdir}/pkgconfig/* \
+ ${libdir}/libAudioManagerCore.so \
+ ${libdir}/libAudioManagerUtilities.so \
+"
+
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/audiomanager.service ${D}${systemd_unitdir}/system/
+}
diff --git a/recipes-multimedia/pulseaudio/files/10-unload-modules.pa b/recipes-multimedia/pulseaudio/files/10-unload-modules.pa
deleted file mode 100644
index 1f8b723e..00000000
--- a/recipes-multimedia/pulseaudio/files/10-unload-modules.pa
+++ /dev/null
@@ -1,4 +0,0 @@
-unload-module module-role-cork
-unload-module module-device-restore
-unload-module module-stream-restore
-unload-module module-card-restore
diff --git a/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend b/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend
deleted file mode 100644
index 30ef4f7e..00000000
--- a/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend
+++ /dev/null
@@ -1,10 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-
-SRC_URI += "file://10-unload-modules.pa"
-
-# Add .include directive to default.pa so optional configuration can be added
-do_install_append () {
- echo ".include ${sysconfdir}/pulse/default.d" >> ${D}${sysconfdir}/pulse/default.pa
- install -d ${D}${sysconfdir}/pulse/default.d
- install -m 0644 ${WORKDIR}/10-unload-modules.pa ${D}${sysconfdir}/pulse/default.d/
-}