summaryrefslogtreecommitdiffstats
path: root/recipes-navigation/osrm-backend/files
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2017-11-07 00:07:14 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-11-11 10:41:09 +0000
commit9339adb65f0ffe0142d5b110d62e8efdca3fdcd8 (patch)
treeeca08c1fbf5b4371a245a24b3144b3f95dec9899 /recipes-navigation/osrm-backend/files
parent74620350fa86739cd068e035015c8335bc33b810 (diff)
osrm-backend: add osrm routing backend recipe
Add osrm-backend which indexes routing of car, bike, and walking routes Bug-AGL: SPEC-1023 Change-Id: I0caeeb228170233d6edd08c66b161c7cfa764e0b Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
Diffstat (limited to 'recipes-navigation/osrm-backend/files')
-rw-r--r--recipes-navigation/osrm-backend/files/0001-cmake-fix-search-paths-for-OE-building.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-navigation/osrm-backend/files/0001-cmake-fix-search-paths-for-OE-building.patch b/recipes-navigation/osrm-backend/files/0001-cmake-fix-search-paths-for-OE-building.patch
new file mode 100644
index 00000000..80a7b6f8
--- /dev/null
+++ b/recipes-navigation/osrm-backend/files/0001-cmake-fix-search-paths-for-OE-building.patch
@@ -0,0 +1,36 @@
+From a45781fbd39426c0be6d57dcce7ce4679ee63b87 Mon Sep 17 00:00:00 2001
+From: Matt Ranostay <matt.ranostay@konsulko.com>
+Date: Fri, 3 Nov 2017 16:53:34 -0700
+Subject: [PATCH] cmake: fix search paths for OE building
+
+For gcc-6 -isystem breaks #include_next so put recipes
+staging include directory before others
+
+Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 175791651..c5a214102 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -113,6 +113,7 @@ elseif(CMAKE_CXX_COMPILER_ID MATCHES "Clang")
+ endif()
+ endif()
+
++include_directories(BEFORE ${STAGING_DIR_HOST}/usr/include/)
+ include_directories(BEFORE ${CMAKE_CURRENT_BINARY_DIR}/include/)
+ include_directories(BEFORE ${CMAKE_CURRENT_SOURCE_DIR}/include/)
+ include_directories(SYSTEM ${CMAKE_CURRENT_SOURCE_DIR}/third_party/sol2/)
+@@ -589,7 +590,6 @@ if (ENABLE_STXXL)
+ endif()
+
+ add_definitions(${OSRM_DEFINES})
+-include_directories(SYSTEM ${DEPENDENCIES_INCLUDE_DIRS})
+
+ set(BOOST_BASE_LIBRARIES
+ ${Boost_DATE_TIME_LIBRARY}
+--
+2.14.2
+