summaryrefslogtreecommitdiffstats
path: root/recipes-navigation
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2017-11-06 23:49:03 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-11-11 10:40:34 +0000
commit74620350fa86739cd068e035015c8335bc33b810 (patch)
tree8b9be7dd0cc3427db471f9f28610113102f7a13c /recipes-navigation
parent7fc850d871ea114f4f3e55ed0baa02e5a4e0d671 (diff)
libosmium: add osmium recipe
osmium is c++ library that is used for working with OpenStreetMap mapping data. Bug-AGL: SPEC-1023 Change-Id: I8188c7f747b3018dade187eeabc995a16a927689 Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
Diffstat (limited to 'recipes-navigation')
-rw-r--r--recipes-navigation/osmium/osmium_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-navigation/osmium/osmium_git.bb b/recipes-navigation/osmium/osmium_git.bb
new file mode 100644
index 00000000..962ba0a8
--- /dev/null
+++ b/recipes-navigation/osmium/osmium_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "libosmium library"
+DESCRIPTION = "Fast and flexible C++ library for working with OpenStreetMap data. "
+HOMEPAGE = "http://osmcode.org/libosmium"
+SECTION = "apps"
+
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e4224ccaecb14d942c71d31bef20d78c"
+
+SRC_URI = "git://github.com/osmcode/libosmium.git;protocol=http"
+SRCREV = "28c676054064c6b75204f0981c21fb3e265c9319"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OECMAKE += "-DBUILD_EXAMPLES=OFF -DBUILD_TESTING=OFF"
+
+DEPENDS = "boost protozero"
+
+inherit cmake pkgconfig