summaryrefslogtreecommitdiffstats
path: root/recipes-navigation
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-02-18 16:09:28 -0500
committerScott Murray <scott.murray@konsulko.com>2024-02-20 14:41:30 +0000
commit953f9ca81b1da07f61f8d417fc2765cb647dcf79 (patch)
treef3f9452c5dedeaf7fb0d35cea9d070c1627a6212 /recipes-navigation
parentd76a46d03a73bbbe8911d9f6f227e0cf80a7b791 (diff)
Rework gpsd configuration
To remove the use of the "virtual/gpsd-conf" RPROVIDES as part of futureproofing for YP 5.0 / Scarthgap, rework the machine-specific gpsd configuration scheme to based on the gpsd-machine-conf recipe that is intended for this upstream. The gpsd-machine-conf recipe is now unconditionally included in the navigation packagegroup, but it will be empty on machines except those that add their own content to it. Bug-AGL: SPEC-5067 Change-Id: I7f1b555f154fe77c643019dae4bb90354ca2a4b4 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29691 ci-image-boot-test: Jenkins Job builder account Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account
Diffstat (limited to 'recipes-navigation')
-rw-r--r--recipes-navigation/gpsd/gpsd-machine-conf_%.bbappend1
-rw-r--r--recipes-navigation/gpsd/gpsd-machine-conf_agldemo.inc8
-rw-r--r--recipes-navigation/gpsd/gpsd_agldemo.inc2
3 files changed, 9 insertions, 2 deletions
diff --git a/recipes-navigation/gpsd/gpsd-machine-conf_%.bbappend b/recipes-navigation/gpsd/gpsd-machine-conf_%.bbappend
new file mode 100644
index 00000000..77c0ef8a
--- /dev/null
+++ b/recipes-navigation/gpsd/gpsd-machine-conf_%.bbappend
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'gpsd-machine-conf_agldemo.inc', '', d)}
diff --git a/recipes-navigation/gpsd/gpsd-machine-conf_agldemo.inc b/recipes-navigation/gpsd/gpsd-machine-conf_agldemo.inc
new file mode 100644
index 00000000..f2bca1a6
--- /dev/null
+++ b/recipes-navigation/gpsd/gpsd-machine-conf_agldemo.inc
@@ -0,0 +1,8 @@
+# Mark package as machine specific, which the upstream stub recipe
+# does not do for unclear reasons.
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+# Allow an empty package as results from the upstream stub recipe.
+# This allows using the package without needing machine specific
+# hooks.
+ALLOW_EMPTY:${PN} = "1"
diff --git a/recipes-navigation/gpsd/gpsd_agldemo.inc b/recipes-navigation/gpsd/gpsd_agldemo.inc
index 77dee8e0..cb26510d 100644
--- a/recipes-navigation/gpsd/gpsd_agldemo.inc
+++ b/recipes-navigation/gpsd/gpsd_agldemo.inc
@@ -8,5 +8,3 @@ do_install:append() {
install -m 0755 ${WORKDIR}/sw-device-hook ${D}${sysconfdir}/gpsd/device-hook
}
-RPROVIDES:${PN}-conf:append = " virtual/gpsd-conf"
-