summaryrefslogtreecommitdiffstats
path: root/recipes-navigation
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-09-15 14:51:22 -0400
committerScott Murray <scott.murray@konsulko.com>2021-09-15 14:51:22 -0400
commita56affa977604cbc5e5e73c60fb234246e0aea4e (patch)
tree08733dc9a3e1300850701708e340e256c8d66334 /recipes-navigation
parent07f4ab8c2833ae5377b97cc9e3820bed67e539d0 (diff)
osrm-backend: remove recipes
Remove the osrm-backend recipe and the recipes for its dependencies osmium and protozero, as they do not build and nothing in AGL uses them. Bug-AGL: SPEC-3921 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I615c555f3827488a43560da5d518a34c3ca1313f
Diffstat (limited to 'recipes-navigation')
-rw-r--r--recipes-navigation/osmium/osmium_git.bb18
-rw-r--r--recipes-navigation/osrm-backend/files/0001-cmake-fix-search-paths-for-OE-building.patch36
-rw-r--r--recipes-navigation/osrm-backend/osrm-backend_git.bb24
-rw-r--r--recipes-navigation/protozero/protozero_git.bb20
4 files changed, 0 insertions, 98 deletions
diff --git a/recipes-navigation/osmium/osmium_git.bb b/recipes-navigation/osmium/osmium_git.bb
deleted file mode 100644
index a7178dbc..00000000
--- a/recipes-navigation/osmium/osmium_git.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-SUMMARY = "libosmium library"
-DESCRIPTION = "Fast and flexible C++ library for working with OpenStreetMap data. "
-HOMEPAGE = "http://osmcode.org/libosmium"
-SECTION = "apps"
-
-LICENSE = "BSL-1.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=e4224ccaecb14d942c71d31bef20d78c"
-
-SRC_URI = "git://github.com/osmcode/libosmium.git;protocol=http"
-SRCREV = "28c676054064c6b75204f0981c21fb3e265c9319"
-
-S = "${WORKDIR}/git"
-
-EXTRA_OECMAKE += "-DBUILD_EXAMPLES=OFF -DBUILD_TESTING=OFF"
-
-DEPENDS = "boost protozero"
-
-inherit cmake pkgconfig
diff --git a/recipes-navigation/osrm-backend/files/0001-cmake-fix-search-paths-for-OE-building.patch b/recipes-navigation/osrm-backend/files/0001-cmake-fix-search-paths-for-OE-building.patch
deleted file mode 100644
index 80a7b6f8..00000000
--- a/recipes-navigation/osrm-backend/files/0001-cmake-fix-search-paths-for-OE-building.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From a45781fbd39426c0be6d57dcce7ce4679ee63b87 Mon Sep 17 00:00:00 2001
-From: Matt Ranostay <matt.ranostay@konsulko.com>
-Date: Fri, 3 Nov 2017 16:53:34 -0700
-Subject: [PATCH] cmake: fix search paths for OE building
-
-For gcc-6 -isystem breaks #include_next so put recipes
-staging include directory before others
-
-Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 175791651..c5a214102 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -113,6 +113,7 @@ elseif(CMAKE_CXX_COMPILER_ID MATCHES "Clang")
- endif()
- endif()
-
-+include_directories(BEFORE ${STAGING_DIR_HOST}/usr/include/)
- include_directories(BEFORE ${CMAKE_CURRENT_BINARY_DIR}/include/)
- include_directories(BEFORE ${CMAKE_CURRENT_SOURCE_DIR}/include/)
- include_directories(SYSTEM ${CMAKE_CURRENT_SOURCE_DIR}/third_party/sol2/)
-@@ -589,7 +590,6 @@ if (ENABLE_STXXL)
- endif()
-
- add_definitions(${OSRM_DEFINES})
--include_directories(SYSTEM ${DEPENDENCIES_INCLUDE_DIRS})
-
- set(BOOST_BASE_LIBRARIES
- ${Boost_DATE_TIME_LIBRARY}
---
-2.14.2
-
diff --git a/recipes-navigation/osrm-backend/osrm-backend_git.bb b/recipes-navigation/osrm-backend/osrm-backend_git.bb
deleted file mode 100644
index 0b5bd3a2..00000000
--- a/recipes-navigation/osrm-backend/osrm-backend_git.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-SUMMARY = "Open Source Routing Machine"
-DESCRIPTION = "Open Source Routing Machine C++ backend"
-HOMEPAGE = "http://map.project-osrm.org"
-SECTION = "apps"
-
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=d7862bc7b1d9f5fbeee5657b31075df1"
-
-SRC_URI = "git://github.com/Project-OSRM/osrm-backend.git;protocol=http \
- file://0001-cmake-fix-search-paths-for-OE-building.patch \
- "
-
-SRCREV = "5b58445535633eb1d6840ef4e8786ff521622867"
-
-FILES:${PN} += " \
- ${datadir}/osrm/profiles/*.lua \
- ${datadir}/osrm/profiles/*/*.lua \
- "
-
-S = "${WORKDIR}/git"
-
-DEPENDS = "boost bzip2 tbb libzip lua osmium protozero expat"
-
-inherit cmake pkgconfig
diff --git a/recipes-navigation/protozero/protozero_git.bb b/recipes-navigation/protozero/protozero_git.bb
deleted file mode 100644
index c65968cd..00000000
--- a/recipes-navigation/protozero/protozero_git.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-SUMMARY = "protozero library"
-DESCRIPTION = "Minimalist protocol buffer decoder and encoder in C++"
-
-HOMEPAGE = "https://github.com/mapbox/protozero"
-SECTION = "apps"
-
-LICENSE = "BSD & Apache-2.0"
-LIC_FILES_CHKSUM = "\
- file://LICENSE.md;md5=bb1a27fdd409f635a3f92106ef78d30a \
- file://LICENSE.from_folly;md5=2ee41112a44fe7014dce33e26468ba93 \
- "
-
-SRC_URI = "git://github.com/mapbox/protozero.git;protocol=http"
-SRCREV = "aa8b304cf63831589f52c254b5af2c688bdc2fc4"
-
-S = "${WORKDIR}/git"
-
-CFLAGS:prepend = " -I${STAGING_DIR_HOST}/include"
-
-inherit cmake pkgconfig