summaryrefslogtreecommitdiffstats
path: root/recipes-openivi
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2016-11-30 22:51:35 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-12-01 21:53:25 +0000
commit3ecf5cc06c44d700a7f29d4ffb49ab4c4954bba7 (patch)
tree84a2b01f15f69362c8147b29f22d9a0b1e1eeb23 /recipes-openivi
parent41effe677fc59faae4158650566286c62ac095d2 (diff)
openivi-html5: Fix compatibility with IVI shell
Update openivi-html5 to latest version and modify openivi-html5.sh to fix the compatibility with Weston IVI shell. Bug-AGL: SPEC-335 Change-Id: I015892f24e78c61283f57897c9741d608bcc383b Suggested-by: Anton Gerasimov <anton@advancedtelematic.com> Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Diffstat (limited to 'recipes-openivi')
-rw-r--r--recipes-openivi/openivi-html5/openivi-html5/openivi-html5.sh30
-rw-r--r--recipes-openivi/openivi-html5/openivi-html5_git.bb2
2 files changed, 30 insertions, 2 deletions
diff --git a/recipes-openivi/openivi-html5/openivi-html5/openivi-html5.sh b/recipes-openivi/openivi-html5/openivi-html5/openivi-html5.sh
index 190ab653..b6225514 100644
--- a/recipes-openivi/openivi-html5/openivi-html5/openivi-html5.sh
+++ b/recipes-openivi/openivi-html5/openivi-html5/openivi-html5.sh
@@ -22,4 +22,32 @@ if [ -e "$HOMESCREEN_CONFIG" ] ; then
fi
fi
-/usr/bin/openivi-html5 -f -u $HOMESCREEN
+#the following value shall be modified for your display side
+SCREEN_W=1080
+SCREEN_H=1920
+
+# Demo is configured to FullHD
+QT_W=1080
+QT_H=1920
+
+# Ensure that Weston has been fully loaded
+sleep 8
+
+/usr/bin/openivi-html5 -f -u $HOMESCREEN &
+
+# qmlscene create 2 surfaces
+# 0x80000000 : for off screen buffer ?
+# 0x80000001 : visible
+#
+SURFACE_ID_QML=0x80000001
+
+#
+# layer-add-surfaces wait till 2 surfaces are created.
+#
+layer-add-surfaces 1000 2
+
+/usr/bin/LayerManagerControl set surface $SURFACE_ID_QML destination region 0 0 $SCREEN_W $SCREEN_H
+/usr/bin/LayerManagerControl set surface $SURFACE_ID_QML source region 0 0 $QT_W $QT_H
+/usr/bin/LayerManagerControl set layer 1000 render order $SURFACE_ID_QML
+/usr/bin/LayerManagerControl set surfaces $SURFACE_ID_QML input focus keyboard
+/usr/bin/LayerManagerControl set screen 0 render order 1000
diff --git a/recipes-openivi/openivi-html5/openivi-html5_git.bb b/recipes-openivi/openivi-html5/openivi-html5_git.bb
index 1e6a96b2..4418b13b 100644
--- a/recipes-openivi/openivi-html5/openivi-html5_git.bb
+++ b/recipes-openivi/openivi-html5/openivi-html5_git.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4641e94ec96f98fabc56ff9cc48be14b"
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI = " \
- git://github.com/openivimobility/openivi-html5.git;branch=master;tag=7e5d9574758e504b194d16a52e04a1cfe4320138 \
+ git://github.com/openivimobility/openivi-html5.git;branch=master;tag=0b370eea8c7c852365bd717013a523b678abbdba \
file://openivi-html5.sh \
file://openivi-html5.service \
"