summaryrefslogtreecommitdiffstats
path: root/recipes-platform/images/agl-demo-platform.bb
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2016-12-21 18:14:11 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-12-22 22:23:51 +0000
commit32b8cd3398e2f8bdbe02b16b5c24a6ab21c474b0 (patch)
tree7c469df3164270ede98c6a1c9a17dfc140f41a8a /recipes-platform/images/agl-demo-platform.bb
parent49806ebb05a7d77c7e88f541c8d712c5e8a148ef (diff)
Add packages to agl-demo-platform for CES2017 Demo
Adding packages for CES2017 Demo to be incliuded in agl-demo-platform by default. This changes add below apps and related packages: MediaPlayer from apps/mediaplayer Settings from apps/settings HVAC from apps/hvac MOST network VOD Service v4 (jsmoeller): mark drivers as porter specific and conditionalize the inclusion for porter only v3 (jsmoeller): rebase on master v2 (jsmoeller): make can-lin conditional to porter board Change-Id: I4e89607508df2e630f46fcbcb64d4babb66a2d6f Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com> Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-platform/images/agl-demo-platform.bb')
-rw-r--r--recipes-platform/images/agl-demo-platform.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-platform/images/agl-demo-platform.bb b/recipes-platform/images/agl-demo-platform.bb
index c58d22cf..a3878790 100644
--- a/recipes-platform/images/agl-demo-platform.bb
+++ b/recipes-platform/images/agl-demo-platform.bb
@@ -24,6 +24,41 @@ IMAGE_TTF_FONTS = " \
"
# add packages for CES2017 demo
+# Only for porter as these kernel module sources
+# are for the 3.10.x kernel only
+MOST_DRIVERS = " "
+MOST_DRIVERS_append_porter = " \
+ aim-cdev \
+ aim-network \
+ aim-sound \
+ aim-v4l2 \
+ hdm-dim2 \
+ hdm-i2c \
+ hdm-usb \
+ mocca-usb \
+ mostcore \
+ "
+
+# HVAC dependencies depend on drivers above
+IMAGE_MOST_HVAC = " "
+IMAGE_MOST_HVAC_append_porter = " \
+ ${MOST_DRIVERS} \
+ unicens \
+ vod-server \
+ "
+
+# can-lin is a binary and only for porter :(
+IMAGE_MOST_HVAC_append_porter = " \
+ can-lin \
+ "
+
+IMAGE_AGL_APPS = " \
+ hvac \
+ mediaplayer \
+ navigation \
+ settings \
+ "
+
IMAGE_INSTALL_append = " \
ces2017-demo \
linux-firmware-ath9k \
@@ -35,5 +70,7 @@ IMAGE_INSTALL_append = " \
climatecontrolplugin \
navigation \
poiapp \
+ ${IMAGE_MOST_HVAC} \
+ ${IMAGE_AGL_APPS} \
${IMAGE_TTF_FONTS} \
"