summaryrefslogtreecommitdiffstats
path: root/recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-06-05 10:08:59 -0400
committerScott Murray <scott.murray@konsulko.com>2023-06-07 13:33:53 -0400
commit2507e4a69862808a6331b0e4c665b694f49a49b9 (patch)
tree7031fe828a07407a21dcf82dd37fbd1774d5f6af /recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb
parentcce52591f8e00ae41ae380a597d620b0856d004d (diff)
Remove systemd user session and clean up packagegroups and imagespike_15.91.0pike/15.91.015.91.0
Remove the use of systemd user session to align with how upstream runs Weston, and to allow using all systemd sandboxing features with the compositor and homescreen, launcher, etc. applications. The changes for this touched enough packagegroups and images that further rework was done to address some of the cleanup described in SPEC-4813, see below for details. Changes: - Rework systemd units and recipes of affected applications. - Rework images to pull in image .bb files instead of .inc files. - Pull in the new agl-image-compositor as a base image where appropriate. - Update weston-terminal-conf recipe to use new split out weston-terminal package. - Use new agl-crosssdk bbclass where appropriate. - Pull some local common cross-SDK additions into a new agl-ivi-crosssdk.inc include file and use as appropriate. Note that this does have a side effect of likely correcting the contents of agl-image-ivi-crosssdk for some recent additions. - Remove flutter-gallery bbappend that turned it into an app, as we are not using it in images, have other examples now, and it seems better to not affect the contents of agl-image-flutter. - Remove unused agl-image-graphical-html5. If a downstream user does desire an image with Chromium+WAM without applications, restoring it can be considered. - Remove unused agl-image-graphical-qt5-crosssdk. - Remove all packagegroup-agl-profile-* packagegroups, as they were either empty or not providing value at this point. Any future plans for defining profiles can start from a clean sheet. - Added new packagegroup-agl-ivi-multimedia-hardware to hold some rcar3 specific additions (via override) that were previously being appended onto packagegroup-agl-graphical-multimedia even though they are machine-specific and that packagegroup is not. This may be a stopgap solution if the agl-ivi-* packagegroups are reworked further. - Replace some :append usage with += to avoid creating problems for downstream users. Bug-AGL: SPEC-4714, SPEC-4813 Change-Id: I544b1495bed1e2e2412a8e46b7d20d7622ec28c9 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb')
-rw-r--r--recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb48
1 files changed, 7 insertions, 41 deletions
diff --git a/recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb b/recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb
index 3e3d478d..c9ed07a0 100644
--- a/recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb
+++ b/recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb
@@ -1,50 +1,16 @@
require agl-ivi-demo-platform.bb
-SUMMARY = "Cross SDK of Full AGL Distribution for IVI profile"
+SUMMARY = "Cross SDK of demo AGL Distribution for IVI profile"
DESCRIPTION = "SDK image for full AGL Distribution for IVI profile. \
-It includes the full meta-toolchain, plus developement headers and libraries \
-to form a standalone cross SDK."
+It includes the full toolchain, plus development headers and libraries \
+for everything in the demo platform to form a standalone cross SDK."
-require recipes-platform/images/agl-image-minimal-crosssdk.inc
+inherit agl-crosssdk
-# Add wayland-scanner to SDK (SPEC-945)
-# Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
-# wayland-scanner is in nativesdk-wayland-dev !
-# option: add also nativesdk-qtwayland-tools
-TOOLCHAIN_HOST_TASK:append = " nativesdk-wayland nativesdk-wayland-dev"
+require agl-ivi-crosssdk.inc
-TOOLCHAIN_HOST_TASK:append = " nativesdk-perl-modules "
+inherit populate_sdk_qt5
# Add qtwaylandscanner to the SDK
-TOOLCHAIN_HOST_TASK:append = " nativesdk-qtwayland-tools "
-
-# add grpc for building natively for grpc_cpp_plugin
-TOOLCHAIN_HOST_TASK:append = " nativesdk-grpc nativesdk-grpc-dev "
-# Task do_populate_sdk and do_rootfs can't be exec simultaneously.
-# Both exec "createrepo" on the same directory, and so one of them
-# can failed (randomly).
-addtask do_populate_sdk after do_rootfs
-
-inherit populate_sdk populate_sdk_qt5
-
-# Task do_populate_sdk and do_rootfs can't be exec simultaneously.
-# Both exec "createrepo" on the same directory, and so one of them
-# can failed (randomly).
-addtask do_populate_sdk after do_rootfs
-
-# Add gcc-sanitizers to support building applications using the SDK with
-# AddressSanitizer support to detect use-after-frees along with other
-# memory issue.
-TOOLCHAIN_TARGET_TASK += "gcc-sanitizers"
-
-
-TOOLCHAIN_HOST_TASK += " \
- nativesdk-lua \
-"
-
-# Required dependencies for app and test builds
-TOOLCHAIN_TARGET_TASK += " \
- lua-dev \
- lua-staticdev \
-"
+TOOLCHAIN_HOST_TASK += "nativesdk-qtwayland-tools"