summaryrefslogtreecommitdiffstats
path: root/recipes-platform/images
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-12-08 11:03:34 +0900
committerScott Murray <scott.murray@konsulko.com>2022-12-10 07:48:55 +0000
commit18e7f90492c1bc15018ac7b20f166d54454626a9 (patch)
tree088982bcb20110197553eb855052d9e45ec94cd4 /recipes-platform/images
parent65ac0bfdce938aa98b232cbdf42cb84c41257488 (diff)
Update Flutter demo images
Changes: - Split demo image feature definitions into an include file to allow reusing them, and pull into both the Qt and Flutter demo platform images. - Remove packagegroup-agl-demo-platform dependencies from feature packagegroups so they will not break the Flutter images. - Tweak Flutter cluster demo image to have KUKSA.val related package omission be controlled by the "agl-demo-preload" feature. - Add the kuksa-vss-init package to the IVI services packagegroup so that the signal initialization expected by the Flutter cluster dashboard will always be done. This covers the usecase of using the Flutter cluster with KUKSA.val on the IVI board. - Add missing "agl-demo-preload" tweaks from the Qt demo platform image to the Flutter one. - Tweak things to leave out the Weston terminal app from images build with the "agl-demo-preload" feature. - Remove flutter-navigation and flutter-mediaplayer from the Flutter demo image for now, and add the messaging, phone, and radio Qt apps to fill out the list of apps for the demo. Bug-AGL: SPEC-4636, SPEC-4637, SPEC-4639 Change-Id: I9cde89278f0191886152f765d4fb1a893c0ea2c1 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-platform/images')
-rw-r--r--recipes-platform/images/agl-cluster-demo-platform-flutter.bb29
-rw-r--r--recipes-platform/images/agl-demo-features.inc4
-rw-r--r--recipes-platform/images/agl-ivi-demo-platform-flutter.bb3
-rw-r--r--recipes-platform/images/agl-ivi-demo-platform.bb6
4 files changed, 28 insertions, 14 deletions
diff --git a/recipes-platform/images/agl-cluster-demo-platform-flutter.bb b/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
index 07555fd8..a14560c7 100644
--- a/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
+++ b/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
@@ -2,28 +2,37 @@ SUMMARY = "Baseline Flutter Image for Release"
LICENSE = "MIT"
-
require recipes-platform/images/agl-image-weston.inc
+IMAGE_FEATURES += "splash package-management ssh-server-openssh"
+
+# Break out KUKSA.val packages, as demo unit configuration
+# points at KUKSA.val server on the IVI board instead of
+# running the full stack locally.
+IMAGE_KUKSA_PACKAGES = " \
+ kuksa-val \
+ kuksa-val-agl \
+ kuksa-dbc-feeder \
+ kuksa-vss-init \
+"
+
# generic
IMAGE_INSTALL:append = "\
agl-compositor \
agl-compositor-init \
- packagegroup-agl-profile-graphical \
+ ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
\
- kuksa-val \
- kuksa-val-agl \
- kuksa-dbc-feeder \
+ packagegroup-agl-profile-graphical \
+ packagegroup-agl-networking \
\
- kuksa-vss-init \
+ ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "${IMAGE_KUKSA_PACKAGES}", d)} \
simple-can-simulator \
"
-# flutter
+# Flutter
IMAGE_INSTALL:append = "\
- weston-ini-conf-landscape \
- \
- flutter-cluster-dashboard-runtimerelease \
+ flutter-cluster-dashboard \
+ ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "flutter-cluster-dashboard-conf-demo", "flutter-cluster-dashboard-conf", d)} \
flutter-auto-runtimerelease \
"
diff --git a/recipes-platform/images/agl-demo-features.inc b/recipes-platform/images/agl-demo-features.inc
new file mode 100644
index 00000000..beaad0bb
--- /dev/null
+++ b/recipes-platform/images/agl-demo-features.inc
@@ -0,0 +1,4 @@
+FEATURE_PACKAGES_agl-demo-preload = "packagegroup-agl-demo-preload"
+FEATURE_PACKAGES_agl-demo-cluster-support = "packagegroup-agl-demo-cluster-support"
+
+IMAGE_FEATURES += "${@bb.utils.filter("AGL_FEATURES", "agl-demo-preload agl-demo-cluster-support", d)}"
diff --git a/recipes-platform/images/agl-ivi-demo-platform-flutter.bb b/recipes-platform/images/agl-ivi-demo-platform-flutter.bb
index 097c1fd3..336ad3bb 100644
--- a/recipes-platform/images/agl-ivi-demo-platform-flutter.bb
+++ b/recipes-platform/images/agl-ivi-demo-platform-flutter.bb
@@ -2,9 +2,12 @@ require agl-image-ivi.bb
DESCRIPTION = "AGL Flutter based Demo Platform image"
+require agl-demo-features.inc
+
# add packages for demo platform (include demo apps) here
IMAGE_INSTALL:append = " \
packagegroup-agl-demo-platform-flutter \
weston-ini-conf-flutter \
+ ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "weston-terminal-conf", d)} \
"
diff --git a/recipes-platform/images/agl-ivi-demo-platform.bb b/recipes-platform/images/agl-ivi-demo-platform.bb
index d3bda6ae..e82a474e 100644
--- a/recipes-platform/images/agl-ivi-demo-platform.bb
+++ b/recipes-platform/images/agl-ivi-demo-platform.bb
@@ -3,13 +3,11 @@ require agl-image-ivi.bb
DESCRIPTION = "AGL Demo Platform image currently contains a simple HMI and \
demos."
-FEATURE_PACKAGES_agl-demo-preload = "packagegroup-agl-demo-preload"
-FEATURE_PACKAGES_agl-demo-cluster-support = "packagegroup-agl-demo-cluster-support"
-
-IMAGE_FEATURES += "${@bb.utils.filter("AGL_FEATURES", "agl-demo-preload agl-demo-cluster-support", d)}"
+require agl-demo-features.inc
# add packages for demo platform (include demo apps) here
IMAGE_INSTALL:append = " \
packagegroup-agl-demo-platform \
+ ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "weston-terminal-conf", d)} \
"