summaryrefslogtreecommitdiffstats
path: root/recipes-platform/images
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 15:18:49 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 22:43:56 +0100
commit1b72a0f90fa7d1b45eb1017629cc83dcd8971c48 (patch)
treedecc406f376b968d90fade3c321777e068a8c00e /recipes-platform/images
parent94a051785cdb588bc3a475a5490f1f286176d646 (diff)
Prepare master for new framework integration
During the last workshop the transition to the new framework was presented. This change essentially deprecates the SMACK-based application framework. To prepare the integration of it, we remove the deprecated components: - recipes-apis : all agl-service-* - recipes-demos: all demo apps but homescreen - non-essential configurations Todo: We need to bring-back the html5 image in a follow-up w/o ties into the old framework. v2: kept WAM + Chromium recipes for reference v3: rebased Bug-AGL: SPEC-4121 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I58075f5f1e477106a1aad3d2171a0904bf0cb16e
Diffstat (limited to 'recipes-platform/images')
-rw-r--r--recipes-platform/images/agl-cluster-demo-platform-crosssdk.bb27
-rw-r--r--recipes-platform/images/agl-cluster-demo-platform.bb15
-rw-r--r--recipes-platform/images/agl-cluster-demo-platform.inc3
-rw-r--r--recipes-platform/images/agl-cluster-demo-qtcompositor.bb15
-rw-r--r--recipes-platform/images/agl-cluster-demo-qtcompositor.inc2
l---------[-rw-r--r--]recipes-platform/images/agl-demo-platform-crosssdk.bb71
l---------[-rw-r--r--]recipes-platform/images/agl-demo-platform-html5.bb15
-rw-r--r--recipes-platform/images/agl-demo-platform-qa.bb13
l---------[-rw-r--r--]recipes-platform/images/agl-demo-platform.bb21
-rw-r--r--recipes-platform/images/agl-demo-platform.inc8
-rw-r--r--recipes-platform/images/agl-image-cluster-qt5.bb9
-rw-r--r--recipes-platform/images/agl-image-cluster-qt5.inc7
-rw-r--r--recipes-platform/images/agl-image-cluster.bb9
-rw-r--r--recipes-platform/images/agl-image-cluster.inc7
-rw-r--r--recipes-platform/images/agl-image-graphical-html5.bb11
-rw-r--r--recipes-platform/images/agl-image-graphical-html5.inc9
-rwxr-xr-xrecipes-platform/images/agl-image-graphical-qt5-crosssdk.bb18
-rw-r--r--recipes-platform/images/agl-image-graphical-qt5-crosssdk.inc14
-rw-r--r--recipes-platform/images/agl-image-graphical-qt5.bb5
-rw-r--r--recipes-platform/images/agl-image-graphical-qt5.inc1
-rw-r--r--recipes-platform/images/agl-image-ivi-crosssdk.bb13
-rw-r--r--recipes-platform/images/agl-image-ivi-qa.bb14
-rw-r--r--recipes-platform/images/agl-image-ivi.bb13
-rw-r--r--recipes-platform/images/agl-image-ivi.inc15
-rw-r--r--recipes-platform/images/agl-image-telematics.bb9
-rw-r--r--recipes-platform/images/agl-image-telematics.inc5
-rw-r--r--recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb59
-rw-r--r--recipes-platform/images/agl-ivi-demo-platform-html5.bb14
-rw-r--r--recipes-platform/images/agl-ivi-demo-platform.bb13
-rw-r--r--recipes-platform/images/agl-telematics-demo-platform-crosssdk.bb21
-rw-r--r--recipes-platform/images/agl-telematics-demo-platform.bb13
-rw-r--r--recipes-platform/images/agl-telematics-demo-platform.inc3
32 files changed, 139 insertions, 333 deletions
diff --git a/recipes-platform/images/agl-cluster-demo-platform-crosssdk.bb b/recipes-platform/images/agl-cluster-demo-platform-crosssdk.bb
deleted file mode 100644
index 8251272c..00000000
--- a/recipes-platform/images/agl-cluster-demo-platform-crosssdk.bb
+++ /dev/null
@@ -1,27 +0,0 @@
-SUMMARY = "Cross SDK of AGL Distribution for Cluster profile Demo"
-
-DESCRIPTION = "SDK image for AGL Distribution for Cluster profile Demo. \
-It includes the full meta-toolchain, plus developement headers and libraries \
-to form a standalone cross SDK."
-
-require agl-cluster-demo-platform.bb
-
-LICENSE = "MIT"
-
-IMAGE_FEATURES:append = " dev-pkgs"
-IMAGE_INSTALL:append = " kernel-dev kernel-devsrc"
-
-inherit populate_sdk populate_sdk_qt5
-
-# Task do_populate_sdk and do_rootfs can't be exec simultaneously.
-# Both exec "createrepo" on the same directory, and so one of them
-# can failed (randomly).
-addtask do_populate_sdk after do_rootfs
-
-# Add wayland-scanner to SDK (SPEC-945)
-# Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
-# wayland-scanner is in nativesdk-wayland-dev !
-# option: add also nativesdk-qtwayland-tools
-TOOLCHAIN_HOST_TASK:append = " nativesdk-wayland nativesdk-wayland-dev"
-
-TOOLCHAIN_HOST_TASK:append = " nativesdk-perl-modules "
diff --git a/recipes-platform/images/agl-cluster-demo-platform.bb b/recipes-platform/images/agl-cluster-demo-platform.bb
deleted file mode 100644
index 2e8be720..00000000
--- a/recipes-platform/images/agl-cluster-demo-platform.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-DESCRIPTION = "AGL Cluster Demo Platform image currently contains a simple cluster interface."
-
-require agl-cluster-demo-platform.inc
-
-LICENSE = "MIT"
-
-IMAGE_FEATURES:append = ""
-
-# add packages for cluster demo platform (include demo apps) here
-IMAGE_INSTALL:append = " \
- packagegroup-agl-cluster-demo-platform \
- ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "cluster-dashboard-demo-config", "", d)} \
- ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
- "
-
diff --git a/recipes-platform/images/agl-cluster-demo-platform.inc b/recipes-platform/images/agl-cluster-demo-platform.inc
deleted file mode 100644
index 8745ca94..00000000
--- a/recipes-platform/images/agl-cluster-demo-platform.inc
+++ /dev/null
@@ -1,3 +0,0 @@
-# Base image
-require recipes-platform/images/agl-image-cluster-qt5.inc
-
diff --git a/recipes-platform/images/agl-cluster-demo-qtcompositor.bb b/recipes-platform/images/agl-cluster-demo-qtcompositor.bb
deleted file mode 100644
index 0e9afb9c..00000000
--- a/recipes-platform/images/agl-cluster-demo-qtcompositor.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-DESCRIPTION = "AGL Cluster Demo Qtwayland Compositor image currently contains a \
-simple cluster interface and some AGL service."
-
-require agl-cluster-demo-qtcompositor.inc
-
-LICENSE = "MIT"
-
-IMAGE_FEATURES:append = " \
- "
-
-# add packages for cluster demo qtcompositor
-IMAGE_INSTALL:append = " \
- packagegroup-agl-cluster-demo-qtcompositor \
- "
-
diff --git a/recipes-platform/images/agl-cluster-demo-qtcompositor.inc b/recipes-platform/images/agl-cluster-demo-qtcompositor.inc
deleted file mode 100644
index 11c1ebce..00000000
--- a/recipes-platform/images/agl-cluster-demo-qtcompositor.inc
+++ /dev/null
@@ -1,2 +0,0 @@
-# Base image
-require recipes-platform/images/agl-image-cluster-qt5.inc
diff --git a/recipes-platform/images/agl-demo-platform-crosssdk.bb b/recipes-platform/images/agl-demo-platform-crosssdk.bb
index 7f98b41a..70daba00 100644..120000
--- a/recipes-platform/images/agl-demo-platform-crosssdk.bb
+++ b/recipes-platform/images/agl-demo-platform-crosssdk.bb
@@ -1,70 +1 @@
-SUMMARY = "Cross SDK of Full AGL Distribution for IVI profile"
-
-DESCRIPTION = "SDK image for full AGL Distribution for IVI profile. \
-It includes the full meta-toolchain, plus developement headers and libraries \
-to form a standalone cross SDK."
-
-require agl-demo-platform.bb
-
-LICENSE = "MIT"
-
-require agl-image-graphical-qt5-crosssdk.inc
-
-inherit populate_sdk populate_sdk_qt5
-
-# Task do_populate_sdk and do_rootfs can't be exec simultaneously.
-# Both exec "createrepo" on the same directory, and so one of them
-# can failed (randomly).
-addtask do_populate_sdk after do_rootfs
-
-# Add mosquitto to support building the telematics demo application.
-# This is currently required for CI, as it uses agl-demo-platform-crosssdk
-# to build everything. An agenda item has been tabled for the May 2019 F2F
-# meeting to discuss the path forward (separate versus superset SDKs), this
-# should be reviewed after that.
-TOOLCHAIN_TARGET_TASK += "mosquitto-dev"
-
-# Add nlohmann-json to support building the speech services.
-# Required until either the agl-speech-framework feature is added as a
-# dependency of agl-demo, or the speech services are migrated into the
-# core profile.
-TOOLCHAIN_TARGET_TASK += "nlohmann-json-dev"
-
-# Add libstdc++-staticdev to support building agl-service-voice-high or
-# other users of the C++17 filesystem standard library feature.
-# Can be removed upon upgrade to gcc 9.x, as it will no longer be necessary.
-TOOLCHAIN_TARGET_TASK += "libstdc++-staticdev"
-
-# Add gcc-sanitizers to support building applications using the SDK with
-# AddressSanitizer support to detect use-after-frees along with other
-# memory issue.
-TOOLCHAIN_TARGET_TASK += "gcc-sanitizers"
-
-# Add azure-iot-sdk-c to support building agl-service-cloudproxy
-# and other users of Azure sdk.
-TOOLCHAIN_TARGET_TASK += "azure-iot-sdk-c umock-c"
-
-# Add mbedTLS to support building aws-iot-device-sdk-embedded-c
-TOOLCHAIN_TARGET_TASK += "mbedtls"
-
-# Add aws-iot-device-embedded-c sdk to support building agl-service-cloudproxy
-# and other users of AWS sdk.
-# These packages are required to add static library and headers:
-TOOLCHAIN_TARGET_TASK += "aws-iot-device-sdk-embedded-c-staticdev"
-TOOLCHAIN_TARGET_TASK += "aws-iot-device-sdk-embedded-c-dev"
-
-TOOLCHAIN_TARGET_TASK += "waltham-dev"
-
-
-# Required dependencies for app and test builds
-TOOLCHAIN_HOST_TASK += " \
- nativesdk-lua \
- "
-
-# Required dependencies for app and test builds
-TOOLCHAIN_TARGET_TASK += " \
- lua-dev \
- lua-staticdev \
- libafb-helpers-staticdev \
- libappcontroller-staticdev \
- " \ No newline at end of file
+agl-ivi-demo-platform-crosssdk.bb \ No newline at end of file
diff --git a/recipes-platform/images/agl-demo-platform-html5.bb b/recipes-platform/images/agl-demo-platform-html5.bb
index a78b8b68..fabf5e35 100644..120000
--- a/recipes-platform/images/agl-demo-platform-html5.bb
+++ b/recipes-platform/images/agl-demo-platform-html5.bb
@@ -1,14 +1 @@
-SUMMARY = "DEMO platform of AGL HTML5 profile"
-DESCRIPTION = "Contains the web runtime and sample web apps"
-
-require agl-demo-platform.inc
-
-LICENSE = "MIT"
-
-IMAGE_FEATURES:append = " \
- "
-
-# add packages for demo platform (include demo apps) here
-IMAGE_INSTALL:append = " \
- packagegroup-agl-demo-platform-html5 \
- "
+agl-ivi-demo-platform-html5.bb \ No newline at end of file
diff --git a/recipes-platform/images/agl-demo-platform-qa.bb b/recipes-platform/images/agl-demo-platform-qa.bb
deleted file mode 100644
index 05598ca7..00000000
--- a/recipes-platform/images/agl-demo-platform-qa.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-SUMMARY = "A full set of AGL Distribution for testing as Quality Assurance"
-
-DESCRIPTION = "A full set of AGL Distribution. This image also has additional \
-packages (e.g. commandline tools) for Quality Assurance(QA)."
-
-LICENSE = "MIT"
-
-require agl-demo-platform.bb
-
-IMAGE_INSTALL:append = " \
- packagegroup-ivi-common-test \
- packagegroup-agl-demo-platform-qa \
- "
diff --git a/recipes-platform/images/agl-demo-platform.bb b/recipes-platform/images/agl-demo-platform.bb
index 5643d4da..ff29cf3e 100644..120000
--- a/recipes-platform/images/agl-demo-platform.bb
+++ b/recipes-platform/images/agl-demo-platform.bb
@@ -1,20 +1 @@
-DESCRIPTION = "AGL Demo Platform image currently contains a simple HMI and \
-demos."
-
-require agl-demo-platform.inc
-
-LICENSE = "MIT"
-
-# The demo will not work on the pi3 due to the gfx memory
-# and the applications requiring FHD (SPEC-390)
-COMPATIBLE_MACHINE:raspberrypi3 = "(^$)"
-
-# Always include the test widgets
-IMAGE_FEATURES:append = " agl-test-wgt"
-
-# add packages for demo platform (include demo apps) here
-IMAGE_INSTALL:append = " \
- packagegroup-agl-demo-platform \
- distro-build-manifest \
- "
-
+agl-ivi-demo-platform.bb \ No newline at end of file
diff --git a/recipes-platform/images/agl-demo-platform.inc b/recipes-platform/images/agl-demo-platform.inc
deleted file mode 100644
index e901409a..00000000
--- a/recipes-platform/images/agl-demo-platform.inc
+++ /dev/null
@@ -1,8 +0,0 @@
-# Base image
-require agl-image-ivi.inc
-
-# Pull in speech framework bits
-IMAGE_FEATURES += "agl-speech-framework"
-
-# Pull in Alexa voiceagent if configured
-IMAGE_FEATURES += "${@bb.utils.filter("AGL_FEATURES", "agl-voiceagent-alexa", d)}"
diff --git a/recipes-platform/images/agl-image-cluster-qt5.bb b/recipes-platform/images/agl-image-cluster-qt5.bb
deleted file mode 100644
index ec4c9876..00000000
--- a/recipes-platform/images/agl-image-cluster-qt5.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-SUMMARY = "A basic Wayland based cluster image with Qt5 support"
-
-require agl-image-cluster-qt5.inc
-
-LICENSE = "MIT"
-
-IMAGE_INSTALL:append = "\
- profile-cluster-qt5 \
- "
diff --git a/recipes-platform/images/agl-image-cluster-qt5.inc b/recipes-platform/images/agl-image-cluster-qt5.inc
deleted file mode 100644
index 93826aa4..00000000
--- a/recipes-platform/images/agl-image-cluster-qt5.inc
+++ /dev/null
@@ -1,7 +0,0 @@
-require recipes-platform/images/agl-image-boot.inc
-
-IMAGE_FEATURES += "splash package-management ssh-server-dropbear"
-
-inherit features_check
-
-REQUIRED_DISTRO_FEATURES = "wayland"
diff --git a/recipes-platform/images/agl-image-cluster.bb b/recipes-platform/images/agl-image-cluster.bb
deleted file mode 100644
index c4e33e33..00000000
--- a/recipes-platform/images/agl-image-cluster.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-SUMMARY = "A basic Wayland based cluster image"
-
-require agl-image-cluster.inc
-
-LICENSE = "MIT"
-
-IMAGE_INSTALL:append = "\
- profile-cluster \
- "
diff --git a/recipes-platform/images/agl-image-cluster.inc b/recipes-platform/images/agl-image-cluster.inc
deleted file mode 100644
index 93826aa4..00000000
--- a/recipes-platform/images/agl-image-cluster.inc
+++ /dev/null
@@ -1,7 +0,0 @@
-require recipes-platform/images/agl-image-boot.inc
-
-IMAGE_FEATURES += "splash package-management ssh-server-dropbear"
-
-inherit features_check
-
-REQUIRED_DISTRO_FEATURES = "wayland"
diff --git a/recipes-platform/images/agl-image-graphical-html5.bb b/recipes-platform/images/agl-image-graphical-html5.bb
index 4ca67634..c25a9275 100644
--- a/recipes-platform/images/agl-image-graphical-html5.bb
+++ b/recipes-platform/images/agl-image-graphical-html5.bb
@@ -1,6 +1,15 @@
SUMMARY = "An image containing all packages required to run web applications"
-require agl-image-graphical-html5.inc
+require recipes-platform/images/agl-image-minimal.inc
+
+IMAGE_FEATURES += "splash"
+
+IMAGE_FEATURES += "${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'ssh-server-dropbear' , '', d)}"
+
+inherit features_check
+
+REQUIRED_DISTRO_FEATURES = "wayland"
+
LICENSE = "MIT"
diff --git a/recipes-platform/images/agl-image-graphical-html5.inc b/recipes-platform/images/agl-image-graphical-html5.inc
deleted file mode 100644
index e943b990..00000000
--- a/recipes-platform/images/agl-image-graphical-html5.inc
+++ /dev/null
@@ -1,9 +0,0 @@
-require recipes-platform/images/agl-image-minimal.inc
-
-IMAGE_FEATURES += "splash"
-
-IMAGE_FEATURES += "${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'ssh-server-dropbear' , '', d)}"
-
-inherit features_check
-
-REQUIRED_DISTRO_FEATURES = "wayland"
diff --git a/recipes-platform/images/agl-image-graphical-qt5-crosssdk.bb b/recipes-platform/images/agl-image-graphical-qt5-crosssdk.bb
index 5147ea44..596ac80e 100755
--- a/recipes-platform/images/agl-image-graphical-qt5-crosssdk.bb
+++ b/recipes-platform/images/agl-image-graphical-qt5-crosssdk.bb
@@ -4,11 +4,25 @@ DESCRIPTION = "SDK image for full AGL Distribution for IVI profile. \
It includes the full meta-toolchain, plus developement headers and libraries \
to form a standalone cross SDK."
-require agl-image-graphical-qt5.bb
+#require agl-image-graphical-qt5.bb
+require recipes-platform/images/agl-image-weston.inc
+
LICENSE = "MIT"
-require agl-image-graphical-qt5-crosssdk.inc
+require recipes-platform/images/agl-image-minimal-crosssdk.inc
+
+# Add wayland-scanner to SDK (SPEC-945)
+# Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
+# wayland-scanner is in nativesdk-wayland-dev !
+# option: add also nativesdk-qtwayland-tools
+TOOLCHAIN_HOST_TASK:append = " nativesdk-wayland nativesdk-wayland-dev"
+
+TOOLCHAIN_HOST_TASK:append = " nativesdk-perl-modules "
+
+# Add qtwaylandscanner to the SDK
+TOOLCHAIN_HOST_TASK:append = " nativesdk-qtwayland-tools "
+
inherit populate_sdk populate_sdk_qt5
diff --git a/recipes-platform/images/agl-image-graphical-qt5-crosssdk.inc b/recipes-platform/images/agl-image-graphical-qt5-crosssdk.inc
deleted file mode 100644
index 760cbac0..00000000
--- a/recipes-platform/images/agl-image-graphical-qt5-crosssdk.inc
+++ /dev/null
@@ -1,14 +0,0 @@
-require recipes-platform/images/agl-image-minimal-crosssdk.inc
-
-TOOLCHAIN_TARGET_TASK += "libafb-helpers-qt-staticdev"
-
-# Add wayland-scanner to SDK (SPEC-945)
-# Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
-# wayland-scanner is in nativesdk-wayland-dev !
-# option: add also nativesdk-qtwayland-tools
-TOOLCHAIN_HOST_TASK:append = " nativesdk-wayland nativesdk-wayland-dev"
-
-TOOLCHAIN_HOST_TASK:append = " nativesdk-perl-modules "
-
-# Add qtwaylandscanner to the SDK
-TOOLCHAIN_HOST_TASK:append = " nativesdk-qtwayland-tools "
diff --git a/recipes-platform/images/agl-image-graphical-qt5.bb b/recipes-platform/images/agl-image-graphical-qt5.bb
deleted file mode 100644
index bcfd724f..00000000
--- a/recipes-platform/images/agl-image-graphical-qt5.bb
+++ /dev/null
@@ -1,5 +0,0 @@
-SUMMARY = "A very basic Wayland image with a terminal"
-
-require agl-image-graphical-qt5.inc
-
-LICENSE = "MIT"
diff --git a/recipes-platform/images/agl-image-graphical-qt5.inc b/recipes-platform/images/agl-image-graphical-qt5.inc
deleted file mode 100644
index 114d06a0..00000000
--- a/recipes-platform/images/agl-image-graphical-qt5.inc
+++ /dev/null
@@ -1 +0,0 @@
-require recipes-platform/images/agl-image-weston.inc
diff --git a/recipes-platform/images/agl-image-ivi-crosssdk.bb b/recipes-platform/images/agl-image-ivi-crosssdk.bb
index 72bf8f7b..9636b609 100644
--- a/recipes-platform/images/agl-image-ivi-crosssdk.bb
+++ b/recipes-platform/images/agl-image-ivi-crosssdk.bb
@@ -1,5 +1,16 @@
require recipes-platform/images/agl-image-minimal-crosssdk.inc
-require agl-image-ivi.inc
+
+require recipes-platform/images/agl-image-minimal.inc
+
+IMAGE_INSTALL:append = "\
+ packagegroup-agl-image-ivi \
+ packagegroup-agl-ivi-services \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'packagegroup-pipewire', '', d)} \
+ can-utils \
+ iproute2 \
+ "
+
+IMAGE_FEATURES += "splash package-management ssh-server-dropbear"
inherit populate_sdk
diff --git a/recipes-platform/images/agl-image-ivi-qa.bb b/recipes-platform/images/agl-image-ivi-qa.bb
deleted file mode 100644
index 2a1dd1a0..00000000
--- a/recipes-platform/images/agl-image-ivi-qa.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-SUMMARY = "A basic system of AGL distribution of IVI profile for Quality Assurance(QA)"
-
-DESCRIPTION = "A basic set of AGL Distribution. This image also has additional \
-packages (e.g. commandline tools) for Quality Assurance(QA)."
-
-require agl-image-ivi.bb
-
-LICENSE = "MIT"
-
-IMAGE_INSTALL:append = " \
- packagegroup-agl-test \
- packagegroup-ivi-common-test \
- "
-
diff --git a/recipes-platform/images/agl-image-ivi.bb b/recipes-platform/images/agl-image-ivi.bb
index b3c72de0..198d3fe3 100644
--- a/recipes-platform/images/agl-image-ivi.bb
+++ b/recipes-platform/images/agl-image-ivi.bb
@@ -2,7 +2,18 @@ SUMMARY = "A basic system of AGL distribution of IVI profile"
DESCRIPTION = "Basic image for baseline of AGL Distribution for IVI profile."
-require agl-image-ivi.inc
+require recipes-platform/images/agl-image-minimal.inc
+
+IMAGE_INSTALL:append = "\
+ packagegroup-agl-image-ivi \
+ packagegroup-agl-ivi-services \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'packagegroup-pipewire', '', d)} \
+ can-utils \
+ iproute2 \
+ "
+
+IMAGE_FEATURES += "splash package-management ssh-server-dropbear"
+
LICENSE = "MIT"
diff --git a/recipes-platform/images/agl-image-ivi.inc b/recipes-platform/images/agl-image-ivi.inc
deleted file mode 100644
index 0f6b1e55..00000000
--- a/recipes-platform/images/agl-image-ivi.inc
+++ /dev/null
@@ -1,15 +0,0 @@
-require recipes-platform/images/agl-image-minimal.inc
-
-IMAGE_INSTALL:append = "\
- packagegroup-agl-image-ivi \
- packagegroup-agl-ivi-services \
- agl-service-homescreen \
- agl-service-weather \
- ${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'packagegroup-pipewire', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'agl-service-mediaplayer', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'agl-service-radio', '', d)} \
- can-utils \
- iproute2 \
- "
-
-IMAGE_FEATURES += "splash package-management ssh-server-dropbear"
diff --git a/recipes-platform/images/agl-image-telematics.bb b/recipes-platform/images/agl-image-telematics.bb
deleted file mode 100644
index 94dd6098..00000000
--- a/recipes-platform/images/agl-image-telematics.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-SUMMARY = "A basic telematics image"
-
-require agl-image-telematics.inc
-
-LICENSE = "MIT"
-
-IMAGE_INSTALL:append = "\
- profile-telematics \
- "
diff --git a/recipes-platform/images/agl-image-telematics.inc b/recipes-platform/images/agl-image-telematics.inc
deleted file mode 100644
index 3e951550..00000000
--- a/recipes-platform/images/agl-image-telematics.inc
+++ /dev/null
@@ -1,5 +0,0 @@
-require recipes-platform/images/agl-image-boot.inc
-
-inherit features_check
-
-REQUIRED_DISTRO_FEATURES = "3g"
diff --git a/recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb b/recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb
new file mode 100644
index 00000000..49004763
--- /dev/null
+++ b/recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb
@@ -0,0 +1,59 @@
+SUMMARY = "Cross SDK of Full AGL Distribution for IVI profile"
+
+DESCRIPTION = "SDK image for full AGL Distribution for IVI profile. \
+It includes the full meta-toolchain, plus developement headers and libraries \
+to form a standalone cross SDK."
+
+
+# add packages for demo platform (include demo apps) here
+IMAGE_INSTALL:append = " \
+ packagegroup-agl-demo-platform \
+ "
+
+LICENSE = "MIT"
+
+#require agl-image-graphical-qt5-crosssdk.inc
+require recipes-platform/images/agl-image-weston.inc
+require recipes-platform/images/agl-image-minimal-crosssdk.inc
+
+# Add wayland-scanner to SDK (SPEC-945)
+# Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
+# wayland-scanner is in nativesdk-wayland-dev !
+# option: add also nativesdk-qtwayland-tools
+TOOLCHAIN_HOST_TASK:append = " nativesdk-wayland nativesdk-wayland-dev"
+
+TOOLCHAIN_HOST_TASK:append = " nativesdk-perl-modules "
+
+# Add qtwaylandscanner to the SDK
+TOOLCHAIN_HOST_TASK:append = " nativesdk-qtwayland-tools "
+
+
+# Task do_populate_sdk and do_rootfs can't be exec simultaneously.
+# Both exec "createrepo" on the same directory, and so one of them
+# can failed (randomly).
+addtask do_populate_sdk after do_rootfs
+
+inherit populate_sdk populate_sdk_qt5
+
+# Task do_populate_sdk and do_rootfs can't be exec simultaneously.
+# Both exec "createrepo" on the same directory, and so one of them
+# can failed (randomly).
+addtask do_populate_sdk after do_rootfs
+
+# Add gcc-sanitizers to support building applications using the SDK with
+# AddressSanitizer support to detect use-after-frees along with other
+# memory issue.
+TOOLCHAIN_TARGET_TASK += "gcc-sanitizers"
+
+TOOLCHAIN_TARGET_TASK += "waltham-dev"
+
+
+TOOLCHAIN_HOST_TASK += " \
+ nativesdk-lua \
+ "
+
+# Required dependencies for app and test builds
+TOOLCHAIN_TARGET_TASK += " \
+ lua-dev \
+ lua-staticdev \
+ " \ No newline at end of file
diff --git a/recipes-platform/images/agl-ivi-demo-platform-html5.bb b/recipes-platform/images/agl-ivi-demo-platform-html5.bb
new file mode 100644
index 00000000..bef66eb3
--- /dev/null
+++ b/recipes-platform/images/agl-ivi-demo-platform-html5.bb
@@ -0,0 +1,14 @@
+SUMMARY = "DEMO platform of AGL HTML5 profile"
+DESCRIPTION = "Contains the web runtime and sample web apps"
+
+require agl-image-ivi.bb
+
+LICENSE = "MIT"
+
+IMAGE_FEATURES:append = " \
+ "
+
+# add packages for demo platform (include demo apps) here
+IMAGE_INSTALL:append = " \
+ packagegroup-agl-demo-platform-html5 \
+ "
diff --git a/recipes-platform/images/agl-ivi-demo-platform.bb b/recipes-platform/images/agl-ivi-demo-platform.bb
new file mode 100644
index 00000000..78a6b2c2
--- /dev/null
+++ b/recipes-platform/images/agl-ivi-demo-platform.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "AGL Demo Platform image currently contains a simple HMI and \
+demos."
+
+require agl-image-ivi.bb
+
+
+LICENSE = "MIT"
+
+# add packages for demo platform (include demo apps) here
+IMAGE_INSTALL:append = " \
+ packagegroup-agl-demo-platform \
+ "
+
diff --git a/recipes-platform/images/agl-telematics-demo-platform-crosssdk.bb b/recipes-platform/images/agl-telematics-demo-platform-crosssdk.bb
deleted file mode 100644
index a3efec42..00000000
--- a/recipes-platform/images/agl-telematics-demo-platform-crosssdk.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-SUMMARY = "Cross SDK of AGL Distribution for telematics profile Demo"
-
-DESCRIPTION = "SDK image for AGL Distribution for Telematics profile Demo. \
-It includes the full meta-toolchain, plus developement headers and libraries \
-to form a standalone cross SDK."
-
-require agl-telematics-demo-platform.bb
-
-LICENSE = "MIT"
-
-IMAGE_FEATURES:append = " dev-pkgs"
-IMAGE_INSTALL:append = " kernel-dev kernel-devsrc"
-
-inherit populate_sdk
-
-# Task do_populate_sdk and do_rootfs can't be exec simultaneously.
-# Both exec "createrepo" on the same directory, and so one of them
-# can failed (randomly).
-addtask do_populate_sdk after do_rootfs
-
-TOOLCHAIN_HOST_TASK:append = " nativesdk-perl-modules "
diff --git a/recipes-platform/images/agl-telematics-demo-platform.bb b/recipes-platform/images/agl-telematics-demo-platform.bb
deleted file mode 100644
index 41ae11b3..00000000
--- a/recipes-platform/images/agl-telematics-demo-platform.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-DESCRIPTION = "AGL Telematics Demo Platform image."
-
-require agl-telematics-demo-platform.inc
-
-LICENSE = "MIT"
-
-IMAGE_FEATURES:append = " \
- "
-
-IMAGE_INSTALL:append = " \
- packagegroup-agl-telematics-demo-platform \
- "
-
diff --git a/recipes-platform/images/agl-telematics-demo-platform.inc b/recipes-platform/images/agl-telematics-demo-platform.inc
deleted file mode 100644
index bd3a89ee..00000000
--- a/recipes-platform/images/agl-telematics-demo-platform.inc
+++ /dev/null
@@ -1,3 +0,0 @@
-# Base image
-require recipes-platform/images/agl-image-telematics.inc
-