summaryrefslogtreecommitdiffstats
path: root/recipes-platform/images
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-01-12 16:41:29 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-01-13 20:33:53 +0000
commitd7d6c8622195aaf83bd66b53dec231d7b1c30bf1 (patch)
tree47c21ec8d25507f644507e413ce7608370eb9dd2 /recipes-platform/images
parente9ec6a99e6c1549a17d1eb36175fe437f69ce327 (diff)
Remove separate agl-{cluster,telematics}-demo features
Changes: - Remove feature templates and associated include files for the agl-cluster-demo and agl-telematics-demo features. All of the demo images can now be built by just configuring with the agl-demo feature. - Remove feature template for agl-cluster-demo-preload, the cluster demo configuration it was pulling into the cluster image is now driven by the agl-demo-preload feature instead. - Moved speech framework and Alexa voiceagent feature inclusion to agl-demo-platform.inc to avoid them accidentally being pulled into the cluster or telematics demo images. Part of this change is moving agl-voiceagent-alexa from using IMAGE_FEATURES to AGL_FEATURES, which needs a corresponding change to meta-agl-devel. - Remove leftover use of agl-core-image-profile DISTRO_FEATURE, which no longer exists. - Remove unneeded explicit dependency on the PREFERRED_RPROVIDER_virtual/voice-high-config, things seem to be working fine with the dependency from agl-service-voice-high, so it is not required. Bug-AGL: SPEC-3749 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ibcfbce28231a91aa56269db9196c471458d0e928
Diffstat (limited to 'recipes-platform/images')
-rw-r--r--recipes-platform/images/agl-cluster-demo-platform.bb4
-rw-r--r--recipes-platform/images/agl-demo-platform.inc6
-rw-r--r--recipes-platform/images/agl-image-ivi.inc1
3 files changed, 8 insertions, 3 deletions
diff --git a/recipes-platform/images/agl-cluster-demo-platform.bb b/recipes-platform/images/agl-cluster-demo-platform.bb
index 52d737b7..9af32ee4 100644
--- a/recipes-platform/images/agl-cluster-demo-platform.bb
+++ b/recipes-platform/images/agl-cluster-demo-platform.bb
@@ -4,11 +4,11 @@ require agl-cluster-demo-platform.inc
LICENSE = "MIT"
-IMAGE_FEATURES_append = " \
- "
+IMAGE_FEATURES_append = ""
# add packages for cluster demo platform (include demo apps) here
IMAGE_INSTALL_append = " \
packagegroup-agl-cluster-demo-platform \
+ ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "cluster-dashboard-demo-config", "", d)} \
"
diff --git a/recipes-platform/images/agl-demo-platform.inc b/recipes-platform/images/agl-demo-platform.inc
index f363e304..e901409a 100644
--- a/recipes-platform/images/agl-demo-platform.inc
+++ b/recipes-platform/images/agl-demo-platform.inc
@@ -1,2 +1,8 @@
# Base image
require agl-image-ivi.inc
+
+# Pull in speech framework bits
+IMAGE_FEATURES += "agl-speech-framework"
+
+# Pull in Alexa voiceagent if configured
+IMAGE_FEATURES += "${@bb.utils.filter("AGL_FEATURES", "agl-voiceagent-alexa", d)}"
diff --git a/recipes-platform/images/agl-image-ivi.inc b/recipes-platform/images/agl-image-ivi.inc
index 95b6ca68..6aa961bc 100644
--- a/recipes-platform/images/agl-image-ivi.inc
+++ b/recipes-platform/images/agl-image-ivi.inc
@@ -13,4 +13,3 @@ IMAGE_INSTALL_append = "\
"
IMAGE_FEATURES += "splash package-management ssh-server-dropbear"
-DISTRO_FEATURES_append = " agl-core-image-profile"