summaryrefslogtreecommitdiffstats
path: root/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 15:18:49 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 22:43:56 +0100
commit1b72a0f90fa7d1b45eb1017629cc83dcd8971c48 (patch)
treedecc406f376b968d90fade3c321777e068a8c00e /recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
parent94a051785cdb588bc3a475a5490f1f286176d646 (diff)
Prepare master for new framework integration
During the last workshop the transition to the new framework was presented. This change essentially deprecates the SMACK-based application framework. To prepare the integration of it, we remove the deprecated components: - recipes-apis : all agl-service-* - recipes-demos: all demo apps but homescreen - non-essential configurations Todo: We need to bring-back the html5 image in a follow-up w/o ties into the old framework. v2: kept WAM + Chromium recipes for reference v3: rebased Bug-AGL: SPEC-4121 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I58075f5f1e477106a1aad3d2171a0904bf0cb16e
Diffstat (limited to 'recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb')
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb33
1 files changed, 18 insertions, 15 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
index ac82d73c..d0c81c6a 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
@@ -1,34 +1,37 @@
-SUMMARY = "The software for DEMO platform of AGL HTML5 profile"
-DESCRIPTION = "Packages required to demo the HTML5 profile and sample web apps"
+SUMMARY = "The software for DEMO platform of AGL IVI profile"
+DESCRIPTION = "A set of packages belong to AGL Demo Platform"
LICENSE = "MIT"
inherit packagegroup
+PROVIDES = "${PACKAGES}"
PACKAGES = "\
packagegroup-agl-demo-platform-html5 \
+ packagegroup-agl-demo-platform-html5-devel \
"
ALLOW_EMPTY:${PN} = "1"
RDEPENDS:${PN} += "\
packagegroup-agl-image-ivi \
- packagegroup-agl-profile-graphical-html5 \
- packagegroup-agl-demo \
"
-AGL_APPS = " \
- html5-homescreen \
- html5-launcher \
- html5-hvac \
- html5-settings \
- html5-mixer \
- html5-mediaplayer \
- html5-dashboard \
- html5-background \
+RDEPENDS:${PN} += "\
+ packagegroup-hmi-framework \
"
+
RDEPENDS:${PN}:append = " \
- weston-ini-conf-landscape \
- ${AGL_APPS} \
+ weston-ini-conf \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
+ "
+
+# NOTE: Currently no coverage versions for the application widgets,
+# they should be added here when available.
+# Also, the navigation and mixer debug widgets are currently
+# specified explicitly, as there's no simple way to derive their
+# names from the virtual/ RPROVIDES at present.
+RDEPENDS:${PN}-devel = " \
+ packagegroup-hmi-framework-devel \
"