summaryrefslogtreecommitdiffstats
path: root/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-20 13:58:45 -0400
committerScott Murray <scott.murray@konsulko.com>2021-08-20 15:51:10 -0400
commit4249268041b879b3d2bae338d5de88f4f2d54b26 (patch)
tree757fd0c2daef3e0ccea1a12c27f900defaea2827 /recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
parente89376af34201168a3e8d3fe72258b587edb7d71 (diff)
Convert to new override syntax
This is the result of running a slightly customized version of the convert-overrides.py script from poky with additional overrides added. The intent of these changes is to minimize the effort to keep the "next" branch that builds against poky master up to date and tested in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4052 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I6eeadd2c985c008b04f8f9815bf0f6fb064bedac
Diffstat (limited to 'recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb')
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
index 72e5d7a6..6fec1fc5 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
@@ -11,13 +11,13 @@ PACKAGES = "\
packagegroup-agl-demo-platform-devel \
"
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
-RDEPENDS_${PN} += "\
+RDEPENDS:${PN} += "\
packagegroup-agl-image-ivi \
"
-RDEPENDS_${PN} += "\
+RDEPENDS:${PN} += "\
packagegroup-agl-profile-graphical-qt5 \
packagegroup-hmi-framework \
packagegroup-agl-demo \
@@ -42,7 +42,7 @@ AGL_APPS = " \
QTAGLEXTRAS = " libqtappfw"
# add support for websocket in Qt and QML
-QTAGLEXTRAS_append = " qtwebsockets qtwebsockets-qmlplugins"
+QTAGLEXTRAS:append = " qtwebsockets qtwebsockets-qmlplugins"
#PREFERRED_PROVIDER_virtual/webruntime = "web-runtime"
# Cluster demo support.
@@ -66,7 +66,7 @@ DEMO_UNIT_CONF += " demo-i2c-udev-conf "
# Preload only if agl-demo-preload is set
DEMO_PRELOAD = "${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", " ${DEMO_UNIT_CONF} poiapp-api-key", "",d)}"
-RDEPENDS_${PN}_append = " \
+RDEPENDS:${PN}:append = " \
weston-ini-conf \
qtquickcontrols2-agl \
qtquickcontrols2-agl-style \
@@ -82,7 +82,7 @@ RDEPENDS_${PN}_append = " \
# Also, the navigation and mixer debug widgets are currently
# specified explicitly, as there's no simple way to derive their
# names from the virtual/ RPROVIDES at present.
-RDEPENDS_${PN}-devel = " \
+RDEPENDS:${PN}-devel = " \
packagegroup-hmi-framework-devel \
dashboard-dbg \
hvac-dbg \