summaryrefslogtreecommitdiffstats
path: root/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-10-20 13:19:19 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-10-21 16:25:57 +0000
commita3275fc08f5c8808aec3c33895c57f3f45322f61 (patch)
tree662b44dc5b31770ea8f6ffc0c74fd1bc1c1258ce /recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
parent1d7fe07ecc136cc0da9b25f57c2f599044c92f4c (diff)
Add tbtnavi cluster navigation application
Add recipe for tbtnavi turn by turn navigation application for use on cluster remote display, and update packagegroup-agl-demo-platform to pull it in when PREFERRED_RPROVIDER_virtual/navigation is ondemandnavi (the default) and the agl-cluster-demo-support feature is enabled. Bug-AGL: SPEC-2913 Change-Id: I0280fe3a2fbd3ff58a028232560b421e83baa887 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb')
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
index d0de2bfc..7e57b63c 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
@@ -69,15 +69,14 @@ AGL_APIS = " \
QTAGLEXTRAS = "${@bb.utils.contains("DISTRO_FEATURES", "agl-hmi-framework", " qtaglextras", "",d)}"
# Cluster demo support.
-# ATM mapviewer is required for navigation map viewing when doing cluster
-# demos with the older navigation application.
-MAPVIEWER = "${@bb.utils.contains("PREFERRED_PROVIDER_virtual/navigation", "navigation", "mapviewer", "",d)}"
+# ATM no cluster map viewer is supported with the older navigation application.
+MAPVIEWER = "${@bb.utils.contains("PREFERRED_RPROVIDER_virtual/navigation", "ondemandnavi", "tbtnavi", "",d)}"
CLUSTER_SUPPORT = "${@bb.utils.contains("DISTRO_FEATURES", "agl-cluster-demo-support", "${MAPVIEWER} cluster-demo-network-config", "",d)}"
# Preload poi API key for demo if requested, and potentially maps for older
# navigation application if it is configured.
DEMO_MAPS_LOCALE ?= "uk"
-DEMO_PRELOAD_MAPS = "${@bb.utils.contains("PREFERRED_PROVIDER_virtual/navigation", "navigation", " navigation-maps-${DEMO_MAPS_LOCALE}", "",d)}"
+DEMO_PRELOAD_MAPS = "${@bb.utils.contains("PREFERRED_RPROVIDER_virtual/navigation", "navigation", " navigation-maps-${DEMO_MAPS_LOCALE}", "",d)}"
DEMO_PRELOAD = "${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", " ${DEMO_PRELOAD_MAPS} poiapp-api-key", "",d)}"
# Hook for demo platform configuration