summaryrefslogtreecommitdiffstats
path: root/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-08-30 14:18:23 -0400
committerScott Murray <scott.murray@konsulko.com>2019-09-02 15:00:55 +0000
commitf19f2f6572adf3825e60ceb5e18e3e35d1995bec (patch)
tree780b84b6f18440838cadae532904374b8352ada5 /recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
parent80f21c014fc13dbd624e3ed6346b3d991615e28c (diff)
Update demo features for switch to ondemandnavihalibut_8.0.1halibut/8.0.18.0.1
The ondemandnavi navigation application does not work with the mapviewer cluster demo application, so update the logic to handle the agl-cluster-demo-support feature in packagegroup-agl-demo-platform to not pull it in when using ondemandnavi as the virtual/navigation provider. Since the plan is to replace mapviewer with an equivalent QtLocation based map streamer for the cluster demo, the mapviewer-demo recipe has also been replaced with a more generically named cluster-demo-network-config recipe. Additionally, the agl-demo-preload feature logic has been tweaked to not pull in the map package for the old navigation application when using ondemandnavi. Bug-AGL: SPEC-2576 Change-Id: I57b45ab152f9fab6cee97d570be1949136cd39eb Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb')
-rw-r--r--[-rwxr-xr-x]recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb17
1 files changed, 11 insertions, 6 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
index a9740509..128d4d7e 100755..100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
@@ -59,12 +59,17 @@ AGL_APIS = " \
QTAGLEXTRAS = "${@bb.utils.contains("DISTRO_FEATURES", "agl-hmi-framework", " qtaglextras", "",d)}"
-# mapviewer and mapviewer-demo are required for AGL cluster demo
-MAPVIEWER = "${@bb.utils.contains("DISTRO_FEATURES", "agl-cluster-demo-support", " mapviewer mapviewer-demo", "",d)}"
-
-# Preload navigation maps and poi API key for demo if requested
+# Cluster demo support.
+# ATM mapviewer is required for navigation map viewing when doing cluster
+# demos with the older navigation application.
+MAPVIEWER = "${@bb.utils.contains("PREFERRED_PROVIDER_virtual/navigation", "navigation", "mapviewer", "",d)}"
+CLUSTER_SUPPORT = "${@bb.utils.contains("DISTRO_FEATURES", "agl-cluster-demo-support", "${MAPVIEWER} cluster-demo-network-config", "",d)}"
+
+# Preload poi API key for demo if requested, and potentially maps for older
+# navigation application if it is configured.
DEMO_MAPS_LOCALE ?= "uk"
-DEMO_PRELOAD = "${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", " navigation-maps-${DEMO_MAPS_LOCALE} poiapp-api-key", "",d)}"
+DEMO_PRELOAD_MAPS = "${@bb.utils.contains("PREFERRED_PROVIDER_virtual/navigation", "navigation", " navigation-maps-${DEMO_MAPS_LOCALE}", "",d)}"
+DEMO_PRELOAD = "${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", " ${DEMO_PRELOAD_MAPS} poiapp-api-key", "",d)}"
# Hook for demo platform configuration
# ATM, only used to disable btwilink module on M3ULCB + Kingfisher by default,
@@ -81,7 +86,7 @@ RDEPENDS_${PN}_append = " \
${AGL_APPS} \
${AGL_APIS} \
${QTAGLEXTRAS} \
- ${MAPVIEWER} \
+ ${CLUSTER_SUPPORT} \
${DEMO_PRELOAD} \
${DEMO_PLATFORM_CONF} \
"