summaryrefslogtreecommitdiffstats
path: root/recipes-platform/packagegroups/packagegroup-hmi-framework.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-04-28 21:11:32 +0000
committerScott Murray <scott.murray@konsulko.com>2020-05-08 13:31:03 -0400
commitd11b688e620f042b4c19e3fcfa0aa9970b3624f5 (patch)
tree767bf47004567389fc9e0ae54e19e1826c0bc4f5 /recipes-platform/packagegroups/packagegroup-hmi-framework.bb
parent69d40194167df655116115f8864251594dbc8744 (diff)
Widget packaging rework
Changes include: - Add "agl-test-wgt" to IMAGE_FEATURES in the agl-demo template definition to yield the desired default behavior of the test widgets always being added to the agl-demo-platform image. - Created new devel and test packagegroup variants for several of the existing packagegroups to contain the associated widgets. - Added several services to the RDEPENDS in the definition of packagegroup-agl-ive-services that have been getting picked up by application RDEPENDS. This simplifies the test/devel packagegroup definitions. - Extend the agl-devel-wgt and agl-test-wgt FEATURE_PACKAGES variables as necessary to add the required corresponding widget packagegroups. - Shifted some non-applications and the use of packagegroup-hmi-framework around a bit in the definition of packagegroup-agl-demo-platform to improve clarity. - The alexa-viewer app and virtual/alexa-voiceagent-config package are now pulled in by extending the agl-voiceagent-alexa FEATURE_PACKAGES definition. This is a cleaner use of the image feature than the previous checking of IMAGE_FEATURES that was being done in the packagegroup-agl-demo-platform definition. Bug-AGL: SPEC-3300 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I0ace2d140fdceb1e0d778a0fe71d7f856a953ae4
Diffstat (limited to 'recipes-platform/packagegroups/packagegroup-hmi-framework.bb')
-rw-r--r--recipes-platform/packagegroups/packagegroup-hmi-framework.bb17
1 files changed, 16 insertions, 1 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-hmi-framework.bb b/recipes-platform/packagegroups/packagegroup-hmi-framework.bb
index cf704e63..f7de02c9 100644
--- a/recipes-platform/packagegroups/packagegroup-hmi-framework.bb
+++ b/recipes-platform/packagegroups/packagegroup-hmi-framework.bb
@@ -9,7 +9,13 @@ PR = "2"
inherit packagegroup
-RDEPENDS_${PN} += " \
+PROVIDES = "${PACKAGES}"
+PACKAGES = "\
+ packagegroup-hmi-framework \
+ packagegroup-hmi-framework-devel \
+ "
+
+RDEPENDS_${PN} = " \
agl-service-windowmanager \
agl-service-homescreen \
homescreen \
@@ -21,3 +27,12 @@ RDEPENDS_${PN} += " \
hmi-debug \
launcher \
"
+
+# NOTE: Currently no coverage versions of these widgets, they should
+# be added here when available.
+RDEPENDS_${PN}-devel = " \
+ agl-service-windowmanager-dbg \
+ agl-service-homescreen-dbg \
+ homescreen-dbg \
+ launcher-dbg \
+"