summaryrefslogtreecommitdiffstats
path: root/recipes-platform
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-05-30 16:52:16 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-05-31 09:55:31 +0000
commit1fb690465a3704a7a492495ff2606c4edb46b902 (patch)
treebcbb72bfab3575877b5df727fac8a973166ce110 /recipes-platform
parenta87c7d82262ba9e88f589acfa8c92f2b6076c0eb (diff)
Add KUKSA.val databroker
Add a recipe for the KUKSA.val databroker, a Rust implementation of a VSS server with gRPC APIs, and add it to the images that currently have the C++ kuksa-val server to ease further integration development. Since the databroker listens for gRPC API requests on a different port than the C++ server, there is no conflict during this period. Users wanting to drive CAN data into the databroker for testing will have to manually update the kuksa-dbc-feeder configuration during this interim period. Changes: - Bump common KUKSA.val SRCREV to pick up some improvements. - Add kuksa-databroker recipe to build the databroker. - Add kuksa-databroker-agl recipe to install AGL-specific configuration for the databroker, similar to what has previously been done with kuksa-val-agl for the C++ server. - Add missing branch node declarations in the AGL VSS overlay, as the databroker VSS parser is stricter and treats their absence as an error. - Add the kuksa-databroker, kuksa-databroker-agl, and the kuksa-databroker-cli packages to the appropriate packagegroups and images. Some follow up work will factor out a packagegroup for the KUKSA.val packages to make future changes easier. Bug-AGL: SPEC-4762 Change-Id: Ie7837b7e42a2283914adc913b75639fcb83029a6 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-platform')
-rw-r--r--recipes-platform/images/agl-cluster-demo-platform-flutter.bb3
-rw-r--r--recipes-platform/images/agl-image-ivi.bb1
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb7
3 files changed, 11 insertions, 0 deletions
diff --git a/recipes-platform/images/agl-cluster-demo-platform-flutter.bb b/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
index 4f3dfbc4..1467c315 100644
--- a/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
+++ b/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
@@ -11,10 +11,13 @@ IMAGE_FEATURES += "splash package-management ssh-server-openssh"
# running the full stack locally.
IMAGE_KUKSA_PACKAGES = " \
kuksa-val \
+ kuksa-databroker \
kuksa-val-agl \
+ kuksa-databroker-agl \
kuksa-certificates-agl \
kuksa-dbc-feeder \
kuksa-vss-init \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'kuksa-databroker-cli' , '', d)} \
"
# generic
diff --git a/recipes-platform/images/agl-image-ivi.bb b/recipes-platform/images/agl-image-ivi.bb
index 30043fdf..b5cf0a54 100644
--- a/recipes-platform/images/agl-image-ivi.bb
+++ b/recipes-platform/images/agl-image-ivi.bb
@@ -9,6 +9,7 @@ require recipes-platform/images/agl-image-weston.inc
IMAGE_INSTALL:append = "\
packagegroup-agl-image-ivi \
packagegroup-agl-ivi-services \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'packagegroup-agl-ivi-services-devel' , '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'packagegroup-pipewire', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'wireplumber-config-agl wireplumber-policy-config-agl', '', d)} \
can-utils \
diff --git a/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb b/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb
index 0b1cf576..e010adad 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb
@@ -5,11 +5,14 @@ inherit packagegroup
PACKAGES = "\
packagegroup-agl-ivi-services \
+ packagegroup-agl-ivi-services-devel \
"
RDEPENDS:${PN} += "\
kuksa-val \
+ kuksa-databroker \
kuksa-val-agl \
+ kuksa-databroker-agl \
kuksa-certificates-agl \
kuksa-dbc-feeder \
kuksa-vss-init \
@@ -17,3 +20,7 @@ RDEPENDS:${PN} += "\
agl-service-audiomixer \
agl-service-radio \
"
+
+RDEPENDS:${PN}-devel += "\
+ kuksa-databroker-cli \
+ "