summaryrefslogtreecommitdiffstats
path: root/recipes-platform
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-12-20 14:24:30 -0500
committerScott Murray <scott.murray@konsulko.com>2022-12-29 04:23:22 +0000
commit2026e365a98e57c319f319e746d307fc94b97a12 (patch)
treed75f070b2134e8b1e475df2803fff840be614968 /recipes-platform
parent56f1eaaa7b445fdc2009f712e45ae87db9cab731 (diff)
Rework cluster demo configuration
Changes: - Rename cluster-dashboard-demo-config to cluster-demo-config since the installed AGL.conf will also be used for receiver configuration now. - Add a Flutter cluster version of AGL.conf that configures the receiver window geometry as required. The alternative mechanism is used to generate separate packages with the different AGL.conf files. - Update the package names installed by agl-demo-preload in the Qt and Flutter cluster demo images. It may make sense to do further rework in the dashboard and receiver apps post-CES to split things into separate configuration files, but this seems the most straightforward way to do things for now. Bug-AGL: SPEC-4640 Change-Id: If8a65228c75f28a53ef32a49be90f75a85d60a16 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-platform')
-rw-r--r--recipes-platform/images/agl-cluster-demo-platform-flutter.bb1
-rw-r--r--recipes-platform/images/agl-cluster-demo-platform.bb2
2 files changed, 2 insertions, 1 deletions
diff --git a/recipes-platform/images/agl-cluster-demo-platform-flutter.bb b/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
index a14560c7..2670bac2 100644
--- a/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
+++ b/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
@@ -32,6 +32,7 @@ IMAGE_INSTALL:append = "\
# Flutter
IMAGE_INSTALL:append = "\
flutter-cluster-dashboard \
+ ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "cluster-demo-config-flutter", "", d)} \
${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "flutter-cluster-dashboard-conf-demo", "flutter-cluster-dashboard-conf", d)} \
flutter-auto-runtimerelease \
"
diff --git a/recipes-platform/images/agl-cluster-demo-platform.bb b/recipes-platform/images/agl-cluster-demo-platform.bb
index d5c92742..f11d883c 100644
--- a/recipes-platform/images/agl-cluster-demo-platform.bb
+++ b/recipes-platform/images/agl-cluster-demo-platform.bb
@@ -13,6 +13,6 @@ REQUIRED_DISTRO_FEATURES = "wayland"
# add packages for cluster demo platform (include demo apps) here
IMAGE_INSTALL:append = " \
packagegroup-agl-cluster-demo-platform \
- ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "cluster-dashboard-demo-config", "", d)} \
+ ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "cluster-demo-config", "", d)} \
${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
"