summaryrefslogtreecommitdiffstats
path: root/recipes-platform
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-09-25 10:55:27 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-09-27 12:27:30 +0000
commit205758c8d7be87386ab094c0d8b76aa831ef8837 (patch)
tree44e8af985fee21888aa7822a9443bd7b5e8ee155 /recipes-platform
parent888f57114cc7913c56334a1a4a2bcb7af37babba (diff)
agl-cluster-demo-platform: Add databroker by default
Pull the KUKSA.val databroker into the agl-cluster-demo-platform when building without the agl-demo-preload feature. This matches the behavior of the Flutter cluster demo image, and enables using the image for standalone testing. Bug-AGL: SPEC-4845 Change-Id: I8bc295858a28ea5cb842b01c5d58b59e3dc1e826 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29246 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-platform')
-rw-r--r--recipes-platform/images/agl-cluster-demo-platform.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes-platform/images/agl-cluster-demo-platform.bb b/recipes-platform/images/agl-cluster-demo-platform.bb
index f0b04a6b..385d7809 100644
--- a/recipes-platform/images/agl-cluster-demo-platform.bb
+++ b/recipes-platform/images/agl-cluster-demo-platform.bb
@@ -10,10 +10,19 @@ inherit features_check
REQUIRED_DISTRO_FEATURES = "wayland"
+# Break out KUKSA.val packages, as demo unit configuration
+# points at KUKSA.val server on the IVI board in full demo
+# builds with the "agl-demo-preload" feature enabled.
+IMAGE_KUKSA_PACKAGES = " \
+ packagegroup-agl-kuksa-val-databroker \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'packagegroup-agl-kuksa-val-databroker-devel' , '', d)} \
+"
+
# add packages for cluster demo platform (include demo apps) here
IMAGE_INSTALL += " \
packagegroup-agl-cluster-demo-platform \
${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "cluster-demo-config", "", d)} \
${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
+ ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "${IMAGE_KUKSA_PACKAGES}", d)} \
${@bb.utils.contains("AGL_FEATURES", "AGLCI", "qemu-set-display", "", d)} \
"