summaryrefslogtreecommitdiffstats
path: root/recipes-platform
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2017-10-12 14:58:03 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-10-12 20:53:26 +0000
commit4fd6eb328820d7f6657c223bf1b1a19e8c864a03 (patch)
treec6335ec1201267d5b4f5a51f4a0c7ac05dc4a271 /recipes-platform
parente3a4827db9283ec9a037d76e225cb4d32fb46f00 (diff)
SDK: add native+target packages to build chromium
This adds the following recipes/adjustements: * recipes-devtools/gn (copied from https://github.com/Igalia/meta-browser, branch ozone/wayland/20170928, rev a01cf92) * recipes-devtools/ninja * recipes-extended/gperf Bug-AGL: SPEC-942 Change-Id: Ibc34a055ead85aeea24c66665655c9070b47d032 Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
Diffstat (limited to 'recipes-platform')
-rw-r--r--recipes-platform/images/agl-demo-platform-crosssdk.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-platform/images/agl-demo-platform-crosssdk.bb b/recipes-platform/images/agl-demo-platform-crosssdk.bb
index 71ba5bab..6df95216 100644
--- a/recipes-platform/images/agl-demo-platform-crosssdk.bb
+++ b/recipes-platform/images/agl-demo-platform-crosssdk.bb
@@ -17,3 +17,30 @@ inherit populate_sdk populate_sdk_qt5
# Both exec "createrepo" on the same directory, and so one of them
# can failed (randomly).
addtask do_populate_sdk after do_rootfs
+
+# native tools to support Chromium build inside SDK (SPEC-942)
+TOOLCHAIN_HOST_TASK += " \
+ nativesdk-gn \
+ nativesdk-ninja \
+ nativesdk-gperf \
+ nativesdk-zlib \
+ nativesdk-xz \
+ nativesdk-nspr-dev \
+ nativesdk-nss-dev \
+ "
+
+# required dependencies for Chromium build inside SDK (SPEC-942)
+TOOLCHAIN_TARGET_TASK += " \
+ pciutils-dev \
+ pulseaudio-dev \
+ cairo-dev \
+ nss-dev \
+ cups-dev \
+ gconf-dev \
+ libexif-dev \
+ pango-dev \
+ libdrm-dev \
+ libssp-dev \
+ ffmpeg-dev \
+ "
+