summaryrefslogtreecommitdiffstats
path: root/recipes-platform
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-07-27 19:41:59 -0400
committerScott Murray <scott.murray@konsulko.com>2022-07-27 19:46:37 -0400
commit7e0e397f3c6c91f3cdaae237f9e0d37046cabbd8 (patch)
tree76259d74a9fc2cc4ab625fd7534b0162238a2edc /recipes-platform
parent731adc93b2fed74bc4410dff510fb019d10f253f (diff)
Add agl-ivi-demo-platform-flutter image
Add an image for testing Flutter applications. At present it uses the Qt demo homescreen and launcher until they can be replaced with a Flutter homescreen with equivalent functionality. To allow testing agl-compositor behavior, the packagegroup for the image includes the demo Qt HVAC and dashboard apps in addition to the Flutter "gallery" demo application packaged for launching with applaunchd. The "agl-flutter" build feature has been added as a dependency of "agl-demo" in order for the above to be buildable by default. Bug-AGL: SPEC-4485 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Idf2daa189a15e9cc4bfe2030ac6aa3f5b0331c0c
Diffstat (limited to 'recipes-platform')
-rw-r--r--recipes-platform/images/agl-ivi-demo-platform-flutter.bb9
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb34
2 files changed, 43 insertions, 0 deletions
diff --git a/recipes-platform/images/agl-ivi-demo-platform-flutter.bb b/recipes-platform/images/agl-ivi-demo-platform-flutter.bb
new file mode 100644
index 00000000..7884a2d0
--- /dev/null
+++ b/recipes-platform/images/agl-ivi-demo-platform-flutter.bb
@@ -0,0 +1,9 @@
+require agl-image-ivi.bb
+
+DESCRIPTION = "AGL Flutter based Demo Platform image"
+
+# add packages for demo platform (include demo apps) here
+IMAGE_INSTALL:append = " \
+ packagegroup-agl-demo-platform-flutter \
+"
+
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb
new file mode 100644
index 00000000..4eaeb062
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb
@@ -0,0 +1,34 @@
+SUMMARY = "The software for Flutter Demo platform of AGL IVI profile"
+DESCRIPTION = "A set of packages for AGL Flutter Demo Platform"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PROVIDES = "${PACKAGES}"
+PACKAGES = "\
+ packagegroup-agl-demo-platform-flutter \
+ "
+
+RDEPENDS:${PN} += "\
+ packagegroup-agl-image-ivi \
+ packagegroup-agl-profile-graphical-qt5 \
+ packagegroup-hmi-framework \
+ packagegroup-agl-demo \
+ "
+
+AGL_APPS = " \
+ hvac \
+ dashboard \
+ flutter-gallery-release \
+ "
+
+RDEPENDS:${PN}:append = " \
+ flutter-embedder-release \
+ launcher \
+ qtquickcontrols2-agl \
+ qtquickcontrols2-agl-style \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip mpc' , '', d)} \
+ ${AGL_APPS} \
+ psplash-portrait-config \
+ "