summaryrefslogtreecommitdiffstats
path: root/recipes-platform
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-10-30 18:21:44 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-11-06 11:53:01 +0000
commit8f24ebb0b6bd4a7181e188a8ab5aec209a1917e4 (patch)
treedd4f13d28a147f514457bb970a2326975a4072a2 /recipes-platform
parent6e5995597c93831394024e0b8431702f1e785dcb (diff)
agl-demo-control-panel: add recipe and image
Add recipe to build the agl-demo-control-panel application, and a corresponding new image recipe, agl-ivi-demo-control-panel, that yields an image that runs the control panel fullscreen on boot. Bug-AGL: SPEC-4952 Change-Id: I17d762230e48ab47de3f6214a2a9dc1f59f3a8ea Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29347 Reviewed-by: Hiroyuki Ishii <ishii.hiroyuki002@jp.panasonic.com> Reviewed-by: Lisandro Perez Meyer <lpmeyer@ics.com> ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account
Diffstat (limited to 'recipes-platform')
-rw-r--r--recipes-platform/images/agl-ivi-demo-control-panel.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-platform/images/agl-ivi-demo-control-panel.bb b/recipes-platform/images/agl-ivi-demo-control-panel.bb
new file mode 100644
index 00000000..21785cae
--- /dev/null
+++ b/recipes-platform/images/agl-ivi-demo-control-panel.bb
@@ -0,0 +1,27 @@
+require recipes-platform/images/agl-image-weston.bb
+
+SUMMARY = "AGL demo control panel image"
+
+IMAGE_FEATURES += "splash package-management ssh-server-openssh"
+
+# NOTE: The client key and certificate in kuksa-certificates-agl-client
+# seem required by kuksa-client at the moment even though client
+# certification has been deprecated upstream, this needs further
+# investigation so it can be dropped from the image.
+#
+IMAGE_KUKSA_PACKAGES = " \
+ kuksa-client \
+ kuksa-certificates-agl-ca \
+ kuksa-certificates-agl-client \
+"
+
+IMAGE_INSTALL += "\
+ packagegroup-agl-networking \
+ weston-ini-conf-landscape \
+ weston-agl-driver-conf \
+ ${IMAGE_KUKSA_PACKAGES} \
+ agl-demo-control-panel \
+ qtwayland \
+ qtwayland-plugins \
+ qtwayland-qmlplugins \
+"