summaryrefslogtreecommitdiffstats
path: root/recipes-platform
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-05-26 10:38:07 -0400
committerScott Murray <scott.murray@konsulko.com>2022-07-06 13:59:56 -0400
commitca7d98904253c7404c3e6384ebb53d922a3c538a (patch)
treed82bc0b67481bef7d64c1b15bfc7636bb58b0955 /recipes-platform
parent785dae680241b989b92725a57255b1df77486d4a (diff)
kuksa-dbc-feeder: add recipe and dependencies
Add a kuksa-dbc-feeder recipe to build the sample CAN feeder for the KUKSA.val Vehicle Information Service (VIS) server and add it to the agl-demo-platform image by adding it to packagegroup-agl-ivi-services. Local patches are applied to enable building with OpenEmbedded, make installation into standard Linux FHS locations feasible, and improve usability on target with respect to logging and error handling. These will be discussed with upstream to hopefully get them integrated. Additional changes: - Add a recipe for the required kuksa-viss-client Python module included with the KUKSA.val source tree. The module is also available via pypi.org, but keeping all the pieces in lockstep for now seems better, so it is built out of a clone of the kuksa.val repo using the same SRCREV as the server and kuksa-dbc-feeder. - Add new recipes for required Python modules: python3-argparse-addons, python3-can-j1939, python3-py-expression-eval, python3-setuptools-git-versioning These will be upstreamed to meta-python as time permits. - Add bbappend for python3-cantools to add a missing runtime dependencies discovered during testing. This will be addressed upstream in meta-python as time permits. - Add minimal DBC file and mapping configuration. At present the agl-vcar.dbc file only contains the minimum message definitions known to be required for the AGL demo platform, namely vehicle and engine speeds and the steering wheel events. - Add can-dev-helper recipe to install a systemd unit and script to ensure a CAN interface is available for testing. This is a tweaked version of what was previously used with agl-service-can-low-level. Bug-AGL: SPEC-4405 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ic48ea71761fe3767ca3c1711c60b47e0d329d9e7
Diffstat (limited to 'recipes-platform')
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb b/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb
index 5f52955e..77f832bc 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb
@@ -9,4 +9,5 @@ PACKAGES = "\
RDEPENDS:${PN} += "\
kuksa-val \
+ kuksa-dbc-feeder \
"