summaryrefslogtreecommitdiffstats
path: root/recipes-platform
diff options
context:
space:
mode:
authorJose Dapena Paz <jdapena@igalia.com>2022-02-11 16:02:54 +0100
committerJose Dapena Paz <jdapena@igalia.com>2022-03-07 14:04:06 +0100
commitd787e10f87845a06cf15d11e592af4ae69d60ee8 (patch)
treeb684a57d08ce0698c6da3c7cc105b82beb237420 /recipes-platform
parent6eb5565d73449bccd81d642d4f970f41151b56a3 (diff)
Add back HTML5 launcher to HTML5 demo
Add the web-based launcher to the HTML5 demo dropping original launcher. It includes changes to the launcher to match the new navigator.appservice API and JS injection and drops agl-js-api. Bug-AGL: SPEC-4249 Change-Id: I02a68fc81693a56aa19e213e8ee200c0ec4e3f42 Signed-off-by: Jose Dapena Paz <jdapena@igalia.com>
Diffstat (limited to 'recipes-platform')
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb7
1 files changed, 2 insertions, 5 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
index 5342f078..bb457b99 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
@@ -41,8 +41,8 @@ RDEPENDS:${PN}-devel = " \
# TODO(jdapena): replace this with HTML5 apps.
AGL_APPS = " \
dashboard \
+ html5-launcher \
html5-hvac \
- hvac \
ondemandnavi \
settings \
"
@@ -58,13 +58,10 @@ DEMO_UNIT_CONF ?= "demo-i2c-udev-conf"
# Preload only if agl-demo-preload is set
DEMO_PRELOAD = "${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "${DEMO_UNIT_CONF}", "",d)}"
-# TODO(jdapena): eventually qtquickcontrols2 components, and launcher
-# (with an HTML5 replacement)
RDEPENDS:${PN}:append = " \
- launcher \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
qtquickcontrols2-agl \
qtquickcontrols2-agl-style \
- ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
${AGL_APPS} \
${DEMO_PRELOAD} \
"