summaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-20 13:58:45 -0400
committerScott Murray <scott.murray@konsulko.com>2021-11-17 14:20:22 -0500
commit12ad591d3038db609db5290d8bbe809a34c743de (patch)
treedbbcc9a44134a012f531d48132c8803c3940bfa2 /recipes-qt
parent88c424f8b8c78dfc5520ea9be1866027df4735b8 (diff)
This is effectively a manual cherry-pick and squash of commits: 4249268041b879b3d2bae338d5de88f4f2d54b26 07f4ab8c2833ae5377b97cc9e3820bed67e539d0 from the master branch with additional review and fixups. The intent of these changes is to minimize the effort to backport fixes from the master branch, which has been updated in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4144 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I3b47f1b7d62038b314a17763d24a64f6d4e15e72
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt-cluster/qtcompositor-conf_1.0.bb4
-rw-r--r--recipes-qt/qt/qtbase_agldemo.inc2
-rw-r--r--recipes-qt/qt/qtlocation_agldemo.inc2
-rw-r--r--recipes-qt/qt/qtmultimedia_agldemo.inc6
-rw-r--r--recipes-qt/qt/qtsystems_agldemo.inc4
-rw-r--r--recipes-qt/qt/qtwayland-config_1.0.0.bb2
-rw-r--r--recipes-qt/qt/qtwayland_agldemo.inc4
7 files changed, 12 insertions, 12 deletions
diff --git a/recipes-qt/qt-cluster/qtcompositor-conf_1.0.bb b/recipes-qt/qt-cluster/qtcompositor-conf_1.0.bb
index 49111b6e8..131210897 100644
--- a/recipes-qt/qt-cluster/qtcompositor-conf_1.0.bb
+++ b/recipes-qt/qt-cluster/qtcompositor-conf_1.0.bb
@@ -29,7 +29,7 @@ KERNEL=="rgnmm", SUBSYSTEM=="misc", MODE="0660", GROUP="display", SECLABEL{smack
EOF
}
-do_install_append_imx() {
+do_install:append:imx() {
install -d ${D}${sysconfdir}/udev/rules.d
cat >>${D}${sysconfdir}/udev/rules.d/zz-dri.rules <<'EOF'
SUBSYSTEM=="gpu_class", MODE="0660", GROUP="${WESTONGROUP}", SECLABEL{smack}="*"
@@ -37,4 +37,4 @@ EOF
}
-RCONFLICTS_${PN} = "weston-init"
+RCONFLICTS:${PN} = "weston-init"
diff --git a/recipes-qt/qt/qtbase_agldemo.inc b/recipes-qt/qt/qtbase_agldemo.inc
index 7f48b4571..5e6477985 100644
--- a/recipes-qt/qt/qtbase_agldemo.inc
+++ b/recipes-qt/qt/qtbase_agldemo.inc
@@ -1 +1 @@
-PACKAGECONFIG_append = " icu fontconfig sql-sqlite"
+PACKAGECONFIG:append = " icu fontconfig sql-sqlite"
diff --git a/recipes-qt/qt/qtlocation_agldemo.inc b/recipes-qt/qt/qtlocation_agldemo.inc
index 7d112d03d..60867aef0 100644
--- a/recipes-qt/qt/qtlocation_agldemo.inc
+++ b/recipes-qt/qt/qtlocation_agldemo.inc
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/qtlocation:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/qtlocation:"
SRC_URI += "\
file://0001-mapbox-update-API-url-to-match-new-schema.patch \
diff --git a/recipes-qt/qt/qtmultimedia_agldemo.inc b/recipes-qt/qt/qtmultimedia_agldemo.inc
index a8ef5afa1..0734a3664 100644
--- a/recipes-qt/qt/qtmultimedia_agldemo.inc
+++ b/recipes-qt/qt/qtmultimedia_agldemo.inc
@@ -1,7 +1,7 @@
-FILESEXTRAPATHS_append := ":${THISDIR}/qtmultimedia"
+FILESEXTRAPATHS:append := ":${THISDIR}/qtmultimedia"
-PACKAGECONFIG_append = " gstreamer"
+PACKAGECONFIG:append = " gstreamer"
-SRC_URI_append = " \
+SRC_URI:append = " \
file://0001-metadata-image-support-with-the-data-URL-scheme-for-.patch \
"
diff --git a/recipes-qt/qt/qtsystems_agldemo.inc b/recipes-qt/qt/qtsystems_agldemo.inc
index 550c58d05..9cd33c8a1 100644
--- a/recipes-qt/qt/qtsystems_agldemo.inc
+++ b/recipes-qt/qt/qtsystems_agldemo.inc
@@ -1,3 +1,3 @@
-DEPENDS_remove = "bluez4"
+DEPENDS:remove = "bluez4"
# currently Qt5 does not support bluez5 "Nothing PROVIDES 'gconfbluez5'"
-#DEPENDS_append = "bluez5"
+#DEPENDS:append = "bluez5"
diff --git a/recipes-qt/qt/qtwayland-config_1.0.0.bb b/recipes-qt/qt/qtwayland-config_1.0.0.bb
index ae7c956d4..7c1e99bfa 100644
--- a/recipes-qt/qt/qtwayland-config_1.0.0.bb
+++ b/recipes-qt/qt/qtwayland-config_1.0.0.bb
@@ -18,4 +18,4 @@ do_install () {
sed -i -e 's/@QT_WAYLAND_DEFAULT_SHELL@/${QTWAYLAND_DEFAULT_SHELL}/' ${D}${sysconfdir}/afm/unit.env.d/qtwayland
}
-RPROVIDES_${PN} += "virtual/qtwayland-config"
+RPROVIDES:${PN} += "virtual/qtwayland-config"
diff --git a/recipes-qt/qt/qtwayland_agldemo.inc b/recipes-qt/qt/qtwayland_agldemo.inc
index 61d0393a5..b24c7b7b1 100644
--- a/recipes-qt/qt/qtwayland_agldemo.inc
+++ b/recipes-qt/qt/qtwayland_agldemo.inc
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_append := ":${THISDIR}/qtwayland"
+FILESEXTRAPATHS:append := ":${THISDIR}/qtwayland"
# QT_MODULE_BRANCH = "5.4"
@@ -12,7 +12,7 @@ FILESEXTRAPATHS_append := ":${THISDIR}/qtwayland"
# file://0002-qwaylandwindow-add-support-for-IVI-Surface-ID-proper.patch \
#
-SRC_URI_append = "\
+SRC_URI:append = "\
file://0010-Added-manifest-file-according-to-smack-3-domain-mode.patch \
file://0001-client-qwaylandintegration-Do-not-attempt-to-use-the.patch \
"