summaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2016-12-26 04:30:35 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-12-27 14:52:00 +0000
commit0a57ab1ff1bb75f529bc46ae1e96ce4d80c68979 (patch)
tree44f6cfe57d5df4c70d7f0d31aa7bb46d7345edd2 /recipes-qt
parent276f30ef24715c9c86a9b63e7406dd9a8cc93a0c (diff)
Fix blank screen after booting on some platform
wl.surface.attach (nil, 0, 0) might cause serious probrem on some platform (it depends on compositor implementation). In the case of ces2017 demo, output alwasy become blank when launch HomeScreen and WindowManager. This bug and patch is reported in https://bugreports.qt.io/browse/QTBUG-47902 Change-Id: Ibc7b20431e7aff6316090d729365b82cdfac6733 Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/qtwayland/0001-Avoid-attaching-NULL-buffer-while-hiding-EGL-windows.patch31
-rw-r--r--recipes-qt/qt5/qtwayland_%.bbappend1
2 files changed, 32 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwayland/0001-Avoid-attaching-NULL-buffer-while-hiding-EGL-windows.patch b/recipes-qt/qt5/qtwayland/0001-Avoid-attaching-NULL-buffer-while-hiding-EGL-windows.patch
new file mode 100644
index 00000000..67c4bba4
--- /dev/null
+++ b/recipes-qt/qt5/qtwayland/0001-Avoid-attaching-NULL-buffer-while-hiding-EGL-windows.patch
@@ -0,0 +1,31 @@
+From f7947e9a0e6ae99e8fd0ab3c9176885f724ac87d Mon Sep 17 00:00:00 2001
+From: Prabhu Sundararaj <prabhu.sundararaj@nxp.com>
+Date: Tue, 19 Jul 2016 12:14:26 -0500
+Subject: [PATCH] Avoid attaching NULL buffer while hiding EGL windows
+
+Incremental fix for QTBUG-46921. Destroying the callback for NULL surface is not
+working all the time. If the window is hidden by destroying the EGL surface
+and hence setting the NULL buffer is no longer required.
+
+Task-number:QTBUG-47902
+Signed-off-by: Prabhu Sundararaj <prabhu.sundararaj@nxp.com>
+---
+ src/client/qwaylandwindow.cpp | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/src/client/qwaylandwindow.cpp b/src/client/qwaylandwindow.cpp
+index 2dd58e8..24b5653 100644
+--- a/src/client/qwaylandwindow.cpp
++++ b/src/client/qwaylandwindow.cpp
+@@ -312,8 +312,6 @@ void QWaylandWindow::setVisible(bool visible)
+ QPointer<QWaylandWindow> deleteGuard(this);
+ QWindowSystemInterface::flushWindowSystemEvents();
+ if (!deleteGuard.isNull()) {
+- attach(static_cast<QWaylandBuffer *>(0), 0, 0);
+- commit();
+ if (mBackingStore) {
+ mBackingStore->hidden();
+ }
+--
+2.7.4
+
diff --git a/recipes-qt/qt5/qtwayland_%.bbappend b/recipes-qt/qt5/qtwayland_%.bbappend
index 98d7cb7c..c430e526 100644
--- a/recipes-qt/qt5/qtwayland_%.bbappend
+++ b/recipes-qt/qt5/qtwayland_%.bbappend
@@ -23,6 +23,7 @@ FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
SRC_URI_append = "\
file://0010-Added-manifest-file-according-to-smack-3-domain-mode.patch \
file://0002_expand_ivi-shell.patch \
+ file://0001-Avoid-attaching-NULL-buffer-while-hiding-EGL-windows.patch \
"
SRC_URI_append_checkforkrogoth = "\
file://disable_xcomposite_egl_qt_wayland_client_buffer_integration.patch \