summaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 15:18:49 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 22:43:56 +0100
commit1b72a0f90fa7d1b45eb1017629cc83dcd8971c48 (patch)
treedecc406f376b968d90fade3c321777e068a8c00e /recipes-qt
parent94a051785cdb588bc3a475a5490f1f286176d646 (diff)
Prepare master for new framework integration
During the last workshop the transition to the new framework was presented. This change essentially deprecates the SMACK-based application framework. To prepare the integration of it, we remove the deprecated components: - recipes-apis : all agl-service-* - recipes-demos: all demo apps but homescreen - non-essential configurations Todo: We need to bring-back the html5 image in a follow-up w/o ties into the old framework. v2: kept WAM + Chromium recipes for reference v3: rebased Bug-AGL: SPEC-4121 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I58075f5f1e477106a1aad3d2171a0904bf0cb16e
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt-cluster/qtcompositor-conf_1.0.bb40
-rw-r--r--recipes-qt/qt-qrcode/qt-qrcode/0001-rework-library-build.patch181
-rw-r--r--recipes-qt/qt-qrcode/qt-qrcode/0002-fix-dangling-pointer.patch25
-rw-r--r--recipes-qt/qt-qrcode/qt-qrcode_git.bb19
-rw-r--r--recipes-qt/qt/qtwayland_agldemo.inc1
5 files changed, 0 insertions, 266 deletions
diff --git a/recipes-qt/qt-cluster/qtcompositor-conf_1.0.bb b/recipes-qt/qt-cluster/qtcompositor-conf_1.0.bb
deleted file mode 100644
index 13121089..00000000
--- a/recipes-qt/qt-cluster/qtcompositor-conf_1.0.bb
+++ /dev/null
@@ -1,40 +0,0 @@
-SUMMARY = "Configuration files for running wayland with a non-weston compositor"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-inherit allarch agl-graphical
-
-do_configure[noexec] = "1"
-do_compile[noexec] = "1"
-
-do_install() {
- # Add a rule to ensure the 'display' user has permissions to
- # open the graphics device
- install -d ${D}${sysconfdir}/udev/rules.d
- cat >${D}${sysconfdir}/udev/rules.d/zz-dri.rules <<'EOF'
-SUBSYSTEM=="drm", MODE="0660", GROUP="${WESTONGROUP}", SECLABEL{smack}="*"
-EOF
-
- # user 'display' must also be able to access /dev/input/*
- cat >${D}${sysconfdir}/udev/rules.d/zz-input.rules <<'EOF'
-SUBSYSTEM=="input", MODE="0660", GROUP="input", SECLABEL{smack}="^"
-EOF
-
- # user 'display' must also be able to access /dev/media*, etc.
- cat >${D}${sysconfdir}/udev/rules.d/zz-remote-display.rules <<'EOF'
-SUBSYSTEM=="media", MODE="0660", GROUP="display", SECLABEL{smack}="*"
-SUBSYSTEM=="video4linux", MODE="0660", GROUP="display", SECLABEL{smack}="*"
-KERNEL=="uvcs", SUBSYSTEM=="misc", MODE="0660", GROUP="display", SECLABEL{smack}="*"
-KERNEL=="rgnmm", SUBSYSTEM=="misc", MODE="0660", GROUP="display", SECLABEL{smack}="*"
-EOF
-}
-
-do_install:append:imx() {
- install -d ${D}${sysconfdir}/udev/rules.d
- cat >>${D}${sysconfdir}/udev/rules.d/zz-dri.rules <<'EOF'
-SUBSYSTEM=="gpu_class", MODE="0660", GROUP="${WESTONGROUP}", SECLABEL{smack}="*"
-EOF
-
-}
-
-RCONFLICTS:${PN} = "weston-init"
diff --git a/recipes-qt/qt-qrcode/qt-qrcode/0001-rework-library-build.patch b/recipes-qt/qt-qrcode/qt-qrcode/0001-rework-library-build.patch
deleted file mode 100644
index 76795268..00000000
--- a/recipes-qt/qt-qrcode/qt-qrcode/0001-rework-library-build.patch
+++ /dev/null
@@ -1,181 +0,0 @@
-Rework library build
-
-Rework qmake files to build libraries out of the quickitem and widget
-code instead of sample programs. This allows using the associated
-classes without copying the source and running afoul of the LGPL
-licensing. Also add pkgconfig file generation to simplify usage, fix
-header installation, and use pkgconfig to pull in libqrencode instead
-of having to clone a copy in-tree and building it.
-
-Upstream-Status: inappropriate [embedded-specific]
-
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-
-diff --git a/lib/lib.pro b/lib/lib.pro
-index d046bc4..6b6c199 100644
---- a/lib/lib.pro
-+++ b/lib/lib.pro
-@@ -1,6 +1,9 @@
- TARGET = qtqrcode
- TEMPLATE = lib
-
-+CONFIG += link_pkgconfig create_pc create_prl no_install_prl
-+PKGCONFIG += libqrencode
-+
- DEFINES += \
- QTQRCODE_LIBRARY \
- QTQRCODE_PLUS_FEATURES
-@@ -12,7 +15,8 @@ contains(DEFINES, QTQRCODE_PLUS_FEATURES) {
- qtqrcodepainter.cpp
-
- HEADERS +=\
-- qtqrcodepainter.h
-+ qtqrcodepainter.h \
-+ QtQrCodePainter
-
- } else {
- QT -= gui
-@@ -23,16 +27,29 @@ SOURCES += \
-
- HEADERS +=\
- qtqrcode_global.h \
-- qtqrcode.h
-+ qtqrcode.h \
-+ QtQrCode
-
- INCLUDEPATH += $$PWD
-
- include(../defaults.pri)
--include(libqrencode.pri)
- # Default rules for deployment.
- include(deployment.pri)
-
- unix {
-+ headers.path = /usr/include
- target.path = /usr/lib
-- INSTALLS += target
- }
-+
-+headers.files = $$HEADERS
-+
-+INSTALLS += headers
-+
-+QMAKE_PKGCONFIG_NAME = qtqrcode
-+QMAKE_PKGCONFIG_FILE = $${QMAKE_PKGCONFIG_NAME}
-+QMAKE_PKGCONFIG_VERSION = $${VERSION}
-+QMAKE_PKGCONFIG_DESCRIPTION = A wrapper interface for qrencode for Qt
-+QMAKE_PKGCONFIG_LIBDIR = ${prefix}/lib
-+QMAKE_PKGCONFIG_INCDIR = ${prefix}/include
-+QMAKE_PKGCONFIG_REQUIRES = libqrencode
-+QMAKE_PKGCONFIG_DESTDIR = pkgconfig
-diff --git a/lib/qtqrcode.h b/lib/qtqrcode.h
-index 2a7a1ff..0830826 100644
---- a/lib/qtqrcode.h
-+++ b/lib/qtqrcode.h
-@@ -31,7 +31,7 @@
- #include <QByteArray>
- #include <QSharedDataPointer>
-
--#include "libqrencode/qrencode.h"
-+#include <qrencode.h>
-
- class QtQrCodeData;
-
-diff --git a/quickitem/quickitem.pro b/quickitem/quickitem.pro
-index ecfef1b..067dc46 100644
---- a/quickitem/quickitem.pro
-+++ b/quickitem/quickitem.pro
-@@ -1,5 +1,7 @@
--TEMPLATE = app
--TARGET = QuickItem
-+TEMPLATE = lib
-+TARGET = qtqrcode-quickitem
-+
-+CONFIG += create_pc create_prl no_install_prl
-
- QT += qml quick widgets
-
-@@ -7,7 +9,7 @@ LIBS += -L../lib -lqtqrcode
-
- DEFINES +=
-
--SOURCES += main.cpp \
-+SOURCES += \
- QtQrCodeQuickItem.cpp
-
- HEADERS += \
-@@ -21,3 +23,21 @@ QML_IMPORT_PATH =
- include(../defaults.pri)
- # Default rules for deployment.
- include(deployment.pri)
-+
-+unix {
-+ headers.path = /usr/include
-+ target.path = /usr/lib
-+}
-+
-+headers.files = $$HEADERS
-+
-+INSTALLS += headers
-+
-+QMAKE_PKGCONFIG_NAME = qtqrcode-quickitem
-+QMAKE_PKGCONFIG_FILE = $${QMAKE_PKGCONFIG_NAME}
-+QMAKE_PKGCONFIG_VERSION = $${VERSION}
-+QMAKE_PKGCONFIG_DESCRIPTION = Qt QuickItem wrapper for qt-qrcode library
-+QMAKE_PKGCONFIG_LIBDIR = ${prefix}/lib
-+QMAKE_PKGCONFIG_INCDIR = ${prefix}/include
-+QMAKE_PKGCONFIG_REQUIRES = qtqrcode
-+QMAKE_PKGCONFIG_DESTDIR = pkgconfig
-diff --git a/widget/widget.pro b/widget/widget.pro
-index 2e26a8c..63add50 100644
---- a/widget/widget.pro
-+++ b/widget/widget.pro
-@@ -1,5 +1,7 @@
--TEMPLATE = app
--TARGET = Widget
-+TEMPLATE = lib
-+TARGET = qtqrcode-widget
-+
-+CONFIG += create_pc create_prl no_install_prl
-
- greaterThan(QT_MAJOR_VERSION, 4): QT += widgets
-
-@@ -9,18 +11,28 @@ LIBS += -L../lib -lqtqrcode
-
- DEFINES +=
-
--SOURCES += main.cpp\
-- MainWindow.cpp \
-- QtQrCodeWidget.cpp
--
--HEADERS += MainWindow.hpp \
-- QtQrCodeWidget.hpp
-+SOURCES += QtQrCodeWidget.cpp
-
--FORMS += MainWindow.ui
--
--CONFIG += mobility
--MOBILITY =
-+HEADERS += QtQrCodeWidget.hpp
-
- include(../defaults.pri)
- # Default rules for deployment.
- include(deployment.pri)
-+
-+unix {
-+ headers.path = /usr/include
-+ target.path = /usr/lib
-+}
-+
-+headers.files = $$HEADERS
-+
-+INSTALLS += headers
-+
-+QMAKE_PKGCONFIG_NAME = qtqrcode-widget
-+QMAKE_PKGCONFIG_FILE = $${QMAKE_PKGCONFIG_NAME}
-+QMAKE_PKGCONFIG_VERSION = $${VERSION}
-+QMAKE_PKGCONFIG_DESCRIPTION = Qt widget wrapper for qt-qrcode library
-+QMAKE_PKGCONFIG_LIBDIR = ${prefix}/lib
-+QMAKE_PKGCONFIG_INCDIR = ${prefix}/include
-+QMAKE_PKGCONFIG_REQUIRES = qtqrcode
-+QMAKE_PKGCONFIG_DESTDIR = pkgconfig
diff --git a/recipes-qt/qt-qrcode/qt-qrcode/0002-fix-dangling-pointer.patch b/recipes-qt/qt-qrcode/qt-qrcode/0002-fix-dangling-pointer.patch
deleted file mode 100644
index 489a49ed..00000000
--- a/recipes-qt/qt-qrcode/qt-qrcode/0002-fix-dangling-pointer.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 5fc5a92e3568674a08a6e7594d050e963d0d854b Mon Sep 17 00:00:00 2001
-From: Raquel Medina <raquel.medina@konsulko.com>
-Date: Mon, 18 May 2020 19:18:00 +0200
-Subject: [PATCH] fix dangling pointer
-
-Bug-AGL: SPEC-3664
-Signed-off-by: Raquel Medina <raquel.medina@konsulko.com>
----
- lib/qtqrcode.cpp | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/lib/qtqrcode.cpp b/lib/qtqrcode.cpp
-index a7000f0..825c354 100644
---- a/lib/qtqrcode.cpp
-+++ b/lib/qtqrcode.cpp
-@@ -116,8 +116,7 @@ void QtQrCode::setBaseQrCodeData(QRcode *qrCode)
- {
- d->width = qrCode->width;
- d->data.clear();
-- // TODO: Beware it here
-- d->data = (const char *) qrCode->data;
-+ d->data = QByteArray(reinterpret_cast<const char *>(qrCode->data), d->width*d->width);
- QRcode_free(qrCode);
- }
-
diff --git a/recipes-qt/qt-qrcode/qt-qrcode_git.bb b/recipes-qt/qt-qrcode/qt-qrcode_git.bb
deleted file mode 100644
index 52f24685..00000000
--- a/recipes-qt/qt-qrcode/qt-qrcode_git.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-SUMMARY = "Qt QR code library"
-DESCRIPTION = "Qt/C++ library for encoding and visualization of data in a \
-QR Code symbol. This library consists of a Qt wrapper for libqrencode, and \
-Qt components that are able to visualize the result."
-LICENSE = "LGPLv3+"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=94a3f3bdf61243b5e5cf569fbfbbea52"
-
-DEPENDS = "qtbase qtdeclarative qtquickcontrols2 qtsvg qrencode"
-
-SRC_URI = "git://github.com/danielsanfr/qt-qrcode.git;protocol=https;branch=master \
- file://0001-rework-library-build.patch \
- file://0002-fix-dangling-pointer.patch \
- "
-SRCREV = "2d57d9c6e2341689d10f9360a16a08831a4a820b"
-
-PV = "git${SRCPV}"
-S = "${WORKDIR}/git"
-
-inherit qmake5
diff --git a/recipes-qt/qt/qtwayland_agldemo.inc b/recipes-qt/qt/qtwayland_agldemo.inc
index b24c7b7b..a02ecf0a 100644
--- a/recipes-qt/qt/qtwayland_agldemo.inc
+++ b/recipes-qt/qt/qtwayland_agldemo.inc
@@ -13,7 +13,6 @@ FILESEXTRAPATHS:append := ":${THISDIR}/qtwayland"
#
SRC_URI:append = "\
- file://0010-Added-manifest-file-according-to-smack-3-domain-mode.patch \
file://0001-client-qwaylandintegration-Do-not-attempt-to-use-the.patch \
"