summaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorChanghyeok Bae <changhyeok.bae@gmail.com>2017-06-01 07:46:15 +0000
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-09-06 13:26:25 +0200
commit23237f85ab7553403b69a003c0e8f418e9df6a1d (patch)
tree624f5c5b04bcfdd5fc7e085259bce9090d41add3 /recipes-qt
parent199f3d33307b86420dc5f127614d91914c56fab1 (diff)
Upgrade to pyro
wayland-ivi-extension: Arrange recipe - Remove unecessary variable in PACKAGECONFIG - Arrange test-path.patch to upgrade wayland-ivi-extension qtbase: Fix build error due to binutils 2.28 bug - gold linker from binutils 2.28 may produce duplicate library symbols, which makes shared libraries created with it not usable with conventional ld linker. - See https://bugs.freebsd.org/bugzilla/attachment.cgi?id=183069&action=diff weston: Change recipe version libdbus-c++: Remove recipe and add bbappend file - meta-openembedded (pyro) already has same version. - Remove PNBLACKLIST[libdbus-c++] to use this component. packagegroups / agl-demo.inc : - move inclusion of qtwebkit out of agl-demo.inc into packagegroup-agl-demo - this fixes an inclusion bug Bug-AGL: SPEC-646 Change-Id: Ia71d5f4dc881f0d8f8f24a5574c9efc0f2da6245 Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/qtbase_%.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtbase_%.bbappend b/recipes-qt/qt5/qtbase_%.bbappend
index ab6fe9a4..af2722d0 100644
--- a/recipes-qt/qt5/qtbase_%.bbappend
+++ b/recipes-qt/qt5/qtbase_%.bbappend
@@ -13,3 +13,6 @@ EXTRA_OECONF_append = ""
# '-qpa wayland-egl' set wayland-egl as default of platform plagins
PACKAGECONFIG[wayland]="-qpa wayland-egl -no-qpa-platform-guard"
+
+# Temporarily fix bug due to binutils 2.28
+QT_CONFIG_FLAGS_append = " -no-use-gold-linker"