summaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-02-13 18:57:27 -0500
committerScott Murray <scott.murray@konsulko.com>2023-02-13 18:57:27 -0500
commit2b882188bd8d5b7a0ffe46e690147b3a8adda3f7 (patch)
tree50539b32e5ecd552f280f755111d47aab65fc5af /recipes-qt
parenta9dd7c22806f6628f7510cdd4196d612310e6590 (diff)
qtlocation: remove bbappend
The qtlocation bbappend has been moved to meta-agl-core to avoid collisions when combining with meta-agl-ic-container. Bug-AGL: SPEC-4703 Change-Id: I3999ed49707de909e424ab7ecc93bda605d7e5ef Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt/qtlocation/0001-mapbox-update-API-url-to-match-new-schema.patch47
-rw-r--r--recipes-qt/qt/qtlocation_%.bbappend1
-rw-r--r--recipes-qt/qt/qtlocation_agldemo.inc14
3 files changed, 0 insertions, 62 deletions
diff --git a/recipes-qt/qt/qtlocation/0001-mapbox-update-API-url-to-match-new-schema.patch b/recipes-qt/qt/qtlocation/0001-mapbox-update-API-url-to-match-new-schema.patch
deleted file mode 100644
index ba8a991e..00000000
--- a/recipes-qt/qt/qtlocation/0001-mapbox-update-API-url-to-match-new-schema.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 58197439eade86e7efc6fe98116c0092ea429d29 Mon Sep 17 00:00:00 2001
-From: Matt Ranostay <matt.ranostay@konsulko.com>
-Date: Tue, 10 Mar 2020 13:59:58 -0700
-Subject: [PATCH] mapbox: update API url to match new schema
-
----
- src/plugins/geoservices/mapbox/qgeotilefetchermapbox.cpp | 7 ++++---
- src/plugins/geoservices/mapbox/qmapboxcommon.h | 2 +-
- 2 files changed, 5 insertions(+), 4 deletions(-)
-
-diff --git a/src/plugins/geoservices/mapbox/qgeotilefetchermapbox.cpp b/src/plugins/geoservices/mapbox/qgeotilefetchermapbox.cpp
-index 0b128556..bd2be6b6 100644
---- a/src/plugins/geoservices/mapbox/qgeotilefetchermapbox.cpp
-+++ b/src/plugins/geoservices/mapbox/qgeotilefetchermapbox.cpp
-@@ -88,12 +88,13 @@ QGeoTiledMapReply *QGeoTileFetcherMapbox::getTileImage(const QGeoTileSpec &spec)
- request.setRawHeader("User-Agent", m_userAgent);
-
- request.setUrl(QUrl(mapboxTilesApiPath +
-- ((spec.mapId() >= m_mapIds.size()) ? QStringLiteral("mapbox.streets") : m_mapIds[spec.mapId() - 1]) + QLatin1Char('/') +
-+ m_mapIds[m_mapIds.size() - 1] +
-+ QStringLiteral("/tiles/256/") +
- QString::number(spec.zoom()) + QLatin1Char('/') +
- QString::number(spec.x()) + QLatin1Char('/') +
- QString::number(spec.y()) +
-- ((m_scaleFactor > 1) ? (QLatin1Char('@') + QString::number(m_scaleFactor) + QLatin1String("x.")) : QLatin1String(".")) +
-- m_format + QLatin1Char('?') +
-+ ((m_scaleFactor > 1) ? (QLatin1Char('@') + QString::number(m_scaleFactor) + QLatin1String("x")) : QLatin1String("")) +
-+ QLatin1Char('?') +
- QStringLiteral("access_token=") + m_accessToken));
-
- QNetworkReply *reply = m_networkManager->get(request);
-diff --git a/src/plugins/geoservices/mapbox/qmapboxcommon.h b/src/plugins/geoservices/mapbox/qmapboxcommon.h
-index e60c4e83..4b2ea98d 100644
---- a/src/plugins/geoservices/mapbox/qmapboxcommon.h
-+++ b/src/plugins/geoservices/mapbox/qmapboxcommon.h
-@@ -46,7 +46,7 @@
-
- QT_BEGIN_NAMESPACE
-
--static const QString mapboxTilesApiPath = QStringLiteral("http://api.tiles.mapbox.com/v4/");
-+static const QString mapboxTilesApiPath = QStringLiteral("https://api.mapbox.com/");
-
- // https://www.mapbox.com/api-documentation/#geocoding
- static const QString mapboxGeocodingApiPath = QStringLiteral("https://api.mapbox.com/geocoding/v5/mapbox.places/");
---
-2.25.0
-
diff --git a/recipes-qt/qt/qtlocation_%.bbappend b/recipes-qt/qt/qtlocation_%.bbappend
deleted file mode 100644
index b12c4281..00000000
--- a/recipes-qt/qt/qtlocation_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'qtlocation_agldemo.inc', '', d)}
diff --git a/recipes-qt/qt/qtlocation_agldemo.inc b/recipes-qt/qt/qtlocation_agldemo.inc
deleted file mode 100644
index 60867aef..00000000
--- a/recipes-qt/qt/qtlocation_agldemo.inc
+++ /dev/null
@@ -1,14 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/qtlocation:"
-
-SRC_URI += "\
- file://0001-mapbox-update-API-url-to-match-new-schema.patch \
- "
-
-# Need to explicitly enable the various plugins
-PACKAGECONFIG += " \
- geoservices_osm \
- geoservices_here \
- geoservices_itemsoverlay \
- geoservices_mapbox \
- geoservices_mapboxgl \
-"