summaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-02-13 17:10:40 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-02-15 15:10:08 +0000
commit2de63bf50492342f59b5780bf356afaa4d2fb840 (patch)
tree125efb5b74be8f6752e3f2a3d6b9d74cb99e4fc9 /recipes-qt
parent337a2f8dd0ecbcd98bcc1d23b8912e3ed9cbc3d5 (diff)
qtwayland-config: remove recipe
Remove qtwayland-config recipe since nothing uses it, rather than rework its RPROVIDES. Bug-AGL: SPEC-5067 Change-Id: Ie6ac95319068f1bed560eb322f2625561bd6db82 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29656 Tested-by: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt/qtwayland-config/qtwayland12
-rw-r--r--recipes-qt/qt/qtwayland-config_1.0.0.bb21
2 files changed, 0 insertions, 33 deletions
diff --git a/recipes-qt/qt/qtwayland-config/qtwayland b/recipes-qt/qt/qtwayland-config/qtwayland
deleted file mode 100644
index a371c6c4..00000000
--- a/recipes-qt/qt/qtwayland-config/qtwayland
+++ /dev/null
@@ -1,12 +0,0 @@
-QT_WAYLAND_SHELL_INTEGRATION=@QT_WAYLAND_DEFAULT_SHELL@
-# The following might be necessary when multiple/split surfaces are created.
-# Without this, QtWayland will sometimes maintain the same/old size even if the
-# split surface is destroyed.
-# We keep it disabled by default as it causes an additional repaint of the
-# surface until the compositor sends a configure event to scale the window to
-# the actual area. Typical windows will, by default, have an initial size set
-# by qtwayland when starting-up (without an explicit size specified by the
-# application).
-# Note that QtWayland will only test the presence of the environment variable
-# so it will be enabled even if set to 0
-# QT_WAYLAND_RESIZE_AFTER_SWAP=1
diff --git a/recipes-qt/qt/qtwayland-config_1.0.0.bb b/recipes-qt/qt/qtwayland-config_1.0.0.bb
deleted file mode 100644
index 7c1e99bf..00000000
--- a/recipes-qt/qt/qtwayland-config_1.0.0.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-SUMMARY = "QtWayland config file."
-DESCRIPTION = "Config file for qtwayland."
-SECTION = "apps"
-LICENSE = "MIT"
-
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-
-SRC_URI = "file://qtwayland"
-
-inherit allarch
-
-QTWAYLAND_DEFAULT_SHELL ?= "xdg-shell"
-
-do_compile[noexec] = "1"
-
-do_install () {
- install -D -m 644 ${WORKDIR}/qtwayland ${D}${sysconfdir}/afm/unit.env.d/qtwayland
- sed -i -e 's/@QT_WAYLAND_DEFAULT_SHELL@/${QTWAYLAND_DEFAULT_SHELL}/' ${D}${sysconfdir}/afm/unit.env.d/qtwayland
-}
-
-RPROVIDES:${PN} += "virtual/qtwayland-config"