summaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2016-12-11 12:45:14 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-12-11 20:55:45 +0000
commit6e5735d2ee0c2ee7e556d209411bf2e001031182 (patch)
tree4060a4e8eec9d5734f161dd80309e7dfe36b8238 /recipes-qt
parent1db34ad4140536c600b8b6e8a310b066786dc38b (diff)
Add qtmultimedia radio plugin to demo images
Add qtmultimedia-rtlfm-radio-plugin recipe and add it as a dependency of the CES 2017 demo so it will go into the demo images. It is required for the Radio application. Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I764c561a8a7c864ac98240bb2f54995d29ce0934
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qtmultimedia-rtlfm-radio-plugin/qtmultimedia-rtlfm-radio-plugin_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-qt/qtmultimedia-rtlfm-radio-plugin/qtmultimedia-rtlfm-radio-plugin_git.bb b/recipes-qt/qtmultimedia-rtlfm-radio-plugin/qtmultimedia-rtlfm-radio-plugin_git.bb
new file mode 100644
index 00000000..8f50024d
--- /dev/null
+++ b/recipes-qt/qtmultimedia-rtlfm-radio-plugin/qtmultimedia-rtlfm-radio-plugin_git.bb
@@ -0,0 +1,19 @@
+SUMMARY = "QtMultimedia RTL-SDR Radio Plugin"
+DESCRIPTION = "QtMultimedia RTL-SDR Radio Plugin"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/staging/qtmultimedia-rtlfm-radio-plugin"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://rtlfmradioplugin.cpp;endline=5;md5=747a800420eac5cb6ab2cb85514d88b2"
+
+DEPENDS = "qtmultimedia pulseaudio"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/qtmultimedia-rtlfm-radio-plugin;protocol=https"
+SRCREV = "${AUTOREV}"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5
+
+FILES_${PN} += "${OE_QMAKE_PATH_PLUGINS}/mediaservice/*.so"
+FILES_${PN}-dbg += "${OE_QMAKE_PATH_PLUGINS}/mediaservice/.debug"
+
+RDEPENDS_${PN} = "rtl-sdr alsa-utils-aplay"