summaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-10-06 16:13:23 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-10-11 08:54:07 +0000
commit9b749f2f280324e2fae396bd9c24f274c3ebcf89 (patch)
tree7ab8cf2a04a8c0e1320ee7650d193c101111212e /recipes-qt
parent9879e35d670df53af43de123ce1804a7296531e1 (diff)
Don't use libegl on nogfx target board
Bug-AGL: SPEC-903 Change-Id: I4593873cc9cb0ad32ef4f377125901eee08daf04 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/qtbase_%.bbappend3
-rw-r--r--recipes-qt/qt5/qtwayland_%.bbappend2
2 files changed, 3 insertions, 2 deletions
diff --git a/recipes-qt/qt5/qtbase_%.bbappend b/recipes-qt/qt5/qtbase_%.bbappend
index af2722d0..203b3264 100644
--- a/recipes-qt/qt5/qtbase_%.bbappend
+++ b/recipes-qt/qt5/qtbase_%.bbappend
@@ -1,7 +1,8 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
DEPENDS_append_koelsch = " libegl"
-DEPENDS_append_porter = " libegl"
+#DEPENDS_append_porter = " libegl"
+DEPENDS_append_porter = " ${@base_conditional('PREFERRED_PROVIDER_virtual/egl', 'mesa', 'mesa', 'libegl', d)}"
PACKAGECONFIG_WAYLAND = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}"
PACKAGECONFIG_GL = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2', '', d)}"
diff --git a/recipes-qt/qt5/qtwayland_%.bbappend b/recipes-qt/qt5/qtwayland_%.bbappend
index ed9e3749..a6a8f00b 100644
--- a/recipes-qt/qt5/qtwayland_%.bbappend
+++ b/recipes-qt/qt5/qtwayland_%.bbappend
@@ -31,4 +31,4 @@ SRC_URI_append_checkforkrogoth = "\
DEPENDS_append_koelsch = " libegl gles-user-module"
-DEPENDS_append_porter = " libegl gles-user-module"
+DEPENDS_append_porter = " ${@base_conditional('PREFERRED_PROVIDER_virtual/egl', 'mesa', 'mesa', 'libegl gles-user-module', d)}"