summaryrefslogtreecommitdiffstats
path: root/recipes-sdl
diff options
context:
space:
mode:
authorPhong Tran <tranmanphong@gmail.com>2017-08-13 22:17:26 +0200
committerPhong Tran <tranmanphong@gmail.com>2017-08-13 22:35:17 +0200
commitb38057354fcc2e99f37bb3391d83b562faae59c2 (patch)
tree5afedc2e76debc83238f93585625565331f51df1 /recipes-sdl
parente9aab9ee0b25b679c2c038b9dbbf46d944be27e0 (diff)
agl-demo-platform: add packagegroup smartdevicelink
Add the new packagegroup name packagegroup-agl-smartdevicelink. This install to agl-demo-platform image with "agl-sdl" in DISTRO_FEATURES Tested build ok with: source meta-agl/scripts/aglsetup.sh -m raspberrypi3 agl-demo agl-netboot agl-appfw-smack agl-sdl Change-Id: I1b348affa88f0f3c1a313b2856bd38482fd8e778 Depends-On: I416d8418c0ef4fe4de5e5ce084e7b9075e64f85f Signed-off-by: Phong Tran <tranmanphong@gmail.com>
Diffstat (limited to 'recipes-sdl')
-rw-r--r--recipes-sdl/packagegroups/packagegroup-agl-smartdevicelink.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-sdl/packagegroups/packagegroup-agl-smartdevicelink.bb b/recipes-sdl/packagegroups/packagegroup-agl-smartdevicelink.bb
new file mode 100644
index 00000000..108e9b7d
--- /dev/null
+++ b/recipes-sdl/packagegroups/packagegroup-agl-smartdevicelink.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Set of packages for SmartDeviceLink"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-smartdevicelink \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ sdl-core \
+ "