summaryrefslogtreecommitdiffstats
path: root/recipes-support
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-01-16 18:14:47 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-01-29 14:29:37 +0000
commitff102f398a1baf0522c359f356c31c3f935491dd (patch)
treecdea279bd6d2d194ab01b53a32cb1d0dcb9d706b /recipes-support
parent3b3008fc244b29a1022c93dd567db73990a8c505 (diff)
rng-tools: disable jitter entropy generation in VMs
Add a bbappend for rng-tools that disables jitter entropy generation for virtio-all machines, as it provides little value in virtual machines that are dependent on the host entropy anyways, and slows their booting very significantly. Bug-AGL: SPEC-4618 Change-Id: Ia61917253b69f37b003c617d4203c823dd51bb6c Signed-off-by: Scott Murray <scott.murray@konsulko.com> (cherry picked from commit ebeba2f0667d7195597d9131a12d880d503a399a)
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/rng-tools/files/default1
-rw-r--r--recipes-support/rng-tools/rng-tools_%.bbappend1
-rw-r--r--recipes-support/rng-tools/rng-tools_agldemo.inc7
3 files changed, 9 insertions, 0 deletions
diff --git a/recipes-support/rng-tools/files/default b/recipes-support/rng-tools/files/default
new file mode 100644
index 00000000..6e2f2ca9
--- /dev/null
+++ b/recipes-support/rng-tools/files/default
@@ -0,0 +1 @@
+EXTRA_ARGS="-r /dev/hwrng -x jitter"
diff --git a/recipes-support/rng-tools/rng-tools_%.bbappend b/recipes-support/rng-tools/rng-tools_%.bbappend
new file mode 100644
index 00000000..8ec7f750
--- /dev/null
+++ b/recipes-support/rng-tools/rng-tools_%.bbappend
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'rng-tools_agldemo.inc', '', d)}
diff --git a/recipes-support/rng-tools/rng-tools_agldemo.inc b/recipes-support/rng-tools/rng-tools_agldemo.inc
new file mode 100644
index 00000000..283c8a4c
--- /dev/null
+++ b/recipes-support/rng-tools/rng-tools_agldemo.inc
@@ -0,0 +1,7 @@
+# Pick up modified default configuration for virtual machines
+# that disables jitter entropy source, as it is not useful when
+# the VMs are effectively driven by the host RNG via virtio-rng.
+# This also helps boot speed, as otherwise the guests have rngd
+# potentially somewhat pointlessly burning a lot of CPU on boot,
+# in addition to the host's own rngd.
+FILESEXTRAPATHS:prepend:virtio-all := "${THISDIR}/files:"