summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-demo/html5-homescreen/html5-homescreen_git.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes-demo/html5-homescreen/html5-homescreen_git.bb b/recipes-demo/html5-homescreen/html5-homescreen_git.bb
index 1d5f14a4..0fdd02be 100644
--- a/recipes-demo/html5-homescreen/html5-homescreen_git.bb
+++ b/recipes-demo/html5-homescreen/html5-homescreen_git.bb
@@ -17,9 +17,10 @@ SRCREV = "${AGL_APP_REVISION}"
DEPENDS = "nodejs-native"
do_compile() {
- bldcmd=${S}/autobuild/agl/autobuild
cd ${S}
- $bldcmd build
+ rm -rf package node_modules package-lock.json
+ npm install
+ npm run build
}
WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
@@ -38,4 +39,4 @@ FILES_${PN} = " \
"
RCONFLICTS_${PN} = "homescreen"
-RDEPENDS_${PN} = "applaunchd html5-background" \ No newline at end of file
+RDEPENDS_${PN} = "applaunchd html5-background"