summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xrecipes-graphics/web-runtime/web-runtime/web-runtime19
-rw-r--r--recipes-graphics/web-runtime/web-runtime_0.1.bb3
2 files changed, 20 insertions, 2 deletions
diff --git a/recipes-graphics/web-runtime/web-runtime/web-runtime b/recipes-graphics/web-runtime/web-runtime/web-runtime
index 80685eb8..ad791555 100755
--- a/recipes-graphics/web-runtime/web-runtime/web-runtime
+++ b/recipes-graphics/web-runtime/web-runtime/web-runtime
@@ -1,2 +1,17 @@
-#!/bin/sh
-exec /usr/bin/qt5/qmlscene "$1" /usr/bin/web-runtime.qml
+#!/bin/bash
+export -n QT_WAYLAND_SHELL_INTEGRATION
+port=$(echo -n "$1" | sed 's,.*local.*:\([^/]*\)/.*,\1,')
+token=$(echo -n "$1" | sed 's,.*token=,,')
+export AFM_APP_INSTALL_DIR=$(mktemp -d)
+cat << EOC > $AFM_APP_INSTALL_DIR/runxdg.toml
+[application]
+role = "WebBrowser"
+method = "POSIX"
+path = "/usr/bin/qt5/qmlscene"
+params = [
+ "$1",
+ "/usr/bin/web-runtime.qml"
+]
+EOC
+/usr/bin/runxdg "$port" "$token"
+rm -rf $AFM_APP_INSTALL_DIR
diff --git a/recipes-graphics/web-runtime/web-runtime_0.1.bb b/recipes-graphics/web-runtime/web-runtime_0.1.bb
index bdfcbecb..ea5acbbf 100644
--- a/recipes-graphics/web-runtime/web-runtime_0.1.bb
+++ b/recipes-graphics/web-runtime/web-runtime_0.1.bb
@@ -16,6 +16,9 @@ RDEPENDS_${PN} = "\
qtdeclarative-tools \
qtwayland-qmlplugins \
qtquickcontrols-qmlplugins \
+ qtwebengine \
+ runxdg \
+ bash \
"
PROVIDES += "virtual/webruntime"