summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb1
-rw-r--r--recipes-qt/qml-radio-plugin/qml-radio-plugin_0.1.bb31
2 files changed, 32 insertions, 0 deletions
diff --git a/recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb b/recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb
index 8b410f0a..e03c85b0 100644
--- a/recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb
+++ b/recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb
@@ -35,6 +35,7 @@ RDEPENDS_${PN} += "\
qtwayland-plugins \
qtwayland-tools \
qtgraphicaleffects-qmlplugins \
+ qml-radio-plugin \
"
# qtwebkit
diff --git a/recipes-qt/qml-radio-plugin/qml-radio-plugin_0.1.bb b/recipes-qt/qml-radio-plugin/qml-radio-plugin_0.1.bb
new file mode 100644
index 00000000..60360aa0
--- /dev/null
+++ b/recipes-qt/qml-radio-plugin/qml-radio-plugin_0.1.bb
@@ -0,0 +1,31 @@
+SUMMARY = "AM/FM Radio QML plugin (for RTL2832U hardware)"
+DESCRIPTION = "This provides a simple QML plugin able to detect and use radio hardware, most notable RTL2832U chipsets (although it can easily be extended). Among other things, it provides generic APIs to display status, switch between AM/FM mode, choose frequency, mute sound..."
+HOMEPAGE = "https://github.com/iotbzh/qml_radio_plugin"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
+ file://qml_radio.cpp;endline=16;md5=10a65c128e3a6cff2a61bb38556ceb04"
+
+DEPENDS = "qtbase-native qtdeclarative rtl-sdr alsa-lib"
+RDEPENDS_${PN} = "qtdeclarative-tools qtquickcontrols-qmlplugins"
+
+SRC_URI = "git://github.com/iotbzh/qml_radio_plugin"
+SRCREV = "0032dc92d1a208219a0f782b68aef7f4cbcc0028"
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-moc-dir=${STAGING_BINDIR_NATIVE}/qt5"
+
+QML_LIBDIR = "${libdir}/qt5/qml"
+
+do_install_append() {
+ # Remove .la files for loadable modules
+ rm -f ${D}/${QML_LIBDIR}/radio/*.la
+ # Install QML example
+ install -d ${D}/${datadir}/qt5/examples/radio
+ install -m 0644 ${S}/radio.qml ${D}/${datadir}/qt5/examples/radio
+}
+
+FILES_${PN} += "${QML_LIBDIR}/radio/*.so ${QML_LIBDIR}/radio/qmldir ${datadir}"
+FILES_${PN}-dbg += "${QML_LIBDIR}/radio/.debug"