summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xrecipes-platform/images/agl-demo-platform-crosssdk.bb4
-rw-r--r--templates/feature/agl-demo/50_bblayers.conf.inc6
2 files changed, 10 insertions, 0 deletions
diff --git a/recipes-platform/images/agl-demo-platform-crosssdk.bb b/recipes-platform/images/agl-demo-platform-crosssdk.bb
index 5bb0dc06..ed3bcb76 100755
--- a/recipes-platform/images/agl-demo-platform-crosssdk.bb
+++ b/recipes-platform/images/agl-demo-platform-crosssdk.bb
@@ -48,3 +48,7 @@ TOOLCHAIN_TARGET_TASK += "libstdc++-staticdev"
# AddressSanitizer support to detect use-after-frees along with other
# memory issue.
TOOLCHAIN_TARGET_TASK += "gcc-sanitizers"
+
+# Add azure-iot-sdk-c to support building agl-service-cloudproxy and
+# other users of Azure sdk.
+TOOLCHAIN_TARGET_TASK += "azure-iot-sdk-c"
diff --git a/templates/feature/agl-demo/50_bblayers.conf.inc b/templates/feature/agl-demo/50_bblayers.conf.inc
index 7e85c574..afa14f23 100644
--- a/templates/feature/agl-demo/50_bblayers.conf.inc
+++ b/templates/feature/agl-demo/50_bblayers.conf.inc
@@ -3,3 +3,9 @@
BBLAYERS =+ " \
${METADIR}/meta-agl-demo \
"
+
+# OpenEmbedded layer to add support for multiple cloud service provider solutions
+#---------------------------------------------------
+BBLAYERS =+ " \
+ ${METADIR}/external/meta-iot-cloud \
+"