summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-demo/webapp-samples/files/webapps-jitsi.desktop11
-rw-r--r--recipes-demo/webapp-samples/html5-jitsi_git.bb11
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb1
3 files changed, 23 insertions, 0 deletions
diff --git a/recipes-demo/webapp-samples/files/webapps-jitsi.desktop b/recipes-demo/webapp-samples/files/webapps-jitsi.desktop
new file mode 100644
index 00000000..63a1043f
--- /dev/null
+++ b/recipes-demo/webapp-samples/files/webapps-jitsi.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Name=HTML5 Jitsi
+Comment=Jitsi
+GenericName=Jitsi
+Exec=/usr/bin/WebAppMgr --appid=webapps-jitsi --app-install-dir=/usr/lib/wam_apps/html5-jitsi/
+Icon=settings
+Terminal=false
+Type=Application
+Categories=System;
+StartupNotify=true
diff --git a/recipes-demo/webapp-samples/html5-jitsi_git.bb b/recipes-demo/webapp-samples/html5-jitsi_git.bb
new file mode 100644
index 00000000..4c92e46b
--- /dev/null
+++ b/recipes-demo/webapp-samples/html5-jitsi_git.bb
@@ -0,0 +1,11 @@
+SUMMARY = "AGL HTML5 Jitsi"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7ea5dd8751060d9f04d2748030c547ed"
+DESKTOP_FILE = "webapps-jitsi.desktop"
+
+require webapp-samples.inc
+
+do_install:append() {
+ cp -R --no-dereference --preserve=mode,links ${S}/jitsi/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+}
+
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
index 53159ba3..5fe6ec9e 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
@@ -27,6 +27,7 @@ AGL_APPS = " \
html5-settings \
html5-aquarium \
html5-youtube \
+ html5-jitsi \
"
RDEPENDS:${PN}:append = " \