summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/multiconfig/agl-kvm-guest.conf2
-rw-r--r--recipes-platform/images/agl-kvm-demo-platform.bb5
2 files changed, 2 insertions, 5 deletions
diff --git a/conf/multiconfig/agl-kvm-guest.conf b/conf/multiconfig/agl-kvm-guest.conf
index b13630db..478bc5ff 100644
--- a/conf/multiconfig/agl-kvm-guest.conf
+++ b/conf/multiconfig/agl-kvm-guest.conf
@@ -4,7 +4,7 @@ MACHINE = "virtio-aarch64"
# Avoid parse errors caused by linux-renesas, and all the other
# random bbappends in meta-rcar-gen3.
-BBMASK += "meta-rcar-gen3/ meta-agl-refhw-gen3/"
+BBMASK += "meta-rcar-gen3/ meta-rcar-gen3-adas/ meta-agl-refhw-gen3/"
DISTRO_FEATURES:append = " kvm virtualization"
diff --git a/recipes-platform/images/agl-kvm-demo-platform.bb b/recipes-platform/images/agl-kvm-demo-platform.bb
index d04186b2..378ea832 100644
--- a/recipes-platform/images/agl-kvm-demo-platform.bb
+++ b/recipes-platform/images/agl-kvm-demo-platform.bb
@@ -36,9 +36,6 @@ GUEST_IMAGES ?= "agl-kvm-guest:${GUEST_VM1_IMAGE} agl-kvm-guest:${GUEST_VM2_IMAG
QEMU_GUEST_CONFIGS ?= ""
-# Handle modification of IMAGE_LINK_NAME done by ULCB builds with Kingfisher support
-MACHINE_SUFFIX = "${@bb.utils.contains('AGL_FEATURES', 'kingfisher', '-kf', '', d)}"
-
python __anonymous() {
for c in (d.getVar('GUEST_IMAGES') or "").split():
(mc, image) = c.split(':')
@@ -56,7 +53,7 @@ install_guest_images() {
name=${image}
rm -rf ${IMAGE_ROOTFS}/var/lib/machines/${name}
install -m 0755 -d ${IMAGE_ROOTFS}/var/lib/machines/${name}
- src="${TOPDIR}/tmp-${config}/deploy/images/${GUEST_MACHINE}/${image}-${GUEST_MACHINE}${MACHINE_SUFFIX}.ext4"
+ src="${TOPDIR}/tmp-${config}/deploy/images/${GUEST_MACHINE}/${image}-${GUEST_MACHINE}.ext4"
bbnote "Installing ${src}"
install -m 0600 ${src} ${IMAGE_ROOTFS}/var/lib/machines/${name}/
# Placeholder until booting from kernel in VM image is worked out