summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-demo/html5-settings/files/webapps-settings.desktop11
-rw-r--r--recipes-demo/html5-settings/html5-settings_git.bb42
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb2
3 files changed, 54 insertions, 1 deletions
diff --git a/recipes-demo/html5-settings/files/webapps-settings.desktop b/recipes-demo/html5-settings/files/webapps-settings.desktop
new file mode 100644
index 00000000..d1081bf4
--- /dev/null
+++ b/recipes-demo/html5-settings/files/webapps-settings.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Name=HTML5 Settings
+Comment=Settings
+GenericName=Settings
+Exec=/usr/bin/WebAppMgr --appid=webapps-settings --app-install-dir=/usr/lib/wam_apps/html5-settings/
+Icon=settings
+Terminal=false
+Type=Application
+Categories=System;
+StartupNotify=true
diff --git a/recipes-demo/html5-settings/html5-settings_git.bb b/recipes-demo/html5-settings/html5-settings_git.bb
new file mode 100644
index 00000000..edbd80f2
--- /dev/null
+++ b/recipes-demo/html5-settings/html5-settings_git.bb
@@ -0,0 +1,42 @@
+SUMMARY = "AGL HTML5 settings Application"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-settings/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+
+SRC_URI = " \
+ git://gerrit.automotivelinux.org/gerrit/apps/html5-settings;protocol=https;branch=master \
+ file://webapps-settings.desktop \
+"
+SRCREV = "69af4d9b9b209fcb33ef9071ddfa8561106044c2"
+
+inherit pythonnative
+
+DEPENDS = "nodejs-native"
+
+do_compile[network] = "1"
+do_compile() {
+ cd ${S}
+ rm -rf package node_modules package-lock.json
+ npm install
+ npm run build
+}
+
+WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
+APPLICATIONS_DIR="${datadir}/applications"
+
+do_install() {
+ install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ install -d ${D}${APPLICATIONS_DIR}
+ install ${WORKDIR}/webapps-settings.desktop ${D}${APPLICATIONS_DIR}
+}
+
+FILES:${PN} = " \
+ ${WAM_APPLICATIONS_DIR}/${PN} \
+ ${APPLICATIONS_DIR} \
+"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
index 056faa01..d91c96ef 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
@@ -35,7 +35,7 @@ AGL_APPS = " \
html5-homescreen \
html5-hvac \
ondemandnavi \
- settings \
+ html5-settings \
"
# TODO(jdapena): review if we still need the demo-i2c stuff.